Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219186 - /dev-lisp/clisp-2.43-r1 : error: `CPPFLAGS' has changed during compilation
Summary: /dev-lisp/clisp-2.43-r1 : error: `CPPFLAGS' has changed during compilation
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Common Lisp Bugs
Depends on:
Reported: 2008-04-24 19:31 UTC by Sasha Medvedev
Modified: 2008-04-29 08:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sasha Medvedev 2008-04-24 19:31:34 UTC
When I update clisp from 2.41 version I get the following error :

../src/lndir ../modules/i18n i18n
m=`cd ../modules/i18n; pwd`; \
	if test -f i18n/configure -a i18n/configure -nt i18n/config.status ; then cd i18n ; \
	  ( cache=`echo i18n/ | sed -e 's,[^/][^/]*//*,../,g'`config.cache; \
	    if test -f ${cache} ; then . ${cache}; \
	      if test "${ac_cv_env_CC_set}" = set; then CC="${ac_cv_env_CC_value}"; export CC; fi; \
	      if test "${ac_cv_env_CFLAGS_set}" = set; then CFLAGS="${ac_cv_env_CFLAGS_value}"; export CFLAGS; fi; \
	      /bin/sh ./configure --cache-file=${cache} --srcdir=$m --with-dynamic-ffi;\
	    else /bin/sh ./configure --srcdir=$m --with-dynamic-ffi; \
	    fi ) ;\
configure: loading cache ../config.cache
configure: error: `CPPFLAGS' has changed since the previous run:
configure:   former value:  -O2 -march=prescott -pipe -fomit-frame-pointer
configure:   current value: -O2 -march=prescott -pipe -fomit-frame-pointer 
configure: error: changes in the environment can compromise the build
configure: error: run `make distclean' and/or `rm ../config.cache' and start over
make: *** [i18n] Ошибка 1

It seems this bug is i18n module specific.
May be somebody know how this portage module can be disabled?

Reproducible: Always

# emrge --info

Portage (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r1-A4 i686)
System uname: 2.6.25-gentoo-r1-A4 i686 Intel(R) Core(TM)2 CPU 4400 @ 2.00GHz
Timestamp of tree: Wed, 23 Apr 2008 01:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CPPFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/mozilla /usr/portage/local/layman/x11 /usr/portage/local/layman/science /usr/portage/local/rusxmms /usr/local/portage"
USE="7zip X a52 aac acpi alsa amrnb amrwb bash-completion bzip2 cairo cdr chm cli cpufreq cracklib crypt cups dbus djvu dri dvd dvdr dvdread encode exif fbcon ffmpeg firefox flac fortran gdbm gif glitz gpm gtk hal hddtemp htmlhandbook iconv id3tag idn isdnlog javascript jbig jpeg jpeg2k latex lcms lirc lm_sensors logitech-mouse mad madwifi midi mmx mmxext mp3 mpeg mudflap musepack ncurses nls nptl nptlonly ocaml ogg openmp pam pcre pdf png pppd qt4 radio rcc readline reflection samba scanner session smp spell spl sse sse2 ssl ssse3 startup-notification svg tcpd tetex tiff truetype type1 unicode usb userlocales v4l2 vorbis wifi win32codecs wma x264 x86 xcomposite xorg xv xvid xvmc zip zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="wacom evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="radeon vesa fbdev"
Comment 1 Marijn Schouten (RETIRED) gentoo-dev 2008-04-24 20:41:31 UTC
not sure what's going on, but you could give the ebuild from bug 218739 a try
Comment 2 Sasha Medvedev 2008-04-25 09:15:31 UTC
Ebuild from bug 218739 give the same result.
I've tried to remove i18n module from ebuild and have the same error.
Comment 3 Stelian Ionescu 2008-04-25 17:27:03 UTC
Please unset $CPPFLAGS and retry the compilation. The contents of your $CPPFLAGS are erroneous, because those are flags valid for the compiler, not for the preprocessor.
Comment 4 Sasha Medvedev 2008-04-29 07:11:04 UTC
I unset $CPPFLAGS and compilation works for me now.
So, should I change bug status to INVALID?
Is this my mistake or ebuild?
May be somebody explain me why this flags are invalid or somebody give me a link.
Comment 5 Stelian Ionescu 2008-04-29 07:26:03 UTC
If you read the cpp(1) manpage you'll see that none of the flags you have in $CPPFLAGS are valid for the preprocessor. The only reason why you've never noticed this problem is that almost all programs don't separate preprocessing from compilation and just pass those flags to gcc. The solution is not to even set $CPPFLAGS unless you know well what you're doing.
Comment 6 Sasha Medvedev 2008-04-29 08:35:18 UTC