Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218831 - net-libs/libcapsinetwork-0.3.0 fails w/ gcc-4.3.0
Summary: net-libs/libcapsinetwork-0.3.0 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-22 04:59 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-05-04 09:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libcapsinetwork-0.3.0-gcc43.patch (libcapsinetwork-0.3.0-gcc43.patch,1.55 KB, patch)
2008-04-22 05:00 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-22 04:59:37 UTC
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/net-libs/libcapsinetwork-0.3.0/work/libcapsinetwork-0.3.0'
Making all in src
make[2]: Entering directory `/var/tmp/portage/net-libs/libcapsinetwork-0.3.0/work/libcapsinetwork-0.3.0/src'
source='listener.cpp' object='listener.lo' libtool=yes \
        depfile='.deps/listener.Plo' tmpdepfile='.deps/listener.TPlo' \
        depmode=gcc3 /bin/bash ../depcomp \
        /bin/bash ../libtool --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..     -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -c -o listener.lo `test -f listener.cpp || echo './'`listener.cpp
mkdir .libs
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -c listener.cpp -MT listener.lo -MD -MP -MF .deps/listener.TPlo  -fPIC -DPIC -o .libs/listener.o
listener.cpp: In member function 'void Listener::checkActivity()':
listener.cpp:103: error: 'exit' was not declared in this scope
make[2]: *** [listener.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-libs/libcapsinetwork-0.3.0/work/libcapsinetwork-0.3.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-libs/libcapsinetwork-0.3.0/work/libcapsinetwork-0.3.0'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-22 05:00:17 UTC
Created attachment 150562 [details, diff]
libcapsinetwork-0.3.0-gcc43.patch

Fixes the problem. Snatched from Debian.
Comment 2 Samuli Suominen gentoo-dev 2008-05-04 09:58:37 UTC
(In reply to comment #1)
> Created an attachment (id=150562) [edit]
> libcapsinetwork-0.3.0-gcc43.patch
> 
> Fixes the problem. Snatched from Debian.
> 

Thanks. Since I'm using 64bit arch (amd64) I've stolen the 64bit fix from Debian too, and since we did force -j1 for emake, and Debian had a fix for that too.. :-)

 04 May 2008; Samuli Suominen <drac@gentoo.org>
  +files/libcapsinetwork-0.3.0-64bit.patch,
  +files/libcapsinetwork-0.3.0-gcc43.patch,
  +files/libcapsinetwork-0.3.0-parallel.patch, libcapsinetwork-0.3.0.ebuild:
  Fix server busy loop with 64bit architectures. Fix parallel make. Fix
  building with GCC 4.3 wrt #218831, thanks to Peter Alfredsen. Also, run
  full eautoreconf to fix obscure compile failure where _init gets
  redefined.