Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218814 - net-im/licq-1.3.5 fails w/ gcc-4.3.0
Summary: net-im/licq-1.3.5 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-21 23:06 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-07-04 15:20 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
licq-1.3.5-gcc43.patch (licq-1.3.5-gcc43.patch,2.46 KB, patch)
2008-04-21 23:10 UTC, Peter Alfredsen (RETIRED)
Details | Diff
licq-1.3.5-gcc43-ebuild.patch (licq-1.3.5-gcc43-ebuild.patch,1.21 KB, patch)
2008-04-21 23:11 UTC, Peter Alfredsen (RETIRED)
Details | Diff
extended licq-1.3.5-gcc43.patch with more '#include <climits>'s (licq-1.3.5-gcc43.patch,3.39 KB, patch)
2008-06-21 14:12 UTC, Petr Zima
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 23:06:58 UTC
checking for inet_addr... yes
checking for inet_aton... yes
checking for strerror... yes
checking vector.h usability... no
checking vector.h presence... no
checking for vector.h... no
configure: error: You need to have the libstdc++ headers installed


Reproducible: Always
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 23:10:40 UTC
Created attachment 150547 [details, diff]
licq-1.3.5-gcc43.patch

Fixes the problem. Snatched from Fedora and included fix for email plugin also.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 23:11:42 UTC
Created attachment 150549 [details, diff]
licq-1.3.5-gcc43-ebuild.patch

Patch for ebuild -- autoconf needs to be rerun.
Comment 3 Petr Zima 2008-06-21 14:12:20 UTC
Created attachment 157925 [details, diff]
extended licq-1.3.5-gcc43.patch with more '#include <climits>'s

The patch should add '#include <climits>' line also to forwarder.cpp and rms.cpp. Otherwise compilation fails on undefined INT_MAX on my system (gcc-4.3.1, glibc-2.8_p20080602, paludis-0.26.2). I will provide more details if necessary.
Comment 4 Santiago M. Mola (RETIRED) gentoo-dev 2008-07-04 15:20:06 UTC
Fixed in 1.3.5-r1. Thanks for the patches!