Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218782 - dev-libs/libofx-0.9.0 fails w/ gcc-4.3.0
Summary: dev-libs/libofx-0.9.0 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gilles Dartiguelongue
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-21 20:34 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-07-13 10:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libofx-0.9.0-gcc43.patch (libofx-0.9.0-gcc43.patch,14.35 KB, patch)
2008-04-21 20:35 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 20:34:29 UTC
if /bin/bash ../libtool --tag=CXX --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..  -I. -I../inc -I/usr/include/OpenSP -DMAKEFILE_DTD_PATH=\"/usr/share/libofx/dtd/\"   -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -MT ofx_utilities.lo -MD -MP -MF ".deps/ofx_utilities.Tpo" -c -o ofx_utilities.lo ofx_utilities.cpp; \
        then mv -f ".deps/ofx_utilities.Tpo" ".deps/ofx_utilities.Plo"; else rm -f ".deps/ofx_utilities.Tpo"; exit 1; fi
mkdir .libs
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../inc -I/usr/include/OpenSP -DMAKEFILE_DTD_PATH=\"/usr/share/libofx/dtd/\" -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -MT ofx_utilities.lo -MD -MP -MF .deps/ofx_utilities.Tpo -c ofx_utilities.cpp  -fPIC -DPIC -o .libs/ofx_utilities.o
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../inc -I/usr/include/OpenSP -DMAKEFILE_DTD_PATH=\"/usr/share/libofx/dtd/\" -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -MT messages.lo -MD -MP -MF .deps/messages.Tpo -c messages.cpp  -fPIC -DPIC -o .libs/messages.o
ofx_utilities.cpp: In function 'time_t ofxdate_to_time_t(std::string)':
ofx_utilities.cpp:116: error: 'time' is not a member of 'std'
ofx_utilities.cpp:120: error: 'atoi' was not declared in this scope
ofx_utilities.cpp:139: error: 'atof' was not declared in this scope
ofx_utilities.cpp: In function 'double ofxamount_to_double(std::string)':
ofx_utilities.cpp:189: error: 'atof' was not declared in this scope
ofx_utilities.cpp: In function 'int mkTempFileName(const char*, char*, unsigned int)':
ofx_utilities.cpp:222: error: 'getenv' was not declared in this scope
make[2]: *** [ofx_utilities.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../inc -I/usr/include/OpenSP -DMAKEFILE_DTD_PATH=\"/usr/share/libofx/dtd/\" -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -MT messages.lo -MD -MP -MF .deps/messages.Tpo -c messages.cpp -o messages.o >/dev/null 2>&1
make[2]: Leaving directory `/var/tmp/portage/dev-libs/libofx-0.9.0/work/libofx-0.9.0/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/libofx-0.9.0/work/libofx-0.9.0'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 20:35:27 UTC
Created attachment 150530 [details, diff]
libofx-0.9.0-gcc43.patch

Fixes the problem. 50% fedora-0.8 patch, 50% home-spun.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-04-21 22:02:06 UTC
I'll try to get to it soonish since I started to use gnucash.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 22:25:51 UTC
(In reply to comment #2)
> I'll try to get to it soonish since I started to use gnucash.
> 

Note that you'll probably hit bug 218779 on the way.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-05-05 22:30:13 UTC
fixed is in tree. Thanks for reporting and patching.
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-13 10:37:50 UTC
*** Bug 231644 has been marked as a duplicate of this bug. ***