Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218702 - expat ebuild fails to make a symlink
Summary: expat ebuild fails to make a symlink
Status: RESOLVED DUPLICATE of bug 128069
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal trivial (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://wiki.linuxquestions.org/wiki/L...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-21 09:11 UTC by H. Beijeman
Modified: 2012-05-15 20:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H. Beijeman 2008-04-21 09:11:47 UTC
dev-libs/expat 2.0.1 failed to make a symlink to /usr/lib/libexpat.so.0, this is needed by media-libs/fontconfig 2.5.0-r1. The result was that the next ebuild that depended on fontconfig failed the linking stage with missing references. This brought my overnight emerge fresh-system to a screeching halt at emerge 6 of 214.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-04-21 15:01:05 UTC
No the symlink is NOT the solution. Please remove the symlink and run revdep-rebuild.
Comment 2 H. Beijeman 2008-04-21 16:20:21 UTC
So I was advised by emerge as well. I tried that route, but I got yet other emerge failures.

Really, you claim it is not a bug. I did a "fresh" gentoo install, did emergy --sync, and then emerge kdebase-startkde. And this fails. Yet it is not a bug, how strange. And it is not about removing symlinks, its about _missing_ symlinks. ldd fontconfig.so showed the missing dependency, I created a symlink to libexpat.so.0, and voila, it worked without revdep or rebuilding. 

At the risk of being very thick and annoying, I reopen this one more time, and hope someone can explain to me what I did wrong, why I should run revdep to fix a missing symlink, and why this isn't a bug. 

Kind regards,
H. B.
Comment 3 Jeroen Roovers gentoo-dev 2008-04-21 16:59:02 UTC

*** This bug has been marked as a duplicate of bug 128069 ***