Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218687 - net-im/empathy-0.22.1 fails w/ gcc-4.3.0
Summary: net-im/empathy-0.22.1 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Santiago M. Mola (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-21 05:53 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-05-01 14:08 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
empathy-0.22.1-gcc43.patch (empathy-0.22.1-gcc43.patch,3.95 KB, patch)
2008-04-21 05:54 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 05:53:22 UTC
i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -DDATADIR=\"/usr/share\" -DORBIT2=1 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gconf/2 -I/usr/include/orbit-2.0 -I/usr/include/telepathy-1.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1 -I/usr/include/libglade-2.0 -I/usr/include/libxml2 -I/usr/include/evolution-data-server-2.22 -I/usr/include/libbonobo-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/bonobo-activation-2.0 -Wall -Wunused -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wno-sign-compare -Wno-pointer-sign -Werror -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3 -MT empathy-preferences.lo -MD -MP -MF .deps/empathy-preferences.Tpo -c empathy-preferences.c  -fPIC -DPIC -o .libs/empathy-preferences.o
cc1: warnings being treated as errors
empathy-preferences.c:637: error: ‘preferences_hookup_spin_button’ defined but not used
empathy-preferences.c:668: error: ‘preferences_hookup_entry’ defined but not used
make[3]: *** [empathy-preferences.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/net-im/empathy-0.22.1/work/empathy-0.22.1/libempathy-gtk'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-im/empathy-0.22.1/work/empathy-0.22.1/libempathy-gtk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-im/empathy-0.22.1/work/empathy-0.22.1'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-21 05:54:06 UTC
Created attachment 150479 [details, diff]
empathy-0.22.1-gcc43.patch

Fixes the problem. Snatched from Debian.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-04-26 21:55:43 UTC
I'd rather just remove stupid compilation flag than modify code.

(and please never omit your emerge ---info)
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-26 22:17:54 UTC
(In reply to comment #2)
> I'd rather just remove stupid compilation flag than modify code.
> 
> (and please never omit your emerge ---info)

I must admit that I totally fail to see how your comment makes sense and how my emerge --info will in any way help you. This is not a problem with compilation flags.


Portage 2.1.5_rc6 (default-linux/x86/2007.0, gcc-4.3.0, glibc-2.7-r2, 2.6.23.12-hrt5 i686)
=================================================================
System uname: 2.6.23.12-hrt5 i686 AMD Sempron(tm)
Timestamp of tree: Sat, 26 Apr 2008 10:33:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.2-r2
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     9999
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks installsources parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ http://mirror.gentoo.no/ http://gentoo.osuosl.org/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en da"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/misc /usr/local/portage/powertop /usr/local/portage/fonts"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi aim alsa authdaemond bash-completion berkdb bzip2 cairo cdr cjk cli cpudetection cracklib crypt css cups curl dbus djbfft dri dts dvd dvdr dvdread evdev fam ffmpeg firefox flac fortran g15 gadu gif glitz gnutls gpm hal hbci iconv icq icu idea imap isdnlog jabber java javascript jpeg kde kdeenablefinal lcd lm_sensors logitech-mouse logrotate lzo mad matroska mbox metric midi mikmod mime mmx mmxext mono moznopango mp3 mp4 mpeg mplayer msn mudflap musepack ncurses network-cron nls nocd nptl nptlonly offensive ogg openal opengl openmp oscar pam pcre pdf perl png pop ppds pppd python qt3 qt4 quicktime readline real reflection sasl sdl sensord session shorten slang smime sms speex spell spl sse ssl svg svga tcpd texteffect theora threads tiff translator truetype unicode usb vcd vorbis win32codecs wmf wxwindows x264 x86 xanim xcb xface xine xml xorg xscreensaver xv xvid yahoo zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="g15" LINGUAS="en da" USERLAND="GNU" VIDEO_CARDS="vesa radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-04-26 22:51:27 UTC
-Wall [snip] -Werror -> cc1: warnings being treated as errors

This is damn stupid for a release to include -Werror and the like because you never know what a new gcc release might or might not do. It's only good for development releases. Makes sense now ?
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-26 23:11:49 UTC
(In reply to comment #4)
> -Wall [snip] -Werror -> cc1: warnings being treated as errors
> 
> This is damn stupid for a release to include -Werror and the like because you
> never know what a new gcc release might or might not do. It's only good for
> development releases. Makes sense now ?

Perfectly, and I agree 100%.
But you were talking as if you wanted to filter my compilation flags (the emerge --info remark at the end). Not only don't I think that's very helpful when the error is obvious and can be confirmed by doing a simple !google. I also think it's rude when I am doing a damn good job of finding gcc-4.3 compile errors and handing them to you on a platter with patches. I don't expect thank yous but condescending remarks aren't appreciated either.
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-04-26 23:24:49 UTC
sorry if I offensed you that was not the intention. I just wanted to make sure your didn't have -Werror in your flags but I was 99.99...% sure it was package's fault anyway :)
Comment 7 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-26 23:29:19 UTC
(In reply to comment #6)
> sorry if I offensed you that was not the intention. I just wanted to make sure
> your didn't have -Werror in your flags but I was 99.99...% sure it was
> package's fault anyway :)

I obviously read something that wasn't there. My bad.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-05-01 14:08:07 UTC
fixed in tree.