Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218483 - media-libs/libgii-1.0.2 compile fails... libtool?
Summary: media-libs/libgii-1.0.2 compile fails... libtool?
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 221035 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-04-19 21:00 UTC by Ewgenij Starostin
Modified: 2008-06-09 09:11 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,20.57 KB, text/plain)
2008-04-19 21:11 UTC, Ewgenij Starostin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ewgenij Starostin 2008-04-19 21:00:06 UTC
Emerging media-libs/libgii-1.0.2 fails on my system:
$ emerge -1v libgii
[ebuild  N    ] media-libs/libgii-1.0.2  USE="X" 0 kB 
/*patches get applied, configure runs, make walks about; then...*/
Making all in gg
make[2]: Entering directory `/var/tmp/portage/media-libs/libgii-1.0.2/work/libgii-1.0.2/gg'
Making all in ggtick
make[3]: Entering directory `/var/tmp/portage/media-libs/libgii-1.0.2/work/libgii-1.0.2/gg/ggtick'
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../.. -I../../include     -march=nocona -O3 -pipe -Wall -pedantic -D_REENTRANT -D_THREAD_SAFE -DDEBUG -g -std=gnu99 -Wpointer-arith -Wsign-compare -Wstrict-prototypes -Wswitch -Wmissing-prototypes -Wreturn-type -Wshadow -Wnested-externs -Wredundant-decls -Wuninitialized -Wcast-qual -Wwrite-strings -Werror-implicit-function-declaration -MT ggtick.o -MD -MP -MF .deps/ggtick.Tpo -c -o ggtick.o ggtick.c
mv -f .deps/ggtick.Tpo .deps/ggtick.Po
/bin/sh ../../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=nocona -O3 -pipe -Wall -pedantic -D_REENTRANT -D_THREAD_SAFE -DDEBUG -g -std=gnu99 -Wpointer-arith -Wsign-compare -Wstrict-prototypes -Wswitch -Wmissing-prototypes -Wreturn-type -Wshadow -Wnested-externs -Wredundant-decls -Wuninitialized -Wcast-qual -Wwrite-strings -Werror-implicit-function-declaration  -Wl,-O1 -o ggtick ggtick.o  
libtool: Version mismatch error.  This is libtool 2.1a, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.1a
libtool: and run autoconf again.
make[3]: *** [ggtick] Error 63

Reproducible: Always

Steps to Reproduce:
1. emerge -1v libgii
Actual Results:  
Libtool bails out, see above or in attached log.

Expected Results:  
It’d be nice if libtool did its job.

emerge --info follows. (Sorry about the USE flags spam.)

Portage 2.1.5_rc5 (default/linux/amd64/2008.0, gcc-4.2.3, glibc-2.7-r2, 2.6.24-hardened x86_64)
=================================================================
System uname: 2.6.24-hardened x86_64 Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz
Timestamp of tree: Sat, 19 Apr 2008 18:15:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.4.4-r6, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://213.186.33.37/gentoo-distfiles/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en en_US de fr es ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3ds 7zip X X509 a52 aac aalib abook ace acl acpi additions aim alisp alsa amd64 amr ansi apache2 arj artworkextra asf async audiofile auth bash-completion bcmath berkdb bidi binfilter blender-game bluetooth bonusscripts boost bugzilla bzip2 cairo cal3d calendar cardbus cddb cdparanoia chipcard chipcard2 chm cjk cli color-console colordiff cpudetection cracklib crypt cscope css ctype cups curl curlwrappers cyrillic dbase dbm dbus dbx devhelp dga dhcp dia divx djvu doc dri dts dv dvd dvdnav dvdr dvdread eap-tls ecc effects enca encode erandom examples exif extensions extra extrafilters fame fbcon fbsplash ffmpeg fftw figlet filter finger firefox flac flash flatfile fltk fluidsynth fontconfig foomaticdb fortran fpx ftp fuse games gcc-libffi gcj gconf gd gdbm geldkarte geoip ggi gif gimp gimpprint ginac git glade glep glgd glib glibc-omitfp glitz glut gmedia gmp gnuplot gnutls gopher gpg gpgme gphoto2 gpm graphics graphviz gs gsl gsm gtk gtk2 gtkhtml guile hal hash hbci hddtemp hdri hfs html humanities i8x0 iconv icq icu id3 id3tag idea idn imagemagick imap imlib immqt inkjar insecure-savers ipod ipv6 ipw3945 irda isdnlog iso14755 ithreads jabber java jce john jpeg jpeg2k json kerberos keyscrub kpathsea kqemu ladspa lame laptop lash lcms ldap ldap-sasl libcaca libdsk libnotify libsamplerate libsexy libwww lights linuxthreads-tls live lm_sensors logrotate lua lzo lzw m17n-lib math matroska mbox mcal mccp md5sum meanwhile mhash midi mime mimencode ming mjpeg mmap mmx mmxext mng mozbranding mozdevelop mozembed mozilla moznocompose moznoirc moznomail mozsvg mp2 mp3 mp3rtp mp4 mp4live mpeg mpeg2 mplayer mpm-worker msn mudflap multilib musepack mysql ncurses net nethack network networking new-interface nfconntrack nfs nis nls nntp nodrm normalizemime nptl nptlonly nsplugin ntlm offensive ofx ogg on-the-fly-crypt openal openct openexr opengl openmp oscar overload pam pango passwordsave pcap pcmcia pcntl pcre pda pdf perl php plotutils png pnm posix pppd print pstricks publishers python qt3support quicktime rar readline realmedia reflection regex resolvconf rle rtc ruby scanner science sdl sensord session sharedext shorten sift silc simplexml slang smartcard smime smp smtp sndfile sockets sound sox speex spell spl sqlite sqlite3 sse sse2 ssl subtitles subversion suhosin svg svgz syslog sysvipc t1lib tcpd tetex tga theora threads threadsafe tidy tiff tokenizer truetype type1 ucs2 ucs4 unicode usb utils v4l v4l2 vamp vcd verse vim vim-syntax vorbis vorbis-psy wavpack wifi wma wmf wmp x264 xanim xcb xchatdccserver xcomposite xetex xface xforms xim xinetd xml xmlreader xmlrpc xmlwriter xorg xosd xplanet xpm xprint xrandr xscreensaver xsl xslt xulrunner xv xvid xvmc yahoo yv12 zip zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard synaptics mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en en_US de fr es ru" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ewgenij Starostin 2008-04-19 21:11:01 UTC
Created attachment 150324 [details]
build.log

By the way, I can reproduce this when I try to build libgii-1.0.2 manually. And it doesn’t happen in the libgii from CVS, but I don’t know why.
Comment 2 Rafał Mużyło 2008-04-23 12:45:14 UTC
Well, this may be annoying to fix, as it's not broken.
libgii uses LT_INIT macro, provided by >=libtool-2.
eautoreconf doesn't recognize LT_INIT as a libtool init macro, so libtoolize is not run and as you've got libtool 1.5.26 installed, things get broken - your ltmain.sh is from libtool 2.1a, libtool.m4 is from libtool 1.5.26.
Comment 3 Andrew Savchenko gentoo-dev 2008-04-28 18:45:08 UTC
(In reply to comment #2)
> Well, this may be annoying to fix, as it's not broken.
> libgii uses LT_INIT macro, provided by >=libtool-2.
> eautoreconf doesn't recognize LT_INIT as a libtool init macro, so libtoolize is
> not run and as you've got libtool 1.5.26 installed, things get broken - your
> ltmain.sh is from libtool 2.1a, libtool.m4 is from libtool 1.5.26.
> 

And what do you propose to fix this?
Since compilation failed and packet is unmasked this is a bug.
Comment 4 Mateusz 2008-04-29 19:56:39 UTC
I had the same problem.
Hashing the eautoreconf solved my problem.
Comment 5 Juergen Rose 2008-05-06 17:42:23 UTC
How can I hash eautoreconf? I have autoreconf-2.62. But running autoreconf-2.62 gives:
autoreconf-2.62: `configure.ac' or `configure.in' is required

Juergen
Comment 6 Matt Jorde 2008-05-07 04:00:56 UTC
Confirming that hashing eautoreconf works.

> How can I hash eautoreconf?

This just means commenting out the eautoreconf line from the ebuild file by placing a '#' symbol at the beginning of that line.
Comment 7 Juergen Rose 2008-05-07 06:46:41 UTC
Hello Matt,
thanks, it worked for me.
Regards Juergen
Comment 8 Rafał Mużyło 2008-05-09 08:48:11 UTC
When I failed to notice that bug #221035 is a duplicate of this one, I posted a real solution there, not the non-solution of comment #4.
Comment 9 Rafał Mużyło 2008-05-09 08:56:19 UTC
Of course, if that solution is used, libgii-1.0.2-configure-cpuid-pic.patch should be modified to aplly to m4/swar.m4.
Comment 10 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-09 15:11:14 UTC
*** Bug 221035 has been marked as a duplicate of this bug. ***
Comment 11 Iain Buchanan 2008-06-03 00:46:46 UTC
So is this workaround going to go into the ebuild sometime?
Comment 12 SpanKY gentoo-dev 2008-06-09 09:11:08 UTC
Rafał Mużyło correctly identified the bug (which is to say libgii is broken, not libtool) ... i'd give you a cookie, but customs would confiscate it

ive committed a fix to cvs

http://sources.gentoo.org/eclass/autotools.eclass?r1=1.76&r2=1.77
http://sources.gentoo.org/media-libs/libgii/libgii-1.0.2.ebuild?r1=1.12&r2=1.13