Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218349 - [PATCH] media-video/qdvdauthor-1.0.0 fails to compile with gcc-4.3
Summary: [PATCH] media-video/qdvdauthor-1.0.0 fails to compile with gcc-4.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Briesenick (RETIRED)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
Reported: 2008-04-19 00:08 UTC by Martin Väth
Modified: 2008-12-17 21:24 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

Fix include for gcc-4.3 (qdvdauthor-gcc-4.3.patch,256 bytes, patch)
2008-04-19 00:09 UTC, Martin Väth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Väth 2008-04-19 00:08:04 UTC
media-video/qdvdauthor-1.0.0 fails to compile with gcc-4.3
Comment 1 Martin Väth 2008-04-19 00:09:09 UTC
Created attachment 150247 [details, diff]
Fix include for gcc-4.3
Comment 2 Kenton Groombridge 2008-04-19 00:52:58 UTC
qdvdauthor 1.1.0 was recently released and doesn't require a patch for gcc 4.3.
Comment 3 Mark Loeser (RETIRED) gentoo-dev 2008-05-10 03:43:57 UTC
Stefan:  can you please do the version bump so we can resolve this bug?  It would be much appreciated.  Thanks
Comment 4 Stefan Briesenick (RETIRED) gentoo-dev 2008-05-15 01:06:40 UTC
there's already version 1.2.0 out. I'm working on it... 
Comment 5 Stefan Briesenick (RETIRED) gentoo-dev 2008-06-08 23:14:25 UTC
new version in CVS. But currently w/o ppc keyword.
Comment 6 2008-06-27 14:56:10 UTC
(In reply to comment #5)
> new version in CVS. But currently w/o ppc keyword.

Then it would be nice to CC pcc team.
Comment 7 Stefan Briesenick (RETIRED) gentoo-dev 2008-06-29 21:34:55 UTC
@pcc-arch: please add ppc keyword to media-video/dv2sub so I can re-add pcc keyword to media-video/qdvdauthor-1.2.0. thanks!
Comment 8 Kenton Groombridge 2008-09-06 23:33:09 UTC
qdvdauthor 1.5.0 has been released a bit over a month ago.  The current ebuild appears to work fine, but had to adjust because the new name (qdvdauthor-1.5.0-2.tar.gz).  I just statically typed in the name into the ebuild (I know is wrong, but worked to get it built).
Comment 9 Stefan Briesenick (RETIRED) gentoo-dev 2008-09-12 16:51:51 UTC
the current ebuild *doesn't* work fine. Some things have changed. There're many "missing file" errors while installing (compiles fine though). I have to check/fix this issues first.
Comment 10 2008-11-30 10:53:58 UTC
I have tried to make an ebuild for 1.5.0 version but I couldn't advance too much, the build system is quite strange and I haven't got too much time for this app that I rarely use. However, if somebody still cares about this, I found that the flag filtering is not needed now, the program compiles with -Os, -O3 and/or -finline-functions.
Comment 11 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-17 21:24:33 UTC
Resolving this, so we can get on with gcc-4.3 business. Bug 251357 holds keyword request.