Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217387 - sys-kernel/hardened-sources-2.6.24 and sys-kernel/gentoo-sources-2.6.24-r4 does not boot when compiled with gcc-4.3 and acpi
Summary: sys-kernel/hardened-sources-2.6.24 and sys-kernel/gentoo-sources-2.6.24-r4 do...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard: linux-2.6.25
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-12 12:29 UTC by Martin Väth
Modified: 2008-06-29 16:31 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
One kernel configuration which does not boot (32bit-2.6.24-hardened.config,55.67 KB, text/plain)
2008-04-12 12:33 UTC, Martin Väth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Väth 2008-04-12 12:29:22 UTC
Since there are plans to unmask gcc-4.3, I was asked on linux.gentoo.dev
to file this as a bug:

When compiled on x86 with gcc-4.3, the hardened-sources-2.6.24 kernel dies
immediately at boot, even before printing any message (so debugging is hard).
When the kernel parameter acpi=off is passed, it boots without problems.
The problem does not occur on amd64 or when gcc-4.2.1 is used for compilation.
I deselected all acpi features in the configuration (except for the general
acpi support, of course), and had the same behaviour.

I have not tried (and have no time to try these days) whether the problem
arises also on gentoo-sources or whether it is hardened specific.
Comment 1 Martin Väth 2008-04-12 12:33:16 UTC
Created attachment 149473 [details]
One kernel configuration which does not boot

The attached .config does not have all acpi deselected, but as mentioned,
this makes no difference.

It has PAX disabled, so this can be excluded as a cause.
Comment 2 Gordon Malm (RETIRED) gentoo-dev 2008-04-12 19:50:42 UTC
(In reply to comment #1)
> Created an attachment (id=149473) [edit]
> One kernel configuration which does not boot
> 
> The attached .config does not have all acpi deselected, but as mentioned,
> this makes no difference.
> 
> It has PAX disabled, so this can be excluded as a cause.
> 

I don't know what roll this machine plays in your operations but if it is not too much trouble, would you mind trying gcc 4.3 compiled gentoo-sources-2.6.24-r4 on it with this config?
Comment 3 Kerin Millar 2008-04-12 23:22:49 UTC
As far as I'm aware, 2.6.24 with gcc-4.3.0 is not a supported combination from an upstream perspective. In fact, I would strongly recommend against it with respect to bug 213811. If you're going to try, then at least apply the following patch:

http://tinyurl.com/2obf6t

I'm not sure whether that has a direct bearing on the reporter's problem though. I too would like to know if the same problem occurs when using gentoo-sources.

Gordon, while I think of it, you should add the above patch to your 2.6.23-r10 queue as the kernel herd will almost certainly address it solely in the current genpatches branch.
Comment 4 Martin Väth 2008-04-13 14:32:48 UTC
Now I found a bit time to try also with gentoo-sources-2.6.24-r4:
The same result, i.e. (as expected) the problem is not hardened specific.

[To be precise: I used "make oldconfig" with the above config and answered
the three new points KALLSYMS_EXTRA_PASS FB_CON_DECOR PROC_KCORE
all with "N"]

@Kerin Millar: Originally, I had also conjectured that the problem is the
well-known cause that gcc-4.3 does not clear the DF flag (that's why I did
not want to post the bug first), but I was told at gentoo-dev mailinglist
that this problem occurs only much later in userspace. Moreover, it seems to
me that the patch you posted was already applied in gentoo-sources-2.6.24-r4
(and then probably also in hardened-sources-2.6.24, since they both are based
on the same patchset).

I don't know know whether it is helpful: If I pass the kernel parameter
vga=0x31A, the vga-mode is changed, before the kernel dies...
Comment 5 Kerin Millar 2008-04-14 20:39:09 UTC
> that this problem occurs only much later in userspace. Moreover, it seems to
> me that the patch you posted was already applied in gentoo-sources-2.6.24-r4
> (and then probably also in hardened-sources-2.6.24, since they both are based
> on the same patchset).

Sorry Martin, you are quite right. Before going gold, the final iteration of the 2.6.24 patchset was adjusted by Gordon. That's the point at which genpatches-2.6.24-5 was pulled in and I hadn't noticed that the patch was included. Well, I suppose that's one less thing to worry about.

Re-assigning to the kernel herd.
Comment 6 SpanKY gentoo-dev 2008-04-20 08:52:01 UTC
linux-2.6.25 has been released ... please test that version to see if the issue remains
Comment 7 Martin Väth 2008-04-20 15:49:24 UTC
The problem has vanished with 2.6.25 (tested: gentoo-sources-2.6.25-r1).

I am not sure whether I should close this bug now or wait until hardened-sources-2.6.25 gets released.
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2008-05-02 17:17:20 UTC
will close when 2.6.25 goes stable, or earlier if we can identify and backport the fix to 2.6.24
Comment 9 Gordon Malm (RETIRED) gentoo-dev 2008-05-02 17:25:22 UTC
(In reply to comment #8)
> will close when 2.6.25 goes stable, or earlier if we can identify and backport
> the fix to 2.6.24
> 

In the case that a backported fix is not found and {gentoo,vanilla}-sources-2.6.25 goes stable, please re-assign to hardened@gentoo.org instead of closing as we will want to keep note of this bug.  Thanks dsd. :)
Comment 10 Martin Väth 2008-06-17 14:32:12 UTC
Just for the records (although it is not very surprising):
Also after the latest gcc update (4.3.0->4.3.1) the kernel
(I tried hardened-sources-2.6.24-r2) does not work.
Comment 11 Martin Väth 2008-06-17 21:48:11 UTC
Since hardened-sources-2.6.25 is now in the tree, I should mention that they
work fine with gcc-4.3.1.
Comment 12 Daniel Drake (RETIRED) gentoo-dev 2008-06-29 16:31:40 UTC
Closing as this is fixed in 2.6.25, which we'll hopefully have headed towards stable soon.