Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216373 - mkxf86config.sh do not correctly detects module
Summary: mkxf86config.sh do not correctly detects module
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-05 19:01 UTC by Sergey Belyashov
Modified: 2011-06-19 13:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Belyashov 2008-04-05 19:01:27 UTC
I try run this live DVD (livedvd-i686-installer-2008.0_beta1.iso) under VirtualBox 1.5.6. It correctly shows Video Card name, but X do not starts. Then I check /etc/X11/xorg.conf and in section Device field Driver contain only "". I rerun mkxf86config.sh, but no changes. Next I manually change driver to "vesa" and restart /etc/init.d/xdm. As result GUI successfully loaded.

Reproducible: Always

Steps to Reproduce:
1. Setup Virtual Machine under VirtualBox
2. Boot from livedvd-i686-installer-2008.0_beta1.iso
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-06 17:02:28 UTC
Can you post the results of "/sbin/lspci" from the CD?

Thanks
Comment 2 Sergey Belyashov 2008-04-06 18:33:12 UTC
May be good idea set vesa as default driver (when driver not defined use vesa)?


# lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II]
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 40)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)

# lspci -n
00:00.0 0600: 8086:1237 (rev 02)
00:01.0 0601: 8086:7000
00:01.1 0101: 8086:7010
00:02.0 0300: 80ee:beef
00:03.0 0200: 1022:2000 (rev 40)
00:04.0 0880: 80ee:cafe
00:07.0 0680: 8086:7113 (rev 08)
Comment 3 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-09 18:29:22 UTC
Well, I set fbdev as the default, since it works on all arches, versus vesa which only works on amd64/x86.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-13 19:44:27 UTC
Does anyone want to work on this or should we close it as WONTFIX / CANTFIX?
Comment 5 Fernando (likewhoa) 2011-05-14 18:14:50 UTC
(In reply to comment #4)
> Does anyone want to work on this or should we close it as WONTFIX / CANTFIX?

mkxf86config is not even used on the livedvd since X can pretty much work with a blank xorg.conf and automagicaly detects most of the drivers and loads the proper modules. Keep in mind this is with x86,x86_64 not the other arches but I suspect it would be the same.
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-06-19 13:02:52 UTC
Seems no one is interested in the package.