Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 215913 - app-text/ghostscript-gpl-8.6[23] - Pre-stripped files found
Summary: app-text/ghostscript-gpl-8.6[23] - Pre-stripped files found
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High QA (vote)
Assignee: Printing Team
URL: http://bugs.ghostscript.com/show_bug....
Whiteboard:
Keywords:
: 250872 (view as bug list)
Depends on:
Blocks: prestripped
  Show dependency tree
 
Reported: 2008-04-02 18:00 UTC by Sandro Bonazzola
Modified: 2009-02-28 19:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to src/devs.mak to prevent premature strip of X11.so (ghostscript-gpl-8.63-no-prestrip.patch,600 bytes, patch)
2009-01-04 06:55 UTC, Kevin Pyle
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Bonazzola 2008-04-02 18:00:42 UTC
QA Notice: Pre-stripped files found:
/var/tmp/portage/app-text/ghostscript-gpl-8.62/image/usr/lib64/ghostscript/8.62/X11.so

$ emerge --info
Portage 2.1.4.4 (default-linux/amd64/2007.0, gcc-4.2.3, glibc-2.7-r2, 2.6.24-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3500+
Timestamp of tree: Wed, 02 Apr 2008 16:45:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/initng/daemon /etc/initng/net /etc/initng/system /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/home/ftp/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache collision-protect cvs distlocks elog java-strict metadata-transfer multilib-strict parallel-fetch sandbox sfperms sign strict stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ "
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
PKGDIR="/home/ftp/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_RSYNC_EXTRA_OPTS=" --timeout=800 --progress "
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 3ds 7zip X a52 aac acl acpi alsa amd64 amr apache2 arts audiofile avahi bash-completion berkdb bl branding bzip2 cairo cal3d caps ccache cdb cddb cdparanoia cdr cg chroot cli cpudetection cracklib crypt css cups curl custom-cflags dbus devhelp dga directfb disk-partition djvu dmi dovecot-sasl dri dts dv dvd dvdr dvdread emerald encode epydoc erandom esd exif expat extrafilters fame ffmpeg firefox flac fltk foomaticdb fortran gd gdbm ggi gif gimp gimpprint glib glibc-omitfp glitz glut gmp gnokii gnome gnutls gphoto2 gpm graphviz gsm gtk gtkhtml guile hal hbci howl-compat iconv idn ieee1394 imagemagick imlib ipv6 isc isdnlog ithreads java javacomm javascript jbig jce jikes jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kqemu lcms ldap libcaca libnotify linuxthreads-tls lm_sensors logitech-mouse logrotate lzo mad mailwrapper matroska mbox mdb mhash midi mikmod mjpeg mmap mmx mmxext mng motif mozdevelop mp3 mpeg mppe-mppc msn mudflap musepack musicbrainz mysql ncurses nfs nls nptl nptlonly nsplugin numeric nvidia odbc ode offensive ofx ogg ogre openexr opengl openmp oss pam parport pch pcre pdf perl php png povray ppds pppd print pulseaudio python qa qt3 qt3support qt4 quicktime quotes rdesktop readline reflection resolvconf restrict-javascript rtc samba scanner sdl session slang slp smime sndfile snmp speex spell spl sse sse2 ssl startup-notification subversion svg sysfs syslog tcpd test tetex tga theora threads tidy tiff timidity tk truetype unicode usb userlocales utempter v4l v4l2 vcd vda vorbis vorbis-psy wma wmf wmp xattr xcomposite xforms xine xinerama xml xorg xpm xprint xscreensaver xv xvid xvmc yv12 zeroconf zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon directory panasonic pccam300" ELIBC="glibc" FOO2ZJS_DEVICES="hp1005 hpp1005" INPUT_DEVICES="mouse evdev keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LDFLAGS, MAKEOPTS
Comment 1 Sandro Bonazzola 2008-08-19 20:02:02 UTC
Still present in app-text/ghostscript-gpl-8.63
QA Notice: Pre-stripped files found:
/var/tmp/portage/app-text/ghostscript-gpl-8.63/image/usr/lib64/ghostscript/8.63/X11.so
Comment 2 Timo Gurr (RETIRED) gentoo-dev 2008-12-14 18:34:46 UTC
*** Bug 250872 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Pyle 2009-01-04 06:54:37 UTC
This was caused by a very strange invocation of gcc when trying to build a library.  The rule passed "-Wl,-soX11.so".  This was parsed as the linker option -s, to strip the file, and the linker option -o, to name the file X11.so.  This rule also ignored user $LDFLAGS.  I will attach a patch to fix both issues.

This whole area should be revisited and reworked to use libtool, but that is beyond the scope of this bug.
Comment 4 Kevin Pyle 2009-01-04 06:55:33 UTC
Created attachment 177314 [details, diff]
Patch to src/devs.mak to prevent premature strip of X11.so
Comment 5 Timo Gurr (RETIRED) gentoo-dev 2009-01-16 20:55:20 UTC
Thanks for your patch Kevin, I've included it in the patchset for ghostscript-gpl-8.63-r1. Would be great if you could send your patch upstream since they're planning a new release for February.
Comment 6 Timo Gurr (RETIRED) gentoo-dev 2009-02-13 19:03:16 UTC
I've sent your patch upstream. I hope you don't mind. See URL.
Comment 7 Kevin Pyle 2009-02-14 18:00:19 UTC
Not at all.  I'm not the reporter, owner, or QA contact for the bug, and I didn't CC myself when I posted the patch, so I didn't get notified about your comments.  I only noticed this one because I was checking up on old patches to see which got merged.
Comment 8 Timo Gurr (RETIRED) gentoo-dev 2009-02-14 19:20:25 UTC
(In reply to comment #7)
> Not at all.  I'm not the reporter, owner, or QA contact for the bug, and I
> didn't CC myself when I posted the patch, so I didn't get notified about your
> comments.  I only noticed this one because I was checking up on old patches to
> see which got merged.

Thanks Kevin, I've also sent you a mail notice yesterday when I realised that you're not CC'ed.
Comment 9 Timo Gurr (RETIRED) gentoo-dev 2009-02-28 19:23:05 UTC
Fixed in ghostscript trunk and now in >=ghostscript-gpl-8.64-r1.