Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 215904 - Unable to load kernel
Summary: Unable to load kernel
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: All ISO (show other bugs)
Hardware: AMD64 Linux
: High critical with 2 votes (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-02 16:53 UTC by Mad Scientist
Modified: 2008-08-26 18:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mad Scientist 2008-04-02 16:53:30 UTC
After selecting an kernel option from grub the computer hangs and becomes unresponsive after the boot commands are shown

Reproducible: Always

Steps to Reproduce:
1.Insert 2008_beta1 LiveDVD into DVD drive.
2.Select the DVD in the boot selector
3.Select one of the 2 options to load the Gentoo kernel ( with or without frame buffer doesn't matter )

Actual Results:  
It displays the commands in grub.conf to boot that kernel and then hangs.

Expected Results:  
I expected the kernel and initrd to be loaded and run.

This is what is displayed when booting with the 'gentoo' option:

  Booting 'gentoo'

kernel /boot/gentoo/ root=/dev/ram0 init=/liuxrc dokeymap looptype=squashfs lo
op=/image.squashfs  cdroot vga=791
   [Linux-bzImage, setup=0x2a00, size=0x239b58]
initrd /boot/gentoo.igz
   [Linux-initrd @ 0x5fb5b000, 0x4948e2 bytes]

gentoo [no framebuffer] is the same except it has 'gentoo [no framebuffer]' instead of 'gentoo' and vga=791 is removed.
Comment 1 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-02 19:13:59 UTC
Have you tried troubleshooting this using any of the options to enable/disable support?

There's not much that we can do without more information.  A hang without any errors/messages is impossible to troubleshoot.
Comment 2 Mad Scientist 2008-04-03 01:39:47 UTC
(In reply to comment #1)
> Have you tried troubleshooting this using any of the options to enable/disable
> support?

I have not tried any other methods to find out the error I did try the help option on the disk though it went by too quickly for me to read it. ( another bug ) If you have any commands you would like me to try and add to the kernel or initrd boot line ill give it a shot.

> There's not much that we can do without more information.  A hang without any
> errors/messages is impossible to troubleshoot.

Yup though since it doesn't even load the kernel that only leaves the boot loader to trouble shoot which isn't that bad in comparison. If it helps I can post the out put from lspci or something. Or maybe just recompiling the kernel is enough. As a side notw I was using a rewritable DVD if that makes a difference.
Comment 3 niogic 2008-04-11 12:37:02 UTC
I came across this before opening a new bug.

Yes, I've got the very same problem (a part HEX numbers) with the minimal cd, too.

And it's indipendent from the graphics or any other option.

I don't know how to help. The 2 lights in the kbd don't start blinking, but everything locks up and I can't change eg. CAPS LOCK, or Num lock.

The motherboard is an Asus P5KR.
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2008-04-12 00:19:37 UTC
Well, Beta 2 has a new grub version and an updated kernel, so we'll see if that fixes it.  If not, then we'll try to come up with some other ideas and see what works.
Comment 5 Martin Mokrejš 2008-04-30 01:03:57 UTC
Try to link a remote serial console via COM1/RS232 cable from another computer to your machine and try to boot it with these parameters:

noacpi pci=assign-busses apic=verbose console=ttyS0,57600n8 console=tty0
Comment 6 Mad Scientist 2008-04-30 01:28:03 UTC
I do not have either of those connectors on the computer this bug happened on. If you know another way to do it I would be happy to try and set it up.
Comment 7 niogic 2008-04-30 11:13:42 UTC
I don't have a serial in the 64 bit pc, too..

Either way, what does this mean?

What should be needed for us not needing a serial to boot properly?
(sorry for the words..)
Comment 8 niogic 2008-04-30 11:47:53 UTC
I've just tried with 2008.0_beta2 and nothing changed !!!

Here are a screenshot and a short video..
http://www.forzazzurri.mine.nu/data/uploaded/g2008.0_beta2_after_grub_error.jpeg
http://www.forzazzurri.mine.nu/data/uploaded/g2008.0_beta2_after_grub_error.mov

This bug becomes quite critical: I haven't a particular hardware.
Asus P5KR, Intel Q6600, 1x2Gb DDR-II, GeForce 8800GT 512MB.


Maybe this is related to #215922
Comment 9 Martin Mokrejš 2008-04-30 17:42:36 UTC
Try to enter the command mode of grub by 'c' type in 'debug' and then try to boot manually. Or add it to grub.conf file.
Comment 10 Martin Mokrejš 2008-04-30 17:49:53 UTC
The arguments 'noacpi pci=assign-busses apic=verbose' from comment #5 would prevent of execution of some parts of the kernel which are the most tricky.

The 'console=ttyS0,57600n8 console=tty0' would cause that the screen output is also copied to a COM1 port (console=tty0 must be last to re-enable the local screen output), which you want to read remotely from another computer via a serial cable at the speed 57600, no parity, 8 bits of data, 1 stop bit.
Comment 11 niogic 2008-04-30 18:07:02 UTC
Martin, I've tried those options, nothing to do.
Also debug mode enabled shows nothing more.

And I can't edit the grub.conf because it's a live cd.


It's sure enough the problem is an incompatible initrd .. or the kernel is compiled with strange options that behave like this.
Comment 12 Mad Scientist 2008-04-30 19:55:25 UTC
Ok just checked with beta2 and it doesn't work. Might I suggest going back to isolinux for booting.

As a note here is my hardware:
Intel Quad Q6600 G0, 2x2GB DDR2 RAM, nVidia 8800GT 512MB, ASUS MAXIMUS FORMULA

Could it be asus boards that this happens on or Q6600 chips( or both combined)?
Comment 13 Alan Wolfe 2008-05-02 13:18:43 UTC
I don't know whether this will fix your problem, but it did for me.  I have a Core2 Duo E6550 CPU (with the dreaded Trusted Computing extensions) on an Intel motherboard.  My system always froze on boot, in exactly the manner you describe, with Gentoo and also with Centos.  The solution for me was this kernel parameter: 

pci=nommconf

Hope this helps. 
Comment 14 niogic 2008-05-02 13:29:29 UTC
It didn't do the trick for me.
Comment 15 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-05-02 14:36:22 UTC
I know the ASUS P5K motherboard has problems with its on-board NIC (e.g. see http://vip.asus.com/forum/view.aspx?SLanguage=en-us&id=20070918185735687&board_id=1&model=P5K&page=1&count=16). Maybe the issue with MAXIMUS FORMULA is similar.

Try to disable the on-board NIC in your BIOS (in fact, disable everything you don't absolutely need to boot), see if that helps.
Comment 16 niogic 2008-05-02 14:57:02 UTC
It didn't help either, Alex.

Also, as you can see (bug #211814) i absolutely need that driver and have been waiting for 2008.0 because of it.


I can also add that the computer *whistles* (like an high-frequency buzz) when the grub is counting-down .. but it stops when it loads the default entry or if I stop the count-down by pressing a key.



Also, *memtest86* doesn't load because it says "there's not enough memory".
I don't know if this is a common problem or just mine and connected to this bug.
Comment 17 niogic 2008-05-02 14:59:26 UTC
Please, set "Component: All ISO" and the severity imho is blocker - gentoo 2008.0 can't be released until this fixed.
Comment 18 Chris Gianelloni (RETIRED) gentoo-dev 2008-05-02 18:13:54 UTC
Ehh, nothing is really a blocker unless it causes file-system corruption or loss of data wrt releases.

I've changed the component and the version.  There's no need to involve the amd64 team, since this is an issue with the release and not with anything in the tree.

Would you be available to test some things for me if I came up with some ISO images for you to test?
Comment 19 Mad Scientist 2008-05-02 18:48:23 UTC
Ya sure that wouldn't be a problem.
Comment 20 niogic 2008-05-02 19:49:28 UTC
Ok Chris.

You'll find me often.

Feel free to mail me if you have some modified ISOs, I'll feedback here or where you prefer.
Comment 21 Martin Mokrejš 2008-05-06 11:16:23 UTC
Gionnico, it sounds like you should replace your power supply. Could you test another one? Also, try to get out of grub shell the hardware configuration. See its documentation. Does it match the hardware physically? e.g. RAM size?

Try Ultimate Boot CD to boot the machine and also try OpenSUSE linux boot cdrom. Just to make sure the hardware is fine.
Comment 22 niogic 2008-05-06 13:29:47 UTC
O_O

My new Enermax Liberty 500W?


The values are correct, and I can boot using other distros.

I can boot also using gentoo x86 (beta too)
Comment 23 Martin Mokrejš 2008-05-06 16:31:52 UTC
So if you can build and boot your own kernel, why don't you post here which kernels work and which not? Did you try to build same kernel as is the one distributed on the CD/DVD and find the difference between /proc/config.gz files?
Maybe a bug in gcc?
Comment 24 niogic 2008-05-09 14:47:24 UTC
I thought I had already answered some days ago.

>So if you can build and boot your own kernel, why don't you post here which
>kernels work and which not? 
Well I can build a kernel, but I can't put it in a live cd.

>Did you try to build same kernel as is the one
>distributed on the CD/DVD and find the difference between /proc/config.gz
>files?
I can't put it in the cd so, to do what?
Also, I don't even know what kernel is loaded and what the config is!


For Eg. Ubuntu x64 works.
Comment 25 Rui Carneiro 2008-05-18 05:10:09 UTC
I also have the same problem :(

Q6600 on a Asus P5E...

Comment 26 niogic 2008-05-18 12:11:18 UTC
(In reply to comment #25)
> I also have the same problem :(
> 
> Q6600 on a Asus P5E...
> 

So, for now, Intel Quad Core and P35 or X38.
And probably also jmicron controller.


Read this: http://lkml.org/lkml/2008/5/17/205
Comment 27 niogic 2008-07-12 15:55:39 UTC
This is soo bad!

You wanted to keep this boot system that uses grub in the 2008.0 final release version making me unable to use gentoo linux on my mainstream machine.

I couldn't use 2007.0 version because the kernel in it didn't support my NIC ethernet card and this is soo bad: it's been months that I've been waiting for this - and I had other problems correlated to this one (that I couldn't intall linux on that machine).


You dashed me this time, gentoo team guys.

And there must be many people in my very same situation since I've got a really normal hardware.



PS: Change to 2008.0 the affected version, I can't.
Comment 28 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-12 16:22:59 UTC
(In reply to comment #27)
> You wanted to keep this boot system that uses grub in the 2008.0 final release
> version making me unable to use gentoo linux on my mainstream machine.

Uhh, wtf are you talking about? We switched back to isolinux for 2008.0 final.

> You dashed me this time, gentoo team guys.

It sounds like you're taking it personally.

> PS: Change to 2008.0 the affected version, I can't.

I have no idea what you just said here.
Comment 29 niogic 2008-07-12 16:51:42 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > You wanted to keep this boot system that uses grub in the 2008.0 final release
> > version making me unable to use gentoo linux on my mainstream machine.
> 
> Uhh, wtf are you talking about? We switched back to isolinux for 2008.0 final.
> 
I've just burned install-amd64-minimal-2008.0.iso and that still has the grub menu to choose what to do (that doesn't work as explained from #1)
> > You dashed me this time, gentoo team guys.
> 
> It sounds like you're taking it personally.
> 
Not with someone in particular (the bug is public), but I'm disappointed of this way of ignoring a critical bug without even try to ask me to try any solutions.

> > PS: Change to 2008.0 the affected version, I can't.
> 
> I have no idea what you just said here.
> 
This bug is marked for the 2008.0_beta2 version, but the problem is still here in 2008.0
Comment 30 niogic 2008-07-29 16:07:24 UTC
I think I know the problem .. you didn't really reverted to isolinux FOR THE AMD64, but only for the x86 (maybe other archs, too).

Because I've just by chance tried the x86 minimal and it does, it has isolinux.

But the AMD64 minimal still has the grub entries..
Comment 31 niogic 2008-08-26 17:43:37 UTC
This is NOW finally fixed with the new amd64 2008.0-r1 media.
You can RESOLVE it, finally. :)
Comment 32 Andrew Gaffney (RETIRED) gentoo-dev 2008-08-26 18:00:33 UTC
Bleh, I knew there was a bug or two I missed when that media went out.