Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 21545 - emerge -pu rsync does an rsync, not an update of the rsync package
Summary: emerge -pu rsync does an rsync, not an update of the rsync package
Status: RESOLVED DUPLICATE of bug 922
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-23 08:46 UTC by Leon Brocard
Modified: 2011-10-30 22:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Brocard 2003-05-23 08:46:41 UTC
emerge -pu rsync does an rsync, not an update of the rsync package

Demonstration:

parrot:/home/acme# emerge -pu rsync
emerge: the "sync" action does not support "--pretend."
parrot:/home/acme# emerge -u rsync
>>> starting rsync with rsync://rsync.uk.gentoo.org/gentoo-portage...
,----------------
|  Welcome to rsync1.uk.gentoo.org!
|
|  For info on Gentoo Linux, see <http://www.gentoo.org/>.
|
|  For more on this server, see <http://vegetable.org.uk/>.
|

   Please note: an excessive rate of connections to this server does not
   benefit anyone - a couple of times per day is normally sufficient. A
   small amount of profiling is undertaken to determine potential abusers
   and rate-limiting may be enforced if needed.


receiving file list ...
zsh: 26016 killed     emerge -u rsync


emerge -pu system shows that:
...
[ebuild    U ] net-misc/rsync-2.5.6-r1 [2.5.6]
...

So I need to update rsync, but I can't update it on its own. This used to work
in the past.

This is with portage 2.0.48.

Reproducible: Always
Steps to Reproduce:
1. # emerge -pu rsync

Actual Results:  
emerge: the "sync" action does not support "--pretend."

Expected Results:  
Upgraded the rsync package
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-23 09:21:53 UTC
This was already mentioned a few times, it's still there for standard unix excuse #1 (historical reasons) :-)

*** This bug has been marked as a duplicate of 922 ***