Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 214835 - sys-devel/gettext compilation against uclibc fails
Summary: sys-devel/gettext compilation against uclibc fails
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
: 250814 328235 328287 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-26 09:10 UTC by disconnect
Modified: 2011-09-07 02:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
first half of solution (gettext-0.17-uclibc-stuff-snatched-from-buildroot.patch,690 bytes, text/plain)
2008-03-26 09:12 UTC, disconnect
Details
second half of solution (gettext-0.17-dischz.patch,622 bytes, text/plain)
2008-03-26 09:14 UTC, disconnect
Details
saved custom config uclibc w/ iconv support (uclibc-0.9.30.1-r1,5.68 KB, text/plain)
2010-07-14 11:35 UTC, Kazankov Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description disconnect 2008-03-26 09:10:40 UTC
because uclibc missing error_print_progname function and have one buggy(?) header

Reproducible: Always

Steps to Reproduce:
1.setup uclibc chroot envrinment
2.emerge gettext
Comment 1 disconnect 2008-03-26 09:12:55 UTC
Created attachment 147351 [details]
first half of solution

snatched from buildroot.
Comment 2 disconnect 2008-03-26 09:14:38 UTC
Created attachment 147353 [details]
second half of solution

a patch by me
i'm not familar with gettext sources, but this dirty hack seems to solves gettext-against-uclibc compilation problem
Comment 3 disconnect 2008-03-26 09:15:01 UTC
discobook ~ # gcc -v
Using built-in specs.
Target: i586-gentoo-linux-uclibc
Configured with: /var/tmp/portage/sys-devel/gcc-4.2.3/work/gcc-4.2.3/configure --prefix=/usr --bindir=/usr/i586-gentoo-linux-uclibc/gcc-bin/4.2.3 --includedir=/usr/lib/gcc/i586-gentoo-linux-uclibc/4.2.3/include --datadir=/usr/share/gcc-data/i586-gentoo-linux-uclibc/4.2.3 --mandir=/usr/share/gcc-data/i586-gentoo-linux-uclibc/4.2.3/man --infodir=/usr/share/gcc-data/i586-gentoo-linux-uclibc/4.2.3/info --with-gxx-include-dir=/usr/lib/gcc/i586-gentoo-linux-uclibc/4.2.3/include/g++-v4 --host=i586-gentoo-linux-uclibc --build=i586-gentoo-linux-uclibc --disable-altivec --disable-nls --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --disable-libmudflap --disable-libssp --disable-libgcj --with-arch=i586 --enable-languages=c,c++,treelang --enable-shared --enable-threads=posix --disable-__cxa_atexit --enable-target-optspace --enable-clocale=uclibc --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion=Gentoo 4.2.3 p1.0
Thread model: posix
gcc version 4.2.3 (Gentoo 4.2.3 p1.0)
Comment 4 disconnect 2008-03-26 09:15:29 UTC
discobook ~ # emerge --info
Portage 2.1.4.4 (uclibc/x86, gcc-4.2.3, uclibc-0.9.29-r0, 2.6.24-gentoo-r3 i686)
=================================================================
System uname: 2.6.24-gentoo-r3 i686 unknown
Timestamp of tree: Tue, 25 Mar 2008 20:47:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.1-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i586-gentoo-linux-uclibc"
CFLAGS="-march=i586 -O2 -pipe"
CHOST="i586-gentoo-linux-uclibc"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=i586 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks metadata-transfer nodoc noinfo noman sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo ftp://pandemonium.tiscali.de/pub/gentoo      http://mirrors.sec.informatik.tu-darmstadt.de/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo   http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror"
LANG="ru_RU.UTF-8"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/root/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi cli dbus dri hal iconv midi mudflap nls openmp reflection session spl truetype uclibc unicode x86 xorg" ALSA_CARDS="cs5535audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="uclibc" INPUT_DEVICES="evdev keyboardmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 solar (RETIRED) gentoo-dev 2008-03-26 15:57:03 UTC
Being that nls is use.masked having gettext is pretty moot under uclibc.
Comment 6 disconnect 2008-03-26 22:00:29 UTC
cat /etc/portage/profile/use.mask
-iconv
-nls

cat /etc/portage/profile/packages
-<dev-libs/glib-2.5

I need it to emerge xorg-x11 :E
Comment 7 SpanKY gentoo-dev 2008-12-22 06:23:46 UTC
*** Bug 250814 has been marked as a duplicate of this bug. ***
Comment 8 Hagen 2008-12-22 13:24:34 UTC
(In reply to comment #7)
> *** Bug 250814 has been marked as a duplicate of this bug. ***
> 

I added the two patch files and tried to emerge gettext again. But I still get the same errors! see bug 250814
Comment 9 disconnect 2008-12-24 13:48:58 UTC
I dont think #250814 is duplicating this.
Both bugs uClibc + gettext related, but compilation errors (and hence reasons of that errors) differs.

P.S. Why you dont adding my patches to portage? At least one of them have 'noble origin' :)
Comment 10 SpanKY gentoo-dev 2009-01-06 14:28:52 UTC
*** Bug 250814 has been marked as a duplicate of this bug. ***
Comment 11 Samuli Suominen gentoo-dev 2010-07-14 08:55:50 UTC
*** Bug 328235 has been marked as a duplicate of this bug. ***
Comment 12 Kazankov Alexander 2010-07-14 11:35:59 UTC
Created attachment 238707 [details]
saved custom config uclibc w/ iconv support

USE=savedconfig emerge uclibc

make -j2 headers 
  MKDIR include/bits
 
You do not have a codesets.txt file.  Please create this 
file in the ./extra/locale directory by running something like: 
  cd ./extra/locale/ && find charmaps -name "*.pairs" > \
        extra/locale/codesets.txt
and then edit that file to disable/enable the codesets you wish to support. 
 
make: *** [extra/locale/codesets.txt] Error 1
make: *** Waiting for unfinished jobs....
Comment 13 Kazankov Alexander 2010-07-14 13:33:22 UTC
When I create codesets.txt and locales.txt it's failed with next error:

  GEN extra/locale/c8tables.h
setlocale(LC_CTYPE,"en_US.UTF-8") failed!
make: *** [extra/locale/c8tables.h] Error 1
make: *** Waiting for unfinished jobs....
Comment 14 Samuli Suominen gentoo-dev 2010-07-14 19:39:23 UTC
*** Bug 328287 has been marked as a duplicate of this bug. ***