Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 214827 - can't switch to TTY with =x11-drivers/nvidia-drivers-169.12
Summary: can't switch to TTY with =x11-drivers/nvidia-drivers-169.12
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-26 06:42 UTC by Andrew Morris
Modified: 2008-07-14 23:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Morris 2008-03-26 06:42:33 UTC
I upgraded to the nvidia-drivers version 169.12. Now i cannot switch to TTY, after saying this in #gentoo on irc.freenode.net there seems to be a few with this issue.

No dmesg errors, no Xorg errors in the log. Happens if i start X from both a TTY and the GUI

Reproducible: Always

Steps to Reproduce:
1.start X (both from TTY and GUI)
2.Start TTY
3.

Actual Results:  
Black Screen, not able to do anything apart from Switch back to the GUI

Expected Results:  
Given the TTY login prompt
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-03-26 09:12:38 UTC
You can use nvidia-bug-report.sh to generate some information to e-mail over to
NVIDIA @ linux-bugs@nvidia.com and you may also wish to consider exploring
NVIDIA's Linux driver forum @ http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14
Comment 2 Doug Goldstein (RETIRED) gentoo-dev 2008-05-07 14:57:39 UTC
Chainsaw is taking over this package.
Comment 3 quazgar 2008-05-07 21:39:49 UTC
I experienced a similar problem, might well be related to this bug and happens with 169.12 but not with 100.14.19 (that's why I changed back to that version).  I'll just attach the mail I sent to nvidia's bug address:

> Sometimes (approximately every 4th-10th time) when changing from X to the 
> console, X will crash due to an error in the nvidia driver, as can be seen in 
> the backtrace in /var/log/Xorg.0.log.old:
>
> Backtrace:
> 0: X(xf86SigHandler+0x6a) [0x48dc8a]
> 1: /lib/libc.so.6 [0x2ac1607ab430]
> 2: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv000754X+0x6a) 
> [0x2ac162dbf37a]
>
> This cannot be always reproduced, but happens every now and then.
>
> My system is a gentoo (stable) linux on amd64, for more hardware details, 
> please refer to the attached automatically generated bug report.
>  

Someone from nvidia answered and told me they are aware of this problem and that it'll be fixed in the upcoming 173 release.

Do with this information whatever you want, I didn't think it was worth its own bug report, since upstream is aware of it already.
Comment 4 Tony Vroon gentoo-dev 2008-05-07 22:41:52 UTC
Thanks for letting us know of the outcome. For the record, there is a 173.08 beta ebuild in the portage tree. It is not supported (and far from perfect), but if you are experimenting with different driver versions it might be helpful at some point.
Comment 5 quazgar 2008-07-14 22:09:25 UTC
Happens again with:
x11-drivers/nvidia-x11-drivers/nvidia-drivers   173.14.09
x11-base/xorg-server                            1.4.0.90-r3 

=====
Backtrace:
0: /usr/bin/X(xf86SigHandler+0x6a) [0x48dc8a]
1: /lib/libc.so.6 [0x2b69aa28b430]
2: /usr/lib64/xorg/modules/drivers//nvidia_drv.so(_nv000754X+0x6a) [0x2b69ac8a010a]

Fatal server error:
Caught signal 11.  Server aborting
======

Please reopen since it seems to be the same bug basically.  I haven't tried the 177 drivers since they're still hardmasked because they're unsupported.
Comment 6 Tony Vroon gentoo-dev 2008-07-14 23:30:51 UTC
Please follow the instructions with the ebuild. That is to use the nvidia bug-report script and open a thread on nvnews.net so nVidia staff can investigate. As I do not have the driver source I am not in a position to help you.