Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 21451 - ebuild of gcc-3.2.3-r1 might be broken symlink not redirecting to new installation.
Summary: ebuild of gcc-3.2.3-r1 might be broken symlink not redirecting to new install...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2003-05-21 21:35 UTC by Spundun Bhatt
Modified: 2003-07-14 14:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Spundun Bhatt 2003-05-21 21:35:48 UTC
I think the ebuild is not arranging the symlinv in the
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2 properly.
in short
spundun@mermaid spundun $ ls -l /usr/lib/gcc-lib/i686-pc-linux-gnu/
total 2
lrwxrwxrwx    1 root     root            5 Feb  7 20:06 3.2 -> 3.2.2
drwxr-xr-x    2 root     root          144 Feb  7 13:57 3.2.1
drwxr-xr-x    3 root     root         1144 May 18 13:50 3.2.3
notice that the symlink is pointing to 3.2.2 directory which does not exist.
I am getting errors while updating gaim to 0.63 version.
the error is
libtool: link: cannot find the library
make[3]: *** [gaim] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gaim-0.63/work/gaim-0.63/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gaim-0.63/work/gaim-0.63/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gaim-0.63/work/gaim-0.63'
make: *** [all-recursive-am] Error 2
!!! ERROR: net-im/gaim-0.63 failed.
!!! Function src_compile, Line 54, Exitcode 2
!!! Make failed

Hope this helps

Reproducible: Always
Steps to Reproduce:
1.update gcc to 3.2.3
2.then try to install gaim 0.63 or check the symlink at

Actual Results:  
link broken gaim error in src_compile

Expected Results:  
the link should have updated to the new installation
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-05-22 02:10:49 UTC
use gcc-config
Comment 2 Spundun Bhatt 2003-05-22 03:03:08 UTC
I am sorry but I dont understand what you are asking me to do.. (a url to a doc will be great).
Are you saying that gaim ebuild should be using gcc-config in someway? Then could you reassign this bug to the relevent dev (or I could create a new bug with a proper subject and description) 
If you mean something else then I didnt get it. 
when on prompt gcc-config outputs this
mermaid root # gcc-config -l
[1] i686-pc-linux-gnu-3.2.3
mermaid root # gcc-config -c
mermaid root # gcc-config -E
export PATH="/usr/i686-pc-linux-gnu/gcc-bin/3.2:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.2:/opt/Acrobat5:/usr/X11R6/bin:/opt/blackdown-jre-1.4.1/bin:/usr/qt/3/bin:/usr/kde/3.1/sbin:/usr/kde/3.1/bin"
export CC="gcc"
export CXX="g++"
mermaid root # gcc-config -B
mermaid root # gcc-config -L
mermaid root # gcc-config -X
mermaid root #

I even tried reinstalling gcc-config since I didnt understand what you were saying... still the symlink is broken and the gcc-config o/p is the same. Also gaim still fails to compile. 
Can you tell me what I am missing?
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-05-22 04:04:13 UTC
gentoo root # gcc-config -l
[1] i586-pc-linux-gnu-2.95.3
gentoo root # gcc-config i586-pc-linux-gnu-2.95.3
Comment 4 Martin Holzer (RETIRED) gentoo-dev 2003-05-23 06:02:43 UTC
can i close this now as invalid ?
Comment 5 Spundun Bhatt 2003-05-23 12:58:17 UTC
I am not sure what you mean by that... you mean I should install 2.95.3? You are being too consise and cryptic for my little mind :)

I am having this problem only with gaim 0.63. I am able to compile a dozen or so other package without any problems... so I am adding lostlogic to the cc list.
Comment 6 Brad Laue (RETIRED) gentoo-dev 2003-06-08 11:31:03 UTC
Please try running 


Once more.
Comment 7 Spundun Bhatt 2003-06-10 13:49:05 UTC
I am very confused about what you are asking me... :( can you please explain what exactly you mean? Mean while this is the closest I got to what you asked.

mermaid root # i686-pc-linux-gnu-gcc --version
i686-pc-linux-gnu-gcc (GCC) 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
mermaid root #

I am still having this problem
please guide me on how to fix it.
Comment 8 Spundun Bhatt 2003-06-10 13:57:02 UTC
BTW may be this will help.

mermaid root # ls /usr/lib/gcc-lib/i686-pc-linux-gnu/ -l
total 2
lrwxrwxrwx    1 root     root            5 Feb  7 20:06 3.2 -> 3.2.2
drwxr-xr-x    2 root     root          144 Feb  7 13:57 3.2.1
drwxr-xr-x    3 root     root         1144 May 18 13:50 3.2.3
mermaid root # cat  /etc/env.d/gcc/i686-pc-linux-gnu-3.2.3
mermaid root #

The way I see it.... the problem is that the softlink in /usr/lib/gcc-lib/i686-pc-linux-gnu/ didnt update it self to point to 3.2.3 from 3.2.2. I dont know why it didnt. I dont know why nobody else is having this problem. I dont think I did anything outof ordinary (at least deliberately). 
Anybody care to answer them? Which package is responsible for keeping these symlinks intact. Is this symlink pointing at the right location for you guys out there?
Comment 9 Spundun Bhatt 2003-06-10 14:50:02 UTC
Okkey, after gaim, gnome-spell is the second ebuild failing. I have been able to install more than 50 ebuilds after I started having problems with gaim. And gnome-spell is the second ebuild I am having problems in. I am appending the result of the make command as I excuted in /var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4 directory. I did make manually so that the out put is small and also so that the make is executed sequentially. The error that I am getting is apprently coming from the libtool command. The burning questions are still the same as I stated earlier today.
Hope we can arrive on a solution soon. :)

mermaid gnome-spell-1.0.4 # make
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4'
Making all in po
make[2]: Entering directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4/po'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4/po'
Making all in gnome-spell
make[2]: Entering directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4/gnome-spell'
/bin/sh ../libtool --mode=link gcc  -march=pentium3 -O3 -pipe -g -g -g -g -g -L/usr/lib  -o   Spell-common.lo Spell-skels.lo Spell-stubs.lo  -laspell
grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.2/ No such file or directory
sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.2/ No such file or directory
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2/' is not a valid libtool archive
make[2]: *** [] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4/gnome-spell'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-spell-1.0.4/work/gnome-spell-1.0.4'
make: *** [all-recursive-am] Error 2
mermaid gnome-spell-1.0.4 #

Comment 10 Seemant Kulleen (RETIRED) gentoo-dev 2003-06-11 04:55:17 UTC
to fix this, all you have to do is emerge aspell again
Comment 11 Spundun Bhatt 2003-06-11 09:56:26 UTC
That worked like a charm! :)
Comment 12 Martin Holzer (RETIRED) gentoo-dev 2003-07-14 14:59:12 UTC