Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213191 - app-cdr/cdrdao-1.2.2 gcc-4.3 patch
Summary: app-cdr/cdrdao-1.2.2 gcc-4.3 patch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
: 229273 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-03-12 20:27 UTC by Hanno Zysik (geki)
Modified: 2008-06-24 18:46 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gcc43 patch (cdrdao-1.2.2-gcc43.patch,775 bytes, patch)
2008-03-12 20:27 UTC, Hanno Zysik (geki)
Details | Diff
cdrdao-1.2.2-gcc43.patch (cdrdao-1.2.2-gcc43.patch,1.99 KB, patch)
2008-03-19 22:26 UTC, Peter Alfredsen (RETIRED)
Details | Diff
Updated GCC 4.3 patch (cdrdao-1.2.2-gcc43.patch,2.39 KB, patch)
2008-05-03 10:52 UTC, Anthony Rousseau
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hanno Zysik (geki) 2008-03-12 20:27:33 UTC
Summary says it. Patch will be attached, from fedora.
Comment 1 Hanno Zysik (geki) 2008-03-12 20:27:54 UTC
Created attachment 145923 [details, diff]
gcc43 patch
Comment 2 Grégoire Favre 2008-03-15 13:13:35 UTC
Thank, I hope it's get into mailine ASAP :-)
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-03-19 22:26:16 UTC
Created attachment 146617 [details, diff]
cdrdao-1.2.2-gcc43.patch

Patch from debian, supposedly fixes additional kinds of build failures, see bug 455309 on debian bugzie:
http://bugs.debian.org/455309
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2008-04-04 01:12:06 UTC
added to gcc-porting overlay.  has this been sent upstream?
Comment 5 Hanno Zysik (geki) 2008-04-04 10:17:05 UTC
It looks like, yes.
http://cdrdao.cvs.sourceforge.net/cdrdao/cdrdao/ChangeLog?revision=1.10&view=markup
Comment 6 Ryan Hill (RETIRED) gentoo-dev 2008-04-20 23:51:31 UTC
Applied, thanks.
Comment 7 Neil Cathey 2008-04-21 06:08:50 UTC
It's still missing a #include <cstring> in trackdb/FormatMp3.cc
Comment 8 Anthony Rousseau 2008-05-03 10:52:47 UTC
Created attachment 151679 [details, diff]
Updated GCC 4.3 patch

This one embeds the #include <cstring> needed by FormatMp3.cc
Comment 9 Samuli Suominen gentoo-dev 2008-05-03 11:22:00 UTC
Reopening wrt last 2 comments.
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2008-05-04 23:16:23 UTC
Thanks for the update.  Fixed.
Comment 11 Samuli Suominen gentoo-dev 2008-06-24 18:46:50 UTC
*** Bug 229273 has been marked as a duplicate of this bug. ***