Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213154 - x11-misc/slim-1.3.0-r1 fails building with sys-devel/gcc-4.3
Summary: x11-misc/slim-1.3.0-r1 fails building with sys-devel/gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Christoph Mende (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-03-12 14:31 UTC by Dennis Schridde
Modified: 2008-05-05 21:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.30 KB, text/plain)
2008-03-12 14:32 UTC, Dennis Schridde
Details
slim-gcc43.patch (slim-gcc43.patch,255 bytes, patch)
2008-03-20 16:23 UTC, ape
Details | Diff
Updated ebuild (slim-1.3.0-r2.ebuild,2.54 KB, text/plain)
2008-04-19 20:59 UTC, Richard Moore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2008-03-12 14:31:48 UTC
cstring missing in cfg.cpp, log attached.

Reproducible: Always

Steps to Reproduce:
Comment 1 Dennis Schridde 2008-03-12 14:32:09 UTC
Created attachment 145908 [details]
build.log
Comment 2 ape 2008-03-20 16:23:32 UTC
Created attachment 146656 [details, diff]
slim-gcc43.patch

This patch should fix the issue. It wasn't too difficult to write it :P
Comment 3 Alexandre Farias 2008-04-19 16:29:55 UTC
This needs to be added to the portage tree, I just had to make a patch like the one attached here because slim wouldn't compile.
Comment 4 Richard Moore 2008-04-19 20:59:14 UTC
Created attachment 150322 [details]
Updated ebuild

Requires 'slim-gcc43.patch' in "${PORTDIR_OVERLAY}/x11-misc/slim/files/"
Comment 5 Richard Moore 2008-04-19 21:01:12 UTC
Comment on attachment 150322 [details]
Updated ebuild

Requires 'slim-gcc43.patch' in "${PORTDIR_OVERLAY}/x11-misc/slim/files/"

Only simple, but it's my first contribution to bugzilla ;)
Comment 6 Samuli Suominen gentoo-dev 2008-05-05 21:30:35 UTC
(In reply to comment #2)
> Created an attachment (id=146656) [edit]
> slim-gcc43.patch
> 
> This patch should fix the issue. It wasn't too difficult to write it :P
> 

Thanks for the patch, and thanks to others too.. committed..