Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213139 - media-libs/vamp-plugin-sdk-1.2 fails building with sys-devel/gcc-4.3
Summary: media-libs/vamp-plugin-sdk-1.2 fails building with sys-devel/gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
: 216117 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-03-12 13:42 UTC by Dennis Schridde
Modified: 2008-04-13 21:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,4.98 KB, text/plain)
2008-03-12 13:42 UTC, Dennis Schridde
Details
vamp-plugin-sdk-1.2-gcc4.3.patch (vamp-plugin-sdk-1.2-gcc4.3.patch,10.56 KB, patch)
2008-03-28 10:45 UTC, impulze
Details | Diff
vamp-plugin-sdk-1.2.ebuild.patch (vamp-plugin-sdk-1.2.ebuild.patch,346 bytes, patch)
2008-03-28 10:46 UTC, impulze
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2008-03-12 13:42:47 UTC
Misses cstring and cmalloc in vamp-sdk/PluginAdapter.cpp. log attached

Reproducible: Always

Steps to Reproduce:
Comment 1 Dennis Schridde 2008-03-12 13:42:58 UTC
Created attachment 145898 [details]
build.log
Comment 2 impulze 2008-03-28 10:45:40 UTC
Created attachment 147527 [details, diff]
vamp-plugin-sdk-1.2-gcc4.3.patch
Comment 3 impulze 2008-03-28 10:46:25 UTC
Created attachment 147529 [details, diff]
vamp-plugin-sdk-1.2.ebuild.patch
Comment 4 Alexis Ballier gentoo-dev 2008-04-05 16:52:37 UTC
*** Bug 216117 has been marked as a duplicate of this bug. ***
Comment 5 Alexis Ballier gentoo-dev 2008-04-13 21:04:02 UTC
applied, thanks.

as always, please dont forget to poke upstream about it.