Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212833 - net-p2p/rtorrent-0.8 fails to build with gcc-4.3
Summary: net-p2p/rtorrent-0.8 fails to build with gcc-4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Timothy Redaelli (RETIRED)
URL:
Whiteboard:
Keywords:
: 260854 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-03-09 15:25 UTC by Philipp
Modified: 2009-03-04 14:30 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for missing includes (rtorrent-gcc43.patch,1.86 KB, patch)
2008-03-09 15:25 UTC, Philipp
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp 2008-03-09 15:25:25 UTC
net-p2p/rtorrent misses some includes that are required by gcc-4.3.
I have filed a bug report upstream.
http://libtorrent.rakshasa.no/ticket/1267
Comment 1 Philipp 2008-03-09 15:25:58 UTC
Created attachment 145653 [details, diff]
patch for missing includes
Comment 2 Santiago M. Mola (RETIRED) gentoo-dev 2008-03-10 10:53:41 UTC
Adding net-p2p since drizzt is unresponsive.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-04-21 15:07:57 UTC
Fixed this myself.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-04 14:30:00 UTC
*** Bug 260854 has been marked as a duplicate of this bug. ***