Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212755 - media-gfx/graphviz-2.16.1-r3 failed w/ libtool-2.2
Summary: media-gfx/graphviz-2.16.1-r3 failed w/ libtool-2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 212775 (view as bug list)
Depends on: 213609
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-03-08 20:43 UTC by Alexey Shvetsov
Modified: 2008-03-16 22:19 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,2.38 KB, text/plain)
2008-03-08 20:44 UTC, Alexey Shvetsov
Details
autoconf-17866.out (autoconf-17866.out,316 bytes, text/plain)
2008-03-08 20:45 UTC, Alexey Shvetsov
Details
graphviz-2.18.ebuild.patch (graphviz-2.18.ebuild.patch,565 bytes, patch)
2008-03-16 17:58 UTC, Arfrever Frehtes Taifersar Arahesis (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shvetsov gentoo-dev 2008-03-08 20:43:42 UTC
Portage 2.2_pre3 (default-linux/amd64/2007.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.24-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r3 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Timestamp of tree: Sat, 08 Mar 2008 18:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -pipe -march=native -mtune=native -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -march=native -mtune=native -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://192.168.0.60 http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo http://gentoo.osuosl.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--sort-common"
LINGUAS="ru en"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/science /usr/portage/local/layman/openrc /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip R X Xaw3d a52 aac acl acpi addbookmarks additions administrator akode alias alsa amarok amd64 amr amrnb amrwb apache2 audiofile audit autoreplace bash-completion berkdb blas bzip2 cairo caps catalogs cdr chm cli color-console connectionstatus contactnotes context cracklib crypt css cups curl cviewer cvs cyrillic dbus djvu doc double-precision dri dvd dvdr dvdread emboss emovix enca encode esd exif extra fam fame fbcondecor ffmpeg fftw firefox fits flac fontconfig fortran fpx ftp fuse games gcc4 gdb gdbm gif git glitz gmp gnutls gphoto2 gpm grace graphics graphviz gs gsl gstreamer gtk hal hdri history humanities iceweasel icon iconv ieee1394 imagemagick inotify iproute2 ipv6 isdnlog ithreads jadetex java jbig jingle jpeg jpeg2k kde kvm lame lapack latex lcms lesstif libffi libwww lm_sensors logrotate lyx lzo mad maps midi mikmod mjpeg mmx mng motif mp3 mp3rtp mpeg mpi mplayer mudflap music mysql ncurses neXt netcdf newspr nfs nls nova nptl nptlonly nsplugin nxclient odk ogg omega openal openexr opengl openmp oscar oss pam pch pcre pdf perl pertty php plasma plotutils plugins png pnm postscript povray ppds pppd profile pstricks publishers pulseaudio python q32 qhull qt-copy qt3 qt3support qt4 query-browser quicktime radio rar rdesktop readline reflection rtc ruby samba sasl sbcl science sdl sensord session sftp slang slp smp solver soundex speex spell spl srt sse sse2 ssl ssse3 subversion svg svnserve symlink sysfs taglib tcl tcpd teamarena teletext tetex tex4ht theora threads tiff tk translator truetype unicode urandom usb utempter valgrind vboxbfe vhosts vim vim-syntax vnc vorbis webdav webpresence wmf workbench x264 x86emu xattr xcb xcomposite xen xetex xft xine xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias ident version" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexey Shvetsov gentoo-dev 2008-03-08 20:44:23 UTC
Created attachment 145596 [details]
build.log

build.log
Comment 2 Alexey Shvetsov gentoo-dev 2008-03-08 20:45:02 UTC
Created attachment 145598 [details]
autoconf-17866.out

autoconf out
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-03-08 23:27:10 UTC
*** Bug 212775 has been marked as a duplicate of this bug. ***
Comment 4 Rafał Mużyło 2008-03-09 00:06:27 UTC
Please compare to the bug 212718#c5
Comment 5 Rafał Mużyło 2008-03-15 18:20:06 UTC
OK, it's unrelated.
AC_PROG_LIBTOOL now does m4_pattern_forbid([^_?LT_[A-Z_]+$])
Maybe this is the reason, why LT_CURRENT, LT_REVISION and LT_AGE
are treated as if they were macros.
Comment 6 Rafał Mużyło 2008-03-15 21:24:50 UTC
Then again, hal uses same patterns and doesn't complain.
Comment 7 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-03-16 17:57:19 UTC
(In reply to comment #5)
> AC_PROG_LIBTOOL now does m4_pattern_forbid([^_?LT_[A-Z_]+$])
> Maybe this is the reason, why LT_CURRENT, LT_REVISION and LT_AGE
> are treated as if they were macros.

It should be fixed in media-gfx/graphviz-2.18.
Comment 8 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-03-16 17:58:51 UTC
Created attachment 146327 [details, diff]
graphviz-2.18.ebuild.patch
Comment 9 Rafał Mużyło 2008-03-16 20:49:16 UTC
Patch from comment 8 does NOT fix the issue.
The error message doesn't change.
Comment 10 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-03-16 20:57:22 UTC
(In reply to comment #9)
> Patch from comment 8 does NOT fix the issue.

I didn't say that it is sufficient.
Comment 11 Markus Meier gentoo-dev 2008-03-16 20:59:11 UTC
(In reply to comment #9)
> Patch from comment 8 does NOT fix the issue.
> The error message doesn't change.

It works with the latest version (media-gfx/graphviz-2.18). Thanks for the patch btw.
Comment 12 Rafał Mużyło 2008-03-16 22:19:37 UTC
There is still the question of why it does not break for hal, which uses those LT_* variables without a problem, cause graphviz-2.18 simply stopped using them.