Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 209036 - app-text/recode-3.6-r2: failed to compile with width of 'ignore' exceeds it's type using GCC-4.3.0
Summary: app-text/recode-3.6-r2: failed to compile with width of 'ignore' exceeds it's...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
: 215245 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-02-05 21:17 UTC by Keith R.
Modified: 2008-04-20 08:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to get recode-3.6 to compile with gcc-4.3 (recode-3.6-gcc-4.3.patch,402 bytes, patch)
2008-02-06 05:27 UTC, Neil Cathey
Details | Diff
Another patch to compile with gcc 4.3 (recode-3.6-gcc-4.3.patch,245 bytes, patch)
2008-04-02 19:17 UTC, Alexey Charkov
Details | Diff
recode-3.6-gcc-4.3.patch (recode-3.6-gcc-4.3.patch,477 bytes, patch)
2008-04-03 18:46 UTC, Peter Volkov (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Keith R. 2008-02-05 21:17:42 UTC
I've tried compiling recode for use with PHP5.2.5-r1 using GCC-4.3.0_alpha20080201. And it said width of 'ignore' exceeds it's type. I have however tried compiling with GCC-4.2.2 and it compiles fine.

Reproducible: Always

Steps to Reproduce:
1. install gcc-4.3.0_alpha20080201 from the toolchain overlay
2. enable ~x86
3. compile
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-02-06 00:07:31 UTC
until gcc-4.3 is portage (officially supported) we'd like bug reports to include patches please. ;)
Comment 2 Neil Cathey 2008-02-06 05:27:55 UTC
Created attachment 142772 [details, diff]
Patch to get recode-3.6 to compile with gcc-4.3

I made my own patch from a suggestion on the fedora-devel-list.  I haven't actually tested it to make sure it works, but it compiles.  See:

https://www.redhat.com/archives/fedora-devel-list/2008-January/msg01411.html
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2008-03-05 21:56:40 UTC
this isn't fixed.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-03-28 20:29:56 UTC
*** Bug 215245 has been marked as a duplicate of this bug. ***
Comment 5 Alexey Charkov 2008-04-02 19:17:57 UTC
Created attachment 148123 [details, diff]
Another patch to compile with gcc 4.3

It seems that 2 is just too much for a bool type. Replacing it with 1 compiles fine (and should presumably yield the same result).
Sadly, I have completely no experience with C programming and this is the first patch I have ever attempted.
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2008-04-03 18:46:23 UTC
Created attachment 148477 [details, diff]
recode-3.6-gcc-4.3.patch

Patch from:
https://www.redhat.com/archives/fedora-devel-list/2008-January/msg01413.html

I don't have gcc-4.3 at hand to check it ...