Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 208872 - sys-power/nut CGI keyword needs PNG support in media-libs/gd
Summary: sys-power/nut CGI keyword needs PNG support in media-libs/gd
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-04 18:42 UTC by RB
Modified: 2008-02-17 04:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Updated ebuild (nut-2.2.0.ebuild,5.44 KB, text/plain)
2008-02-04 18:43 UTC, RB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RB 2008-02-04 18:42:19 UTC
sys-power/nut-2.2.0 needs to perform a 'built_with_use media-libs/gd png' check if being compiled with CGI support.  If media-libs/gd is not built with PNG support, econf fails with the following:


checking for gdImagePng in -lgd... no
configure: error: libgd not found, required for CGI build


The following (unrelated but easily fixed) QA notice pops up during the compile as well:

 * QA Notice: 'autoconf' called by src_unpack: sys-power/nut-2.2.0
 * Use autotools.eclass instead of calling 'autoconf' directly.
Comment 1 RB 2008-02-04 18:43:07 UTC
Created attachment 142668 [details]
Updated ebuild

Attaching updated ebuild with suggested changes.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2008-02-04 20:59:53 UTC

*** This bug has been marked as a duplicate of bug 2272 ***
Comment 3 Chris Slycord 2008-02-17 04:38:54 UTC
(In reply to comment #2)
> 
> *** This bug has been marked as a duplicate of bug 2272 ***
> 

How is this a dupe? Even if that bug gets fixed, this one will still stand.
Comment 4 RB 2008-02-17 04:53:13 UTC
I would tend to agree, but emailed [what I thought was] the last maintainer of this ebuild and got zero return.

Jakub does sometimes tend to broadly classify bugs, but I don't figure it's up to me to fix him, just keep providing reports and resolutions.