Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208430 - dev-perl/MARC-* ebuilds for supporting Koha ILC
Summary: dev-perl/MARC-* ebuilds for supporting Koha ILC
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2008-02-01 14:16 UTC by Tomas Cohen Arazi
Modified: 2014-12-07 18:48 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
MARC-1.07 ebuild (MARC-1.07.ebuild,600 bytes, text/plain)
2008-02-01 14:20 UTC, Tomas Cohen Arazi
Details
MARC-Charset-0.98 ebuild (MARC-Charset-0.98.ebuild,689 bytes, text/plain)
2008-02-01 14:21 UTC, Tomas Cohen Arazi
Details
MARC-Lint-1.43 ebuild (MARC-Lint-1.43.ebuild,638 bytes, text/plain)
2008-02-01 14:21 UTC, Tomas Cohen Arazi
Details
MARC-Record-2.0.0 ebuild (MARC-Record-2.0.0.ebuild,576 bytes, text/plain)
2008-02-01 14:21 UTC, Tomas Cohen Arazi
Details
MARC-XML-0.88 ebuild (MARC-XML-0.88.ebuild,647 bytes, text/plain)
2008-02-01 14:22 UTC, Tomas Cohen Arazi
Details
Net-Z3950-ZOOM-1.21 ebuild (Net-Z3950-ZOOM-1.21.ebuild,620 bytes, text/plain)
2008-02-01 14:22 UTC, Tomas Cohen Arazi
Details
Business-ISBN-2.03 ebuild (Business-ISBN-2.03.ebuild,573 bytes, text/plain)
2008-02-01 14:22 UTC, Tomas Cohen Arazi
Details
Unicode-Normalize-1.02 ebuild (Unicode-Normalize-1.02.ebuild,587 bytes, text/plain)
2008-02-01 14:22 UTC, Tomas Cohen Arazi
Details
Test-More-Diagnostic-0.2 ebuild (Test-More-Diagnostic-0.2.ebuild,529 bytes, text/plain)
2008-02-01 14:23 UTC, Tomas Cohen Arazi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Cohen Arazi 2008-02-01 14:16:21 UTC
In order to support the install of Koha (http://koha.org) in Gentoo(*) there are some dependencies to be satisfied.

dev-perl/Business-ISBN
dev-perl/MARC
dev-perl/MARC-Charset
dev-perl/MARC-Lint
dev-perl/MARC-Record
dev-perl/MARC-XML
dev-perl/Net-Z3950-ZOOM
dev-perl/Test-More-Diagnostic
dev-perl/Unicode-Normalize

As they are not in portage yet, adding them wont cause much trouble as they are not dependencies of other packages.

I prepared ebuilds for all of them. Do I have to post them here, or one for each ebuild?

(*) Using portage to handle the needed modules instead of CPAN.

Reproducible: Always




As =dev-libs/yaz-3.0.16 is already in portage all other dependencies are met for this ebuilds in portage.
Comment 1 Tomas Cohen Arazi 2008-02-01 14:20:01 UTC
Created attachment 142381 [details]
MARC-1.07 ebuild
Comment 2 Tomas Cohen Arazi 2008-02-01 14:21:04 UTC
Created attachment 142383 [details]
MARC-Charset-0.98 ebuild
Comment 3 Tomas Cohen Arazi 2008-02-01 14:21:28 UTC
Created attachment 142385 [details]
MARC-Lint-1.43 ebuild
Comment 4 Tomas Cohen Arazi 2008-02-01 14:21:48 UTC
Created attachment 142386 [details]
MARC-Record-2.0.0 ebuild
Comment 5 Tomas Cohen Arazi 2008-02-01 14:22:06 UTC
Created attachment 142388 [details]
MARC-XML-0.88 ebuild
Comment 6 Tomas Cohen Arazi 2008-02-01 14:22:21 UTC
Created attachment 142389 [details]
Net-Z3950-ZOOM-1.21 ebuild
Comment 7 Tomas Cohen Arazi 2008-02-01 14:22:35 UTC
Created attachment 142391 [details]
Business-ISBN-2.03 ebuild
Comment 8 Tomas Cohen Arazi 2008-02-01 14:22:53 UTC
Created attachment 142393 [details]
Unicode-Normalize-1.02 ebuild
Comment 9 Tomas Cohen Arazi 2008-02-01 14:23:13 UTC
Created attachment 142395 [details]
Test-More-Diagnostic-0.2 ebuild
Comment 10 Tomas Cohen Arazi 2008-03-20 18:44:53 UTC
I'd like to become maintainer of these packages.
Comment 11 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-10-27 15:39:09 UTC
The following packages have been added to the tree by robbat2 and tove:

MARC-Charset-1.0
MARC-Record-2.0.0
MARC-XML-0.88
Net-Z3950-ZOOM-1.25
Comment 12 Chan Min Wai 2009-01-30 03:19:12 UTC
In the new version 3 Koha. the following perl modules are required.

 HTML::Template::Pro 
 MARC::Crosswalk::DublinCore
 PDF::Reuse 
 SMS::Send

Comment 13 me 2009-03-16 21:59:11 UTC
(In reply to comment #12)
> In the new version 3 Koha. the following perl modules are required.
and some more, see #262723, #262721, #262718, #262717, #262715, #262712
or the tickets behind the requested packages below:
>  HTML::Template::Pro 
#262726
>  MARC::Crosswalk::DublinCore
#262728
>  PDF::Reuse 
#262729 and #262732 for PDF-Reuse-Barcode
>  SMS::Send
#262735
> 

Comment 14 Agryppa 2009-08-16 12:28:12 UTC
Is there an ebuild for koha yet? I don't see any in the attachments. 
I am looking forward to seeing one. It seems to be quite of a challenge to write one for koha because there are many non-standard things to be done during koha's setup. 

should I file a bug or just wait here for one?

thanks
Comment 15 Agryppa 2009-08-18 16:30:07 UTC
(In reply to comment #0)
> In order to support the install of Koha (http://koha.org) in Gentoo(*) there
> are some dependencies to be satisfied.


The dependencies that Makefile.PL lists are the following;

'Algorithm::CheckDigits'           => 0.50,
                            'Biblio::EndnoteStyle'             => 0.05,
                            'CGI'                              => 3.15,
                            'CGI::Carp'                        => 1.29,
                            'CGI::Session'                     => 4.20,
                            'CGI::Session::Serialize::yaml'    => 4.20,
                            'Class::Factory::Util'             => 1.6,
                            'Class::Accessor'                  => 0.30,
                            'DBD::mysql'                       => 4.004,
                            'DBI'                              => 1.53,
                            'Data::Dumper'                     => 2.121,
                            'Data::ICal'                       => 0.13,
                            'Date::Calc'                       => 5.4,
                            'Date::ICal'                       => 1.72,
                            'Date::Manip'                      => 5.44,
                            'Digest::MD5'                      => 2.36,
                            'Email::Date'                      => 1.103,
                            'File::Temp'                       => 0.16,
                            'GD'                               => 2.39,    #optional
                            'GD::Barcode::UPCE'                => 1.1,
                            'Getopt::Long'                     => 2.35,
                            'Getopt::Std'                      => 1.05,
                            'HTML::Template::Pro'              => 0.69,
                            'HTML::Scrubber'                   => 0.08,
                            'HTTP::Cookies'                    => 1.39,
                            'HTTP::OAI'                        => 3.20,
                            'HTTP::Request::Common'            => 1.26,
                            'JSON'                             => 2.07, # Needed by admin/item_circulation_alerts.pl
                            'LWP::Simple'                      => 1.41,
                            'LWP::UserAgent'                   => 2.033,
                            'Lingua::Stem'                     => 0.82,
                            'List::Util'                       => 1.18,
                            'List::MoreUtils'                  => 0.21,
                            'Locale::Language'                 => 2.07,
                            'MARC::Charset'                    => 0.98,
                            'MARC::Crosswalk::DublinCore'      => 0.02,
                            'MARC::File::XML'                  => 0.88,
                            'MARC::Record'                     => 2.00,
                            'MIME::Base64'                     => 3.07,
                            'MIME::Lite'                       => 3.00,
                            'MIME::QuotedPrint'                => 3.07,
                            'Mail::Sendmail'                   => 0.79,
                            'Net::LDAP'                        => 0.33, # optional
                            'Net::LDAP::Filter'                => 0.14, # optional
                            'Net::Z3950::ZOOM'                 => 1.16,
                            'PDF::API2'                        => 2.000,
                            'PDF::API2::Page'                  => 2.000,
                            'PDF::API2::Util'                  => 2.000,
                            'PDF::Reuse'                       => 0.33,
                            'PDF::Reuse::Barcode'              => 0.05,
                            'POE'                              => 0.9999,
                            'POSIX'                            => 1.09,
                            'Schedule::At'                     => 1.06,
                            'SMS::Send'                        => 0.05, # optional
                            'Term::ANSIColor'                  => 1.10,
                            'Test'                             => 1.25,
                            'Test::Harness'                    => 2.56,
                            'Test::More'                       => 0.62,
                            'Text::CSV'                        => 0.01,
                            'Text::CSV_XS'                     => 0.32,
                            'Text::Iconv'                      => 1.7,
                            'Text::Wrap'                       => 2005.082401,
                            'Time::HiRes'                      => 1.86,
                            'Time::localtime'                  => 1.02,
                            'Unicode::Normalize'               => 0.32,
                            'XML::Dumper'                      => 0.81,
                            'XML::LibXML'                      => 1.59,
                            'XML::LibXSLT'                     => 1.59,
                            'XML::SAX::ParserFactory'          => 1.01,
                            'XML::SAX::Writer'                 => 0.44,
                            'XML::Simple'                      => 2.14,
                            'XML::RSS'                         => 1.31,
                            'YAML::Syck'                       => 0.71,


some of them, though, are not abligatory for the core of koha to functions. So we need to appropriate a certain number of IUSE="" flags in the ebuild.

Also, the g-cpan ebuild is supposed to take care of some of them.

Agryppa
Comment 16 Andreas K. Hüttel gentoo-dev 2014-10-15 21:31:00 UTC
Is anyone still interested in this? If yes, please say so here and now!
Comment 17 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-12-07 18:48:11 UTC
Seems not.