Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 207330 - net-irc/xchat-xsys needs audacious built with dbus support
Summary: net-irc/xchat-xsys needs audacious built with dbus support
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
: 208606 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-25 00:19 UTC by elprespufferfish
Modified: 2008-02-02 18:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elprespufferfish 2008-01-25 00:19:08 UTC
xchat-xsys-2.2.0 fails to build if audacious is not built with dbus support

Reproducible: Always

Steps to Reproduce:
1. USE="-dbus" emerge audacious
2. emerge xchat-xsys
Actual Results:  
xsys.c:32:31: error: audacious/audctrl.h: No such file or directory
xsys.c:43: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'dbus_init'
xsys.c:66: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
xsys.c:67: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token
xsys.c: In function 'xchat_plugin_init':
xsys.c:111: warning: implicit declaration of function 'dbus_init'
xsys.c: At top level:
xsys.c:168: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'dbus_init'
xsys.c: In function 'np_cb':
xsys.c:690: warning: implicit declaration of function 'audacious_remote_get_playlist_pos'
xsys.c:690: error: 'dbus_proxy' undeclared (first use in this function)
xsys.c:690: error: (Each undeclared identifier is reported only once
xsys.c:690: error: for each function it appears in.)
xsys.c:692: warning: implicit declaration of function 'audacious_remote_is_running'
xsys.c:698: warning: implicit declaration of function 'audacious_remote_get_output_time'
xsys.c:699: warning: implicit declaration of function 'audacious_remote_get_playlist_time'
xsys.c:700: warning: implicit declaration of function 'audacious_remote_get_playlist_title'
xsys.c:700: warning: passing argument 1 of 'decruft_filename' makes pointer from integer without a cast
Comment 1 Tony Vroon gentoo-dev 2008-01-25 22:23:56 UTC
eerror "Unsupported configuration: D-Bus disabled"
ewarn "D-Bus has been disabled. Note that audtool will not be provided, you will not"
ewarn "be to able to get song information from scripts or control the player remotely."
ewarn "This configuration is provided for people heavily opposed to D-Bus that are able "
ewarn "to live with the loss of functionality that this implies. Reports about remote "
ewarn "control or multiple instances of Audacious being launched will be *closed*."

As clearly announced in the audacious ebuild, this bug report will be closed. If you disagree with the functionality provided by the dbus USE-flag, please take it up with the reporter and commenter on bug #199069.
Note that these warnings *will* have been displayed on your terminal as portage buffers these messages and will display them at the end of a merge.
Comment 2 elprespufferfish 2008-01-26 01:05:01 UTC
May I suggest that the xchat-xsys ebuild be altered to notify the user to rebuild audacious with dbus support if it wasn't enabled initially?

if built_with_use --missing true  media-sound/audacious dbus ; then
                        eerror "You MUST build media-sound/audacious with the dbus USE flag"

Something like that?
Comment 3 Tony Vroon gentoo-dev 2008-01-29 12:29:52 UTC
Unsupported. That means it is not supported. As such, you do not file bugs about it. The message will have been displayed clearly on your screen. If you do not agree with having this USE-flag, bug #199069 has the contact details of the people you'll want to talk to.
Closing.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-02-02 17:59:10 UTC
*** Bug 208606 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-02 18:01:32 UTC
Why don't you enable the flag by default via EAPI-1?
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2008-02-02 18:08:06 UTC
*** Bug 208606 has been marked as a duplicate of this bug. ***