Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20697 - remove gpm and xemacs cannot work
Summary: remove gpm and xemacs cannot work
Status: RESOLVED DUPLICATE of bug 1991
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: CVS/SVN/Git (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-09 07:58 UTC by François Dupoux
Modified: 2011-10-30 22:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description François Dupoux 2003-05-09 07:58:52 UTC
First, I installed xemacs. gpm was already installed for a long time. I decided to remove 
gpm (emerge unmerge sys-libvs/gpm). xemacs cannot start: 
# xemacs -nw /etc/X11/XF86Config 
xemacs: error while loading shared libraries: libgpm.so.1: cannot open shared object 
file: No such file or directory 
 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Jon Portnoy (RETIRED) gentoo-dev 2003-05-09 11:16:57 UTC
This is expected behavior: xemacs will link against gpm for mouse support.

Recompiling it should fix it.
Comment 2 Martin Holzer (RETIRED) gentoo-dev 2003-05-09 12:51:42 UTC

*** This bug has been marked as a duplicate of 1991 ***