Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206965 - media-video/mplayer brings in a local copy of libogg
Summary: media-video/mplayer brings in a local copy of libogg
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-22 00:28 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-02-11 07:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-01-22 00:28:20 UTC
Symbol ogg_packet_clear@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_bos@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_checksum_set@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_continued@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_eos@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_granulepos@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_packets@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_pageno@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_serialno@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer
Symbol ogg_page_version@@ (64-bit UNIX System V ABI AMD x86-64 architecture) present 3 times
  /usr/bin/mencoder
  /usr/lib64/libogg.so.0.5.3
  /usr/bin/mplayer

comes from tremor support. It's nice to know that mplayer  _links_ to libogg already...
Comment 1 Luca Barbato gentoo-dev 2008-02-11 07:40:18 UTC
the problem isn't exactly simple to fix since tremor is an embedded vorbis implementation and has a tinylibogg inside itself, I'll check with the other diego what to do soonish (ping me if I don't come with replies in few days)