Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206538 - media-gfx/phatch (new ebuild)
Summary: media-gfx/phatch (new ebuild)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Default Assignee for New Packages
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Reported: 2008-01-18 16:37 UTC by Bjoern Olausson
Modified: 2022-04-26 00:01 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

media-gfx/phatch-0.1_pre222.ebuild (phatch-0.1_pre222.ebuild,532 bytes, text/plain)
2008-01-18 16:38 UTC, Bjoern Olausson
media-gfx/phatch-0.1.3.ebuild (phatch-0.1.3.ebuild,486 bytes, text/plain)
2008-05-01 16:43 UTC, Marco Corbetta
New Ebuild for version 0.1.5 of Phatch (phatch-0.1.5.ebuild,486 bytes, text/plain)
2008-09-29 08:27 UTC, Oswald
new Ebuild for phatch-0.1.5 without sandbox problens (phatch-0.1.5-r1.ebuild,751 bytes, text/plain)
2008-11-06 23:43 UTC, Otavio
The patch to fix the sandbox problem (phatch-0.1.5.patch,1018 bytes, patch)
2008-11-06 23:45 UTC, Otavio
Details | Diff
Ebuild for phatch-0.2.7. The patch team fixed so the patch is no longer necessary. (phatch-0.2.7.ebuild,744 bytes, text/plain)
2010-04-08 15:53 UTC, Otavio
added sys-apps/mlocate dependency (phatch-0.2.7-r1.ebuild,762 bytes, text/plain)
2010-12-29 14:14 UTC, Lia

Note You need to log in before you can comment on or make changes to this bug.
Description Bjoern Olausson 2008-01-18 16:37:58 UTC
Phatch is a simple to use cross-platform GUI Photo Batch Processor which handles all popular image formats and can duplicate (sub)folder hierarchies. Phatch can batch resize, rotate, rename, ... and more in minutes instead of hours or days if you do it manually. Phatch will also support a console version in the future to batch photos on webservers.

Reproducible: Always
Comment 1 Bjoern Olausson 2008-01-18 16:38:45 UTC
Created attachment 141230 [details]
Comment 2 Marco Corbetta 2008-05-01 16:41:23 UTC
New version with a light modified ebuild.
Version 0.1.3

Comment 3 Marco Corbetta 2008-05-01 16:43:06 UTC
Created attachment 151541 [details]
Comment 4 Jan Boros 2008-05-02 10:26:47 UTC
I have a problem to install this program.
here is the error message :

copying phatch/linux/lib/ -> build/lib/phatch/linux/lib
package init file 'phatch/templates/' not found (or not a regular file)
running build_scripts
creating build/scripts-2.4
copying and adjusting bin/phatch -> build/scripts-2.4
changing mode of build/scripts-2.4/phatch from 644 to 755
update-mime-database: I don't have write permission on /usr/share/mime.
Try rerunning me as root.

Updating the mime types database.
ACCESS DENIED  open_wr:   /usr/share/applications/.mimeinfo.cache.ULZOAU
No directories in update-desktop-database search path could be processed and updated.
Updating the .desktop file database.

Installation finished! You can now run Phatch by typing 'phatch' 
or through your applications menu.
>>> Source compiled.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-6109.log"

open_wr:   /usr/share/applications/.mimeinfo.cache.ULZOAU
Comment 5 Marco Corbetta 2008-05-02 13:19:04 UTC
Sorry i don't know how to suppress sandbox violation in the right way.
At the moment i emerged this with FEATURES="-sandbox" and it works, but i don't think it is a good idea recommending this method.
Comment 6 Bjoern Olausson 2008-05-03 17:22:39 UTC
I'll have a look into this. Give me some days (busy right now)
Comment 7 Bjoern Olausson 2008-06-03 06:39:26 UTC
mpf I got still problems compiling dev-python/wxpython ... hang on ;-)
Comment 8 Oswald 2008-09-29 08:27:07 UTC
Created attachment 166742 [details]
New Ebuild for version 0.1.5 of Phatch


I changed the download location as the 0.1.3 version doesn't seem to be available anymore. I didn't make any other changes to the ebuild. It still errors out with the Sandbox-Violation error mentioned above. I don't have the knowledge to resolve such an error, sry!

Greetings, Oswald
Comment 9 Otavio 2008-11-06 23:43:41 UTC
Created attachment 170949 [details]
new Ebuild for phatch-0.1.5 without sandbox problens

The sandbox violation happens because the tried to update the mime database during the installation. I removed that and changed the ebuild to do it after the installation. I am not an ebuild expert, but these changes worked for me.
Comment 10 Otavio 2008-11-06 23:45:01 UTC
Created attachment 170950 [details, diff]
The patch to fix the sandbox problem

I used this patch in the ebuild above.
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2009-04-14 18:32:22 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

On behalf of the Gentoo Sunrise Team,

Comment 12 Otavio 2010-04-08 15:53:46 UTC
Created attachment 227023 [details]
Ebuild for phatch-0.2.7. The patch team fixed so the patch is no longer necessary.
Comment 13 rob miller 2010-06-25 07:30:55 UTC
> Ebuild for phatch-0.2.7. 

I find that I python-2.5 is a dependency.  On first attempt with this ebuild I had python 2.6.5-r2 and 3.1.2-r3 slotted and the ebuild succeeded but phatch crashed.  Upon emerging python 2.5.4-r4 it seems to be working.
Comment 14 Sergey Ilinykh 2010-06-27 06:18:44 UTC
its possible to use my overlay (layman -a rion) to install phatch.
btw works fine with python-2.6
Comment 15 Christian Faulhammer (RETIRED) gentoo-dev 2010-10-24 12:04:37 UTC
The ebuild found in looks like it meets a good ebuild standard.  Is anybody interested to take this over?  I could proxy-maintain for you, this means I commit the stuff to the official Portage tree while you answer all bugs and inform me about updates/fixes.  Should be not too much work.

Comment 16 Lia 2010-12-29 14:14:41 UTC
Created attachment 258353 [details]
added sys-apps/mlocate dependency
Comment 17 Denilson Sá Maia 2011-03-11 14:03:36 UTC
(In reply to comment #14)
> its possible to use my overlay (layman -a rion) to install phatch.
> btw works fine with python-2.6

Would you mind adding this to sunrise? I don't want to use your overlay because it contains ebuilds that will take precedence over portage ones. In special, I'm thinking about dev-libs/nss.