Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 205949 - <=media-sound/vkeybd-0.1.17a fails to compile w/ linux-headers-2.6.23
Summary: <=media-sound/vkeybd-0.1.17a fails to compile w/ linux-headers-2.6.23
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard: Needs a version bump to at least 0.1.17b
Keywords:
: 216928 (view as bug list)
Depends on:
Blocks: sane-linux-headers
  Show dependency tree
 
Reported: 2008-01-15 13:24 UTC by trurl
Modified: 2008-04-10 08:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description trurl 2008-01-15 13:24:49 UTC
The current x86 stable version of vkeybd (0.1.15-r2) fails to compile with kernel 2.6.23.

Error message:
oper_awe.c:35:31: error: linux/awe_voice.h: No such file or directory

A little googling suggested that this is because the file /include/linux/awe_voice.h has been removed as of kernel-2.6.22. The testing version (0.1.17a) fails similarly.

Version 0.1.17b of vkeybd fixes this, it can be found here http://www.gtlib.gatech.edu/pub/suse/people/tiwai/vkeybd/


Reproducible: Always

Steps to Reproduce:
1.emerge vkeybd
2.
3.

Actual Results:  
emerge fails with:
oper_awe.c:35:31: error: linux/awe_voice.h: No such file or directory


emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
=================================================================
System uname: 2.6.23-gentoo-r3 i686 AMD Athlon(tm) 64 Processor 3400+
Timestamp of tree: Tue, 15 Jan 2008 09:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /usr/X11R6/bin/startx"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks metadata-transfer noinfo parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LINGUAS="en fi"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://trumpetti.atm.tut.fi/gentoo-portage/"
USE="3dnow 3dnowext 7zip X Xaw3d a52 aac aalib accessibility acl acpi alsa arts asf audiofile avi bash-completion berkdb bidi bitmap-fonts branding bzip2 bzlib cairo caps cdda cddb cdio cdparanoia cdr chardet cjk cli cpudetection cracklib crypt css cups custom-cflags dbus dga divx divx4linux djbfft dlloader dmi dri dssi dts dv dvd dvdr dvdread edl emboss encode ess evo exif faad fam fame fbcon ffmpeg fftw firefox flac foomaticdb fortran fpx freetype fuse gd gdbm gif gimp gimpprint glibc-omitfp glitz glut gmedia gnutls gphoto2 gpm graphviz gs gtk hal httpd iconv ieee1394 imagemagick imlib ipod isdnlog jack jack-tmpfs jackmidi java javascript jbig jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kdexdeltas kdgraphics kerberos kipi ladspa lame latex lcms ldap libcaca libedit libsamplerate lirc live lm_sensors lzo mad matroska midi mikmod mjpeg mmx mng mod modplug mp3 mp4 mpeg mpeg4 mplayer mudflap musepack musicbrainz ncurses network nls nptl nptlonly nsplugin nvidia offensive ogg oggvorbis ooo-kde openal openexr opengl openmp osc oss pam pcre pdf perl pic png portaudio ppds pppd python qt qt3 qt3support qt4 quicktime readline real realmedia reflection resid rtc scanner screen sdl session sid skins sndfile socks5 soundtouch sox speex spell spl sse sse2 ssl stream subtitles svg svga tcpd tga theora threads tiff timidity toolbar transcode truetype truetype-fonts type1 type1-fonts unicode usb v4l v4l2 vcd videos visualization vlm vorbis vst wavpack win32codecs wma wmf wmp wxwindows x11 x264 x86 xanim xattr xcomposite xine xml xorg xosd xprint xscreensaver xv xvid xvmc zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fi" LIRC_DEVICES="livedrive_midi" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-01-17 18:13:18 UTC
FWIW 0.1.18 is also available.
Comment 2 Alexis Ballier gentoo-dev 2008-01-26 22:17:38 UTC
bumped to 0.1.17b

0.1.18 tarball seems crippled, a .tar.bz2 which is in fact a tar and I couldnt find the pixmaps subdirectory thus make install failed
Comment 3 Samuli Suominen gentoo-dev 2008-04-10 08:15:00 UTC
*** Bug 216928 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2008-04-10 08:24:38 UTC
10 Apr 2008; Samuli Suominen <drac@gentoo.org>
-files/vkeybd-0.1.15-makefile.patch, -files/vkeybd-0.1.17a-makefile.patch,
-vkeybd-0.1.15-r2.ebuild, -vkeybd-0.1.17a.ebuild, vkeybd-0.1.17b.ebuild:
amd64/x86 stable, because current linux-headers doesn't provide awe_voice.h
wrt #205949, #216928

And closing.