Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 20594 - Filmgimp 0.16 ebuild can't find OpenEXR library, ebuild needs a flag
Summary: Filmgimp 0.16 ebuild can't find OpenEXR library, ebuild needs a flag
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-07 14:27 UTC by Willie Sippel
Modified: 2003-08-24 06:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
The modified ebuild. (filmgimp-0.16-r1.ebuild,799 bytes, text/plain)
2003-05-07 14:30 UTC, Willie Sippel
Details
The modified ebuild (dupe). (filmgimp-0.16-r1.ebuild,799 bytes, text/plain)
2003-05-07 14:30 UTC, Willie Sippel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willie Sippel 2003-05-07 14:27:03 UTC
I don't know where Filmgimp searches for the OpenEXR library, but it doesn't seem to look in 
/usr/lib, so the .ebuild has to be edited: 
 
In line 22, after '--with-gnu-ld', '--with-openexr-prefix=/usr' needs to be added (without the 
quotes, of course...). 
 
This shouldn't break anything even if OpenEXR is not installed. 
OpenEXR get's installed in /usr/lib using the ebuild. 
 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Willie Sippel 2003-05-07 14:30:18 UTC
Created attachment 11653 [details]
The modified ebuild.
Comment 2 Willie Sippel 2003-05-07 14:30:58 UTC
Created attachment 11654 [details]
The modified ebuild (dupe).
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2003-08-24 06:03:39 UTC
 now cinepaint