Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20593 - Metalog prevents most pcmcia slots from being detected
Summary: Metalog prevents most pcmcia slots from being detected
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Mobile Herd (OBSOLETE)
Depends on: 8607
  Show dependency tree
Reported: 2003-05-07 14:06 UTC by Roger
Modified: 2004-12-29 06:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Roger 2003-05-07 14:06:19 UTC
With metalog installed, I found that it was preventing all of my pcmcia/cardbus
slots from being detected (using pcmcia-cs) or being used.  After uninstalling
metalog and installing sysklogd, both the slots worked instead of just one of
them.  This bug might be related to #8607

Reproducible: Always
Steps to Reproduce:
1. Use metalog as the logger
2. install pcmcia_cs for your laptop
3. reboot the system

Actual Results:  
only one pcmcia/cardbus slot worked and not both

Expected Results:  
it shouldn't conflict with pcmcia_cs package.

I'm betting that this isn't the only package that metalog conflicts with and
that there are many more besides the "procmail, postfix, spamassassin" package
combo that I listed in bug #8607.

So far, the symptoms of this metalog bug is to the extent of hardware & software
not working at all (which includes system hangs & freezes).

If a system is left on long enough where services requiring root access are run
and cause a hang, the system will hang to the point of a system freeze requiring
the power button to be used (ie no magic sys keys will be able to properly
umount many of the harddrives attached).

Comment 1 Grant Goodyear (RETIRED) gentoo-dev 2003-05-13 12:59:33 UTC
I can't reproduce this problem, so tossing back into the bug-wranglers pool.
Comment 2 Roger 2003-05-13 14:34:17 UTC
mm...dunno why i said "ALL" pcmcia/cardbus slots.  should read "only one of my cardbus/pcmcia slots worked".

i'll bet the bug has something todo with the logger borking after finding the first slot.
Comment 3 Boyd Waters 2003-08-19 10:55:43 UTC
I have a Dell Inspiron 8000 PIII coppermine, 512MB RAM, never noticed a problem with 
metalog and pcmcia slots. Both slots seem to work fine. I have always used metalog... 
Note that, on this model Dell, you MUST modify the pcmcia memory probe range in 
/etc/pcmcia/config.opts: remove port 0x800-0x8ff. Otherwise it locks up when pcmcia is 
Absent of that, I have noticed no terrible problems with pcmcia at run time. (Compile time is 
another story...) 
Comment 4 Roger 2003-08-22 15:37:54 UTC
Negative on that.  The remove "0x800-0x8ff" memory location is already well documented and can be found at the following "Howto install Gentoo/Debian on a Dell Inspiron 8000/8100".

I found meta-log too budgy for my needs and have switched to a the more stabled syslog-ng.

I believe the bug has already been documented (on the metalog mailling list?) and had a pending release with the fix, but there hasn't been a newer version for sometime released.  
Comment 5 Roger 2003-08-22 15:43:03 UTC
Forgot the url incase you're wondering:
Debian and Gentoo GNU/Linux on the Dell Inspiron 8000/8100

If i'm not mistakened, the two laptops (8000's & 8100's) use diff chips and h/w.  
Comment 6 Heinrich Wendel (RETIRED) gentoo-dev 2003-12-01 12:30:53 UTC
please try out metalog-0.8_pre20031130
Comment 7 Andrew Cooks 2004-08-08 01:47:05 UTC
This bug has been inactive for more than 90 days.

Can this be closed as a TEST REQUEST?
Comment 8 Roger 2004-08-09 14:02:20 UTC
I've been using syslog-ng for quite some time now.  And never went back to test metalog further as I ran into some trouble and ran out of free time.

I would say, close this bug.  Although I do find it funny that a logger would create a port conflict, removing metallog from init.d did resolve the pcmcia services issue.  I appear to have no problems with the livecd.  So go figure.

I'm sure I would have been able to track the issue down, but again, I don't have the time!
Comment 9 Doug Goldstein (RETIRED) gentoo-dev 2004-09-22 09:23:53 UTC
We need some testing on this problem to be able to fix it since no one has the configuration which caused the problem anymore... Can't do anything about it. The other devs that use metalog can't seem to duplicate this problem. So... if you run into this situation again... Please reopen.
Comment 10 Henrik Brix Andersen 2004-12-29 06:13:45 UTC
Closing due to lack of feedback.