Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 205728 - net-im/palaver-0.5 - multi-user chat component for Jabber (New package)
Summary: net-im/palaver-0.5 - multi-user chat component for Jabber (New package)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://onlinegamegroup.com/projects/p...
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2008-01-14 01:38 UTC by Manuel Friedli
Modified: 2021-08-16 00:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for palaver-0.5 (palaver-0.5.ebuild,1.38 KB, text/plain)
2008-01-14 01:39 UTC, Manuel Friedli
Details
Init script for palaver-0.5 (palaver-0.5-initd,591 bytes, text/plain)
2008-01-14 01:40 UTC, Manuel Friedli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Friedli 2008-01-14 01:38:20 UTC
Currently, the only chat-component for jabber included in the portage tree is net-im/mu-conference (afaik), which doesn't seem to be under very active development. There is another implementation of a multi-user chat, called Palaver. It's implemented in python, similar to the Py{AIM,ICQ,MSN}-transports. I suggest that this package be included in portage.
I wrote an ebuild and installed it on my box just a few minutes ago. It seems to be working (as far as I can tell, after some very brief testing). I'll attach it here, plus you can check it out from my overlay via SVN at https://svn.fritteli.ch/gentoo-overlay/net-im/palaver
This is my first "big" ebuild, so I'm happy if you tell me what to improve.

Reproducible: Always

Steps to Reproduce:
1. emerge palaver
2.
3.

Actual Results:  
"emerge: there are no ebuilds to satisfy "palaver"."

Expected Results:  
palaver should be smoothly installed :)

I'm running jabberd2-2.1.19 on x86. My Ebuild doesn't check for jabberd/jabberd2/ejabberd/whatever, so there's probably some work needed. But as I'm not very experienced with writing ebuilds, I just did it as best I could.

Output of emerge --info:
Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-hardened-r8 i686)
=================================================================
System uname: 2.6.22-hardened-r8 i686 Pentium III (Coppermine)
Timestamp of tree: Sun, 13 Jan 2008 02:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer -fstack-protector"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -pipe -fomit-frame-pointer -fstack-protector"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo http://distfiles.gentoo.org"
LANG="de_CH.UTF-8"
LINGUAS="en de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/fritteli"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="apache2 authdaemond bash-completion bzip2 cli cracklib crypt ctype cups curl curlwrappers enscript exif fam fastbuild fasttrack gd gencertdaily gnutella iconv idn imagemagick innodb ipv6 isdnlog jabber jpeg jpeg2k madwifi magic memlimit minimal mmx mmxext mudflap mysql mysqli ncurses nls nptl nptlonly offensive ogg pam pcre php png posix python readline reiserfs sasl session sockets spl sse ssl subversion suhosin sysvipc tcpd threads truetype unicode urandom usb vhosts x86 xml xmlrpc xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" FRITZCAPI_CARDS="fcpci" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Manuel Friedli 2008-01-14 01:39:21 UTC
Created attachment 140911 [details]
ebuild for palaver-0.5
Comment 2 Manuel Friedli 2008-01-14 01:40:20 UTC
Created attachment 140912 [details]
Init script for palaver-0.5

Palaver is started via twistd. I have no clue if I did this correctly with this init-script, at least it starts up correctly :)
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-14 18:31:15 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 4 Manuel Friedli 2021-08-16 00:47:41 UTC
I don't believe the palaver project even exists at all by now, so let's just close this bug.