Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 205503 - net-im/gnome-jabber-0.4 fails to compile (bad autotools foo?)
Summary: net-im/gnome-jabber-0.4 fails to compile (bad autotools foo?)
Status: RESOLVED DUPLICATE of bug 152940
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on: 152940
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-01-12 17:21 UTC by Evil Compile Person
Modified: 2008-11-21 17:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evil Compile Person 2008-01-12 17:21:41 UTC
>>> Unpacking source...
>>> Unpacking gnome-jabber-0.4.tar.bz2 to /var/tmp/portage/net-im/gnome-jabber-0.4/work
You should update your 'aclocal.m4' by running aclocal.
 * Running eautoreconf in '/var/tmp/portage/net-im/gnome-jabber-0.4/work/gnome-jabber-0.4' ...
 * Running aclocal ...                                                    [ !! ]

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-im/gnome-jabber-0.4/temp/aclocal-16407.out

 *
 * ERROR: net-im/gnome-jabber-0.4 failed.

***** aclocal *****

am-wrapper: /usr/bin/aclocal-1.7 is missing or not executable.
            Please try emerging the correct version of automake.

Portage 2.1.4_rc14 (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.7-r1, 2.6.23-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r1 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Timestamp of tree: Mon, 07 Jan 2008 19:00:08 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.1-r5
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/svn/env /usr/kde/svn/share/config /usr/kde/svn/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://localhost/gentoo-portage"
USE="X acl amd64 berkdb bitmap-fonts cli cracklib crypt cups dri fortran gcj gdbm gpm iconv ipv6 isdnlog midi mmx mudflap ncurses nls nptl nptlonly objc openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl tcpd truetype-fonts type1-fonts unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-06-29 14:14:50 UTC
please note that setting WANT_AUTOMAKE before inherit autotools would spare you the need to add a buggy depend in DEPEND.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-10-11 18:38:20 UTC
actually this project is dead and upstream dev moved to gossip.

Seen on http://gnome-jabber.sourceforge.net/:

 [28/10/05] - Gnome Jabber a dead project!
Gnome Jabber has not been developed for some time now and since I moved over to work on Gossip and am now one of two maintainers on the project I am dropping any support for Gnome Jabber.

The page will still remain here for people to use it they want to and there is a windows version (which was in beta stages when I stopped working on it) to download and try if you want.

Thanks for all the support people gave on this project! 

-----------------

shall we pass this over to treecleaners ?
Comment 3 Olivier Crete (RETIRED) gentoo-dev 2008-11-21 17:21:43 UTC
Use gossip or a newer jabber client, gnome-jabber is dead

*** This bug has been marked as a duplicate of bug 152940 ***