Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 20533 - can't use alsa-driver 0.9.3 with my cs4236 sound card
Summary: can't use alsa-driver 0.9.3 with my cs4236 sound card
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Arcady Genkin (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-06 10:09 UTC by Andrew Kirilenko
Modified: 2003-05-22 13:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Kirilenko 2003-05-06 10:09:18 UTC
I just emerged new alsa-driver 0.9.3 and when /etc/init.d/alsasound start it
prints that snd-pnp taints the kernel (not under gpl license) and don't want to
load cs4236.o module at all. When downgraded to alsa 0.9.2 - everything is OK.

Reproducible: Always
Steps to Reproduce:
Just emerge alsa-0.9.3 with cs4236 card.

Actual Results:  
See above.

Expected Results:  
See above.

System uname: 2.4.20-gentoo-r3 i686 Celeron (Mendocino)
GENTOO_MIRRORS="http://gentoo.oregonstate.edu/
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
PORTDIR="/usr/portage"
DISTDIR="/usr/portage/distfiles"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR_OVERLAY=""
USE="x86 -3dfx -3dnow aalib -acl -acpi -afs alsa apache2 apm -arts -atlas avi
berkdb -bonobo -canna -cdr -cjk crypt cups curl dga -directfb -doc -dvb -dvd
-emacs encode -esd -ethereal -ev6 -evo -fbcon -firebird -flash -freetds -freewnn
-gb gd -gdbm -ggi gif -gnome -gphoto2 -gpm -gps gtk gtk2 -gtkhtml -guile -icc
-iccpgo -imap imlib innodb ipv6 -java -jikes jpeg -junit -kde -kerberos -ladcca
-lcms -ldap -leim -libg++ -libgda libwww -lirc maildir matrox mbox -mikmod mmx
motif -mozilla mpeg -mpi -mule mysql -nas ncurses -nhc98 nls nocardbus oav -oci8
odbc oggvorbis opengl oss pam -pcmcia -pda pdflib perl -plotutils png -pnp
-postgres prebuilt python -qt quicktime readline -ruby samba -sasl -scanner sdl
-selinux slang slp -snmp -socks5 spell sse ssl -svga tcltk tcpd -tetex tiff
truetype usb -voodoo3 wmf X -Xaw3d -xface -xinerama xml xml2 -xmms -xv -zeo zlib"
COMPILER="gcc3"
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=pentium2 -mcpu=pentium2 -O3 -pipe"
CXXFLAGS="-march=pentium2 -mcpu=pentium2 -O3 -pipe"
ACCEPT_KEYWORDS="x86 ~x86"
MAKEOPTS="-j2"
AUTOCLEAN="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
FEATURES="sandbox ccache"
Comment 1 Narada Sage 2003-05-06 20:12:11 UTC
I am using alsa-driver-0.9.3a with the cs46xx driver and /etc/init.d/alsasound start loads sound as normal.  I also emerged alsa-lib, alsa-utils and alsa-tools of version 0.9.3.  The only difference I can see between our configurations is that I have ALSA_CARDS="cs46xx" in my /etc/make.conf so that when it compiles with that card in mind.  I can post further details such as /etc/modules.d/alsa if you would like for comparison.
Comment 2 John Youells 2003-05-07 12:31:54 UTC
alsa-driver-0.9.3a also will not load with my ISA 4237B sound card (uses the cs4236.o modules...) Error msg indicates trouble with pnp. Alsa-driver 0.9.2 works fine.
Comment 3 Andrew Kirilenko 2003-05-22 06:54:43 UTC
The problem was solved with alsa-drivers-0.9.3c. So it's time to close this bug.
Comment 4 Arcady Genkin (RETIRED) gentoo-dev 2003-05-22 13:09:29 UTC
Great, thanks for letting us know.