Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204687 - dev-cpp/gtkmm-2.12.3 GCC 4.3 build failure
Summary: dev-cpp/gtkmm-2.12.3 GCC 4.3 build failure
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: GNOME C++ Bindings Maintainers (OBSOLETE)
URL:
Whiteboard:
Keywords:
: 207354 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-01-06 23:57 UTC by Ryan Hill (RETIRED)
Modified: 2008-02-12 04:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gtkmm-2.12.3-gcc-4.3-include.patch (gtkmm-2.12.3-gcc-4.3-include.patch,1.09 KB, patch)
2008-01-06 23:58 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hill (RETIRED) gentoo-dev 2008-01-06 23:57:34 UTC
Again, just missing a couple #include <cstring>'s.

scale.cc: In function 'gchar*<unnamed>::Scale_signal_format_value_callback(GtkScale*, gdouble, void*)':
scale.cc:145: error: 'strlen' was not declared in this scope
scale.cc: In static member function 'static gchar* Gtk::Scale_Class::format_value_callback(GtkScale*, gdouble)':
scale.cc:315: error: 'strlen' was not declared in this scope
make[5]: *** [scale.lo] Error 1
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-01-06 23:58:02 UTC
Created attachment 140330 [details, diff]
gtkmm-2.12.3-gcc-4.3-include.patch
Comment 2 Rémi Cardona gentoo-dev 2008-01-07 12:39:05 UTC
Ryan, I've seen a couple of your last blog posts about g++ 4.3. Did you send those patches to upstream devs? Although I'd be more than happy to apply your patches, I'd rather upstream published new tarballs.

And thanks for your work on g++ 4.3, I'm looking forward to seeing it hit ~arch :)
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2008-01-07 23:06:59 UTC
sorry, i meant to mention that.  these changes are upstream, so we can wait til the next release, 2.12.4 or whichever.
Comment 4 milan hodoscek 2008-01-25 08:51:08 UTC
*** Bug 207354 has been marked as a duplicate of this bug. ***
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2008-02-12 04:42:56 UTC
fixed in 2.12.4