Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204522 - Support atom wildcards in package.use
Summary: Support atom wildcards in package.use
Status: RESOLVED DUPLICATE of bug 204493
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-06 08:55 UTC by Hans de Graaff
Modified: 2008-01-11 02:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans de Graaff gentoo-dev 2008-01-06 08:55:13 UTC
What I would like to do in package use is to turn on the 'doc' USE flag for all packages in dev-ruby (with 'doc' turned off globally). Since there are a lot of ruby packages and the set I use changes on a regular basis, I'd like to add something like this to package.use:

=dev-ruby/*  doc

Currently this does not work since package.use requires full atoms.
Comment 1 Piotr Jaroszyński (RETIRED) gentoo-dev 2008-01-06 16:02:43 UTC
Why the '=' w/o version?
Comment 2 Hans de Graaff gentoo-dev 2008-01-07 07:09:50 UTC
I'm not sure. :-) The key point for me is to be able to use a wildcard for the atom, so something like 'dev-ruby/* doc' would be fine as well, or if a special character is needed to indicate that this is a wildcard for atoms, perhaps '~dev-ruby/* doc'?
Comment 3 Piotr Jaroszyński (RETIRED) gentoo-dev 2008-01-08 05:59:41 UTC
I don't think a special operator is necessary, at least in Paludis we didn't need it.
Comment 4 Piotr Jaroszyński (RETIRED) gentoo-dev 2008-01-08 06:02:37 UTC
On a somehow related note, portage currently accepts '*' as a pkgname, so you can have repo/cat/*/*-1.ebuild and that's why you don't get errors about invalid syntax if you use the '*' already :]
Comment 5 Marius Mauch (RETIRED) gentoo-dev 2008-01-11 02:17:31 UTC
(In reply to comment #4)
> On a somehow related note, portage currently accepts '*' as a pkgname,

Where?

(In reply to comment #0)
> I'd like to add something like this to package.use:
> 
> =dev-ruby/*  doc
> 
> Currently this does not work since package.use requires full atoms.

If we could implement #204493 this would be covered too.



*** This bug has been marked as a duplicate of bug 204493 ***