Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20345 - ImageMagick digest doesn't match.
Summary: ImageMagick digest doesn't match.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jon Portnoy (RETIRED)
Depends on:
Reported: 2003-05-02 16:01 UTC by Chris Paulson-Ellis
Modified: 2003-05-05 04:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Chris Paulson-Ellis 2003-05-02 16:01:35 UTC
I'm getting a digest mismatch on ImageMagick-5.5.6.tar.bz2. I tried deleting 
the file & emerge sync, but it still doesn't match.

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. rm /usr/portage/distfiles/ImageMagick-5.5.6.tar.bz2
3. emerge imagemagick

Actual Results:  
# emerge imagemagick
Calculating dependencies ...done!
>>> emerge (1 of 1) media-gfx/imagemagick-5.5.6 to /
>>> Resuming download...
>>> Downloading
           => `/usr/portage/distfiles/ImageMagick-5.5.6.tar.bz2'
Resolving done.
Connecting to[]:80... connected.
HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

    The file is already fully retrieved; nothing to do.

!!! ImageMagick-5.5.6.tar.bz2: message digests do not match!
!!! ImageMagick-5.5.6.tar.bz2 is corrupt or incomplete.
>>> our recorded digest: eac3971f0704059dcf2f7a5737b7daa8
>>>  your file's digest: 4b582b380ef866860468fb401798fc32
>>> Please delete /usr/portage/distfiles/ImageMagick-5.5.6.tar.bz2 and refetch.
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-05-04 15:50:13 UTC
same here

/space/distfiles-local contains a good file
/home/gmirror a bad one
Comment 2 Jon Portnoy (RETIRED) gentoo-dev 2003-05-04 16:47:51 UTC
Fixed. Apparently cp -u is being stupid...
Comment 3 Chris Paulson-Ellis 2003-05-05 04:35:14 UTC
Fix verified by reporter.