Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 201275 - media-tv/tvtime crashes with DISPLAY redirect
Summary: media-tv/tvtime crashes with DISPLAY redirect
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-04 21:12 UTC by Igor Ulyanov
Modified: 2011-08-13 18:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emergeinfo.txt,4.12 KB, text/plain)
2009-01-21 18:06 UTC, Igor Ulyanov
Details
emerge --info (emerge_info.txt,3.62 KB, text/plain)
2010-06-01 06:29 UTC, Jacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Ulyanov 2007-12-04 21:12:33 UTC
tvtime seems to crash due to shm memory usage, which is not shared across network


Reproducible: Always

Steps to Reproduce:
1. export DISPLAY=smth
2. tvtime

or tvtime -X smth

Actual Results:  
xvoutput: Received X error: BadAccess (attempt to access private resource denied)
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)


Expected Results:  
working tvtime window
Comment 1 Steve Dibb (RETIRED) gentoo-dev 2009-01-10 12:40:38 UTC
need version and emerge --info, if this is still a bug
Comment 2 Igor Ulyanov 2009-01-21 18:06:31 UTC
Created attachment 179187 [details]
emerge --info
Comment 3 Igor Ulyanov 2009-01-21 18:16:13 UTC
media-tv/tvtime-1.0.2-r2 (all available versions currently have this bug) and emerge --info attached
Comment 4 Jacek 2010-06-01 06:24:59 UTC
Same for me:
# tvtime -v
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /root/.tvtime/tvtime.xml
cpuinfo: CPU Intel(R) Core(TM)2 Duo CPU     E7300  @ 2.66GHz, family 6, model 7, stepping 6.
cpuinfo: CPU measured at 400.818MHz.
xcommon: Display localhost:10.0, vendor The X.Org Foundation, vendor release 10706000
xfullscreen: Single-head detected, pixel aspect will be calculated.
xfullscreen: Pixel aspect ratio on the primary head is: 764/755 == 1.01.
xfullscreen: Using the XFree86-VidModeExtension to calculate fullscreen size.
xfullscreen: Fullscreen to 0,0 with size 1280x1024.
xcommon: Have XTest, will use it to ping the screensaver.
xcommon: Pixel aspect ratio 1:1.
xcommon: Pixel aspect ratio 1:1.
xcommon: Window manager is Fluxbox and is EWMH compliant.
xcommon: Using EWMH state fullscreen property.
xcommon: Using EWMH state above property.
xcommon: Using EWMH state below property.
xcommon: Pixel aspect ratio 1:1.
xcommon: Displaying in a 768x576 window inside 768x576 space.
xvoutput: Using XVIDEO adaptor 63: NV Video Blitter.
speedycode: Using MMXEXT optimized functions.
station: Reading stationlist from /root/.tvtime/stationlist.xml
videoinput: Using video4linux2 driver 'saa7134', card 'Avermedia PCI pure analog (M135' (bus PCI:0000:05:00.0).
videoinput: Version is 527, capabilities 5010015.
videoinput: Maximum input width: 720 pixels.
tvtime: Sampling input at 720 pixels per scanline.
xvoutput: Received X error: BadAccess (attempt to access private resource denied)
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)
xcommon: Pixel aspect ratio 1:1.
xcommon: Displaying in a 768x576 window inside 768x576 space.
xcommon: Received a map, marking window as visible (64).
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)
xvoutput: Received X error: BadShmSeg (invalid shared segment parameter)
tvtime: Cleaning up.
Thank you for using tvtime.

Attached emerge --info
Comment 5 Jacek 2010-06-01 06:29:16 UTC
Created attachment 233755 [details]
emerge --info
Comment 6 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-08-13 18:06:38 UTC
(In reply to comment #0)
> tvtime seems to crash due to shm memory usage, which is not shared across
> network
> 

This seems to be a design issue. With no active upstream, we cannot do much about this.
If you can find a patch that resolves this issue, feel free to reopen the bug.
Thanks.