Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 201030 - x11-drivers/xf86-video-i810-2.2.0 - direct rendering does not work
Summary: x11-drivers/xf86-video-i810-2.2.0 - direct rendering does not work
Status: RESOLVED DUPLICATE of bug 219867
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Rémi Cardona (RETIRED)
: 201200 (view as bug list)
Depends on:
Reported: 2007-12-02 22:03 UTC by Zsolt Fabok
Modified: 2008-05-22 13:24 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

glxinfo output (glxinfo,176 bytes, text/plain)
2007-12-02 22:04 UTC, Zsolt Fabok
xorg log warnings and errors with the driver (xorg,1.26 KB, text/plain)
2007-12-02 22:05 UTC, Zsolt Fabok

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Fabok 2007-12-02 22:03:19 UTC

I'm recently upgraded to xf86-video-i810 version 2.2.0 and realized that the direct rendering does not work anymore. There are some errors in the glxinfo and in the Xorg.0.log. You can find them as attachment. I do not know what else do you need for investigation, please let me know if I can help with other logs. My x11-drm version is 20070314.

Reproducible: Always

Steps to Reproduce:
Comment 1 Zsolt Fabok 2007-12-02 22:04:01 UTC
Created attachment 137571 [details]
glxinfo output
Comment 2 Zsolt Fabok 2007-12-02 22:05:11 UTC
Created attachment 137573 [details]
xorg log warnings and errors with the driver
Comment 3 lopan 2007-12-03 01:13:22 UTC
This version not very work. When i use compiz-fusion the animations is very slow. The direct rendering is enable but no fine! The system not show any error to me, but, the version 2.1.1 is more fast when using compiz-fusion.
Comment 4 Julien 2007-12-03 14:26:07 UTC
confirm bug:
(EE) AIGLX error: drmMap of framebuffer failed (Invalid argument)(EE) AIGLX: reverting to software rendering

$ compiz --replace
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2007-12-04 20:23:03 UTC
*** Bug 201200 has been marked as a duplicate of this bug. ***
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2007-12-04 20:51:21 UTC
Please try in-kernel DRM or x11-drm-20071019, at least the original reporter's snapshot is fairly old.
Comment 7 Zsolt Fabok 2007-12-04 20:57:16 UTC

I tried the drm version 20071019 but it did not work either. Using that module crashed my X, so I went back to an older but working version. I'm going to try the  kernel based drm if it helps. The result will be put here in this week.
Comment 8 Matthias Langer 2007-12-07 10:10:44 UTC
> Please try in-kernel DRM

in-kernel DRM does not work for me at least with

x11-base/xorg-server-  USE="dri ipv6 nptl sdl xorg -3dfx -debug -dmx -kdrive -minimal -xprint"

note that i'm doing nothing compiz-related here; glxgears is enough to reproduce the problem:

$ glxgears 
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering

also note that opengl works with =xf86-video-i810-2.1* (although these versions have other issues) for me.

Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
System uname: 2.6.23-gentoo-r3 i686 Intel(R) Celeron(R) CPU 2.80GHz
Timestamp of tree: Fri, 07 Dec 2007 01:46:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
CFLAGS="-march=prescott -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en de"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="3dnow 3dnowext X acpi alsa berkdb bitmap-fonts bzip2 cairo caps cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode evo exif fam firefox fortran gdbm gif gimp gnome gpm gstreamer gtk hal hddtemp iconv ipv6 isdnlog java jpeg jpeg2k ldap libnotify lm_sensors mad midi mikmod mmap mmx mmxext mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl plotutils png pppd python qt3support quicktime readline real reflection ruby sdl session spell spl sse ssl svg tcpd tetex threads tiff truetype truetype-fonts type1-fonts unicode usb vim-syntax vorbis win32codecs x86 xattr xml xorg xv zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="i810 vesa nv i128 i740"
Comment 9 Marek Sapota 2007-12-18 00:33:36 UTC
No problem with compiz or glxgears for me with 2.2.0 driver. I've only experienced such messages, when I had my virtual desktop size > 2048.
Comment 10 Erik Zeek 2007-12-18 14:16:40 UTC
(In reply to comment #9)
> No problem with compiz or glxgears for me with 2.2.0 driver. I've only
> experienced such messages, when I had my virtual desktop size > 2048.

I have the problem without any virtual desktop size setting.
Comment 11 Paolo Ornati 2007-12-31 12:59:07 UTC
Same problem here.

Hardware (lspci):
Intel Corporation 82G965 Integrated Graphics Controller (rev 02)
Comment 12 Erik Zeek 2007-12-31 13:50:22 UTC
And with x11-drivers/xf86-video-i810-2.2.0-r1.
Comment 13 Marek Sapota 2008-01-14 22:44:05 UTC
I've started kubuntu live-cd and when I restarted my computer, direct rendering in 2.2.0 was gone, so my previous comment is wrong - it got broken anyway, although in strange way...
Comment 14 Rémi Cardona (RETIRED) gentoo-dev 2008-01-24 13:51:19 UTC
I've just added a snapshot of the upcoming 2.2.1 release, as upstream wants
more testing before making official releases.

Please try this snapshot on top of xorg-server- If it isn't fixed,
please open a bug in freedesktop's bugzilla [1] and paste the url here.


Comment 15 Erik Zeek 2008-01-25 04:01:22 UTC
Still there:

 LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 1.9.0 i915 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
Comment 16 Erik Zeek 2008-01-25 04:07:33 UTC
It's already been reported to xorg:
Comment 17 Erik Zeek 2008-02-03 14:30:37 UTC
x11-drivers/xf86-video-i810-2.2.1_pre20080125 gives the same results.
Comment 18 Rémi Cardona (RETIRED) gentoo-dev 2008-02-06 15:24:58 UTC
Fixed by upstream. Should work fine with >= (which I'll be committing tonight).

If this bug still happens, don't hesitate to reopen.
Comment 19 Brent Hagany 2008-02-10 22:27:06 UTC
Still occurs with for me.
Comment 20 Rémi Cardona (RETIRED) gentoo-dev 2008-02-11 07:38:28 UTC
Brent, please make sure you are using the latest ~ packages for the kernel or libdrm, xorg-server, and basically anything related to drivers and the server (client libs should be fine).

If the bug still happens, please open another bug as you may be on to a different issue.

Comment 21 Daniel Squires 2008-02-20 23:08:18 UTC
I have just taken the opportunity to try this out too (fed up with the freezes of previous drivers), whilst all indicators are that dri is working, the performance i'm seeing compared to the 2.1 driver would suggest it is not.


Off topic but i now notice several other issues, the backlight on change to Vt is off altogether, the brightness in X is stuck at the very minimum, in the previous driver it would stick at full in X but changing to vt and back would get the brightness controlls working again. Resume from suspend2ram now takes an age (10+ seconds), and sometimes boots out of X altogether meaning i have to log in again.
Comment 22 Daniel Squires 2008-02-21 10:08:04 UTC
I've been running these new versions for all of 5 hours and have just encountered a rather impressive crash! The screen completely scrambled in mid use, not to disimilar to films where a computer gets a virus! the mouse then froze too, the Magic Sys Req keys still worked this time however, the freezes on logout with the previous driver rendered these key inoperable.

I loved my previous AMD + nvidia systems, they always worked flawlessly. I switched to Intel for the benefits of core2duo, but it seems everyting Intel is cursed with poor drivers, the gfx, the ipw wifi and the HD intel sound all have problems, I know where my money is going next time.
Comment 23 Rémi Cardona (RETIRED) gentoo-dev 2008-02-21 10:47:30 UTC

Please take the time to report these bugs over at by following this small guide That's where bugs get fixed as I am no way capable of fixing graphics drivers.

If you do, please add me as a CC there so that I can follow your bug and backport patches if necessary.

Comment 24 Albert Zeyer 2008-05-03 11:34:03 UTC
The bug 219867 is probably related to this bug. It's about non-working DR with xf86-video-i810-2.3.0 and the same error message.
Comment 25 Rémi Cardona (RETIRED) gentoo-dev 2008-05-04 07:23:59 UTC
(In reply to comment #24)
> The bug 219867 is probably related to this bug. It's about non-working DR with
> xf86-video-i810-2.3.0 and the same error message.

Indeed, these 2 bugs are probably the same. I'll be keeping the other one open for now. Problem is, the only work-around for that bug is to upgrade xorg-server to, which is already considered a dead branch by upstream...

All in all, I'm not really sure what to do about all this.
Comment 26 Zsolt Fabok 2008-05-12 11:58:06 UTC
(In reply to comment #25)

> All in all, I'm not really sure what to do about all this.
I rechecked with xorg ebuild version and seems to be working (nevertheless the touchpad does not work, but it is a different topic).

Thanks for your efforts and you can close this entry from my side.

Comment 27 Rémi Cardona (RETIRED) gentoo-dev 2008-05-22 13:06:37 UTC
Comment 28 Rémi Cardona (RETIRED) gentoo-dev 2008-05-22 13:14:40 UTC
Basically, we won't fix 1.3. It's too much work for everyone for very little gain.

Donnie (dberkholz) has decided to push (with a bunch of patches) to stable. So if you want to help test it, here's what you can do :

echo "x11-base/xorg-server **" >> /etc/portage/package.keywords

followed by emerge -1 xorg-server. That should install xorg-server which is going to be stabled. I suggest removing the "hal" useflag if you don't really know how to configure HAL for this.

If anything breaks with that, please report it in another bug so that we can fix it (nothing _should_ break, but we never know).

Closing again. Thanks

*** This bug has been marked as a duplicate of bug 219867 ***