Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200702 - dev-scheme/guile-gnome-platform-2.15.92 build fails
Summary: dev-scheme/guile-gnome-platform-2.15.92 build fails
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Scheme Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-28 23:14 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2009-07-20 16:04 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/portage/dev-scheme:guile-gnome-platform-2.15.92:20071128-205933.log (dev-scheme:guile-gnome-platform-2.15.92:20071128-205933.log,30.51 KB, text/plain)
2007-11-28 23:14 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/tmp/emerge--info (emerge--info,8.97 KB, text/plain)
2007-11-28 23:14 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
a part of my overlay, tar -xvf somewhere like /usr/local/overlays/<something> for testing (set_of_patches+ebuilds_for_guile-gnome-platform-2.15.96_and_gwave.tar.bz2,5.75 KB, application/octet-stream)
2008-01-07 20:37 UTC, Panagiotis Christopoulos (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-28 23:14:03 UTC
i686-pc-linux-gnu-gcc -shared  .libs/libguile_gnome_gobject_0_la-gobject.o .libs/libguile_gnome_gobject_0_la-gsignal.o .libs/libguile_gnome_gobject_0_la-gclosure.o .libs/libguile_gnome_gobject_0_la-gvalue.o .libs/libguile_gnome_gobject_0_la-gparameter.o .libs/libguile_gnome_gobject_0_la-gtype.o .libs/libguile_gnome_gobject_0_la-gutil.o .libs/libguile_gnome_gobject_0_la-gc.o .libs/libguile_gnome_gobject_0_la-guile-support.o  /usr/lib/libgobject-2.0.so -L/usr/lib /usr/lib/libglib-2.0.so /usr/lib/libguile.so /usr/lib/libgmp.so -lcrypt -lm /usr/lib/libltdl.so  -pthread -march=athlon-mp -pthread -Wl,-soname -Wl,libguile-gnome-gobject-0.so.0 -o .libs/libguile-gnome-gobject-0.so.0.0.0
(cd .libs && rm -f libguile-gnome-gobject-0.so.0 && ln -s libguile-gnome-gobject-0.so.0.0.0 libguile-gnome-gobject-0.so.0)
(cd .libs && rm -f libguile-gnome-gobject-0.so && ln -s libguile-gnome-gobject-0.so.0.0.0 libguile-gnome-gobject-0.so)
creating libguile-gnome-gobject-0.la
(cd .libs && rm -f libguile-gnome-gobject-0.la && ln -s ../libguile-gnome-gobject-0.la libguile-gnome-gobject-0.la)
make[5]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib/gnome/gobject'
make[4]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib/gnome/gobject'
Making all in gw
make[4]: Entering directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib/gnome/gw'
guile  -c \
          "(debug-set! stack 400000) \
           (use-modules (gnome-0)) \
           (use-modules (g-wrap)) \
           (use-modules (gnome gw gobject-spec)) \
           (generate-wrapset 'guile 'gnome-gobject \"guile-gnome-gw-gobject\")"
guile  -c \
          "(debug-set! stack 400000) \
           (use-modules (gnome-0)) \
           (use-modules (g-wrap)) \
           (use-modules (gnome gw glib-spec)) \
           (generate-wrapset 'guile 'gnome-glib \"guile-gnome-gw-glib\")"
WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core binding `raise'
ERROR: In procedure class-precedence-list:
ERROR: Wrong type argument in position 1 (expecting class): #<condition-type &error 40356f30>
WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core binding `raise'
ERROR: In procedure class-precedence-list:
ERROR: Wrong type argument in position 1 (expecting class): #<condition-type &error 40357030>
make[4]: *** [guile-gnome-gw-gobject.c] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: *** [guile-gnome-gw-glib.c] Error 1
make[4]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib/gnome/gw'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib/gnome'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92/glib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-scheme/guile-gnome-platform-2.15.92/work/guile-gnome-platform-2.15.92'
make: *** [all] Error 2
 *
 * ERROR: dev-scheme/guile-gnome-platform-2.15.92 failed.
 * Call stack:
 *               ebuild.sh, line 1762:  Called dyn_compile
 *               ebuild.sh, line  891:  Called qa_call 'src_compile'
 *               ebuild.sh, line   35:  Called src_compile
 *             environment, line 2547:  Called die
 * The specific snippet of code:
 *       emake guilegnomedir=/usr/share/guile/site guilegnomelibdir=/usr/$(get_libdir) || diefunc "$FUNCNAME" "$LINENO" "$?" "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/dev-scheme:guile-gnome-platform-2.15.92:20071128-205933.log'.
 *
 * GNU info directory index is up-to-date.
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-28 23:14:19 UTC
Created attachment 137282 [details]
/var/log/portage/dev-scheme:guile-gnome-platform-2.15.92:20071128-205933.log
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-28 23:14:36 UTC
Created attachment 137283 [details]
/tmp/emerge--info
Comment 3 Samuli Suominen gentoo-dev 2007-11-29 15:17:11 UTC
I've had this problem, which is why I didn't keyword it for ~amd64. dev-scheme/guile-gnome-platform-2.15.95 builds for me and is keyworded for ~amd64.  However, after upgrading to it latest version of "gwave" doesn't start and segmentation faults. This is why it's in package.mask now. So from one problem, to another.. I regret for touching it, and would appericiate if someone else would double check the 2.15.95 ebuild, but it should be pretty straight forward.
Comment 4 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-29 15:30:21 UTC
So, should I esync and remerge world ? I dont use gwave really often. this guile problem is blocking some upgrades.
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2007-11-30 06:20:49 UTC
I've run into funny problems like this before, too, related to changing versions and such. Here's one thing to try: uninstall guile-gnome-platform, guile-cairo, g-wrap and guile, then reinstall them (emerge guile-gnome-platform should pull 'em all in). Please do post if it works.
Comment 6 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-30 15:31:04 UTC
I did not install it yet: it is inserted on my system as a new dep before I can update gwave:

[ebuild  N    ] dev-scheme/guile-gnome-platform-2.15.92  0 kB
[ebuild     U ] sci-electronics/gwave-20070514 [20060606] USE="gnuplot plotutils" 0 kB


I ll test what you suggest.
Comment 7 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-30 15:57:12 UTC
Dont be shy:
emerge -Cv gwave guile-cairo g-wrap guile guile-gtk

 dev-libs/g-wrap
    selected: 1.9.9
   protected: none
     omitted: none

 dev-scheme/guile-cairo
    selected: 1.4.0
   protected: none
     omitted: none

 sci-electronics/gwave
    selected: 20060606
   protected: none
     omitted: none

 dev-scheme/guile
    selected: 1.8.3-r1
   protected: none
     omitted: none

 x11-libs/guile-gtk
    selected: 2.0
   protected: none
     omitted: none

[...]

root@moon_gen_2:~# emerge -DaNuv world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild  N    ] dev-scheme/guile-1.8.3-r1  USE="deprecated discouraged nls regex threads -debug -debug-freelist -debug-malloc -elisp -networking" 0 kB
[ebuild  N    ] dev-libs/g-wrap-1.9.9  0 kB
[ebuild  N    ] dev-scheme/guile-cairo-1.4.0  0 kB
[ebuild  N    ] x11-libs/guile-gtk-2.0  USE="X" 0 kB
[ebuild  N    ] dev-scheme/guile-gnome-platform-2.15.92  0 kB
[ebuild  N    ] sci-electronics/gwave-20070514  USE="gnuplot plotutils" 0 kB

[...]

=> same error :S
(except that now I dont have gwave at all anymore :S )
Comment 8 Denis Dupeyron (RETIRED) gentoo-dev 2007-11-30 16:18:50 UTC
(In reply to comment #7)
> (except that now I dont have gwave at all anymore :S )

You can just add =sci-electronics/gwave-20070514 to /etc/portage/package.mask until we solve this and you will get the previous version back. Unfortunately that means you have to go back to guile 1.6, which is the reason why I was so happy to be able to bump gwave to a guile 1.8 compatible version.

At this point we need the scheme guys to help us and I'm afraid nowadays that means Marijn only. So Marijn, whenever you have 5 minutes to waste, please... ;o)

Denis.
Comment 9 DEMAINE Benoît-Pierre, aka DoubleHP 2007-12-23 13:37:51 UTC
No, that does not work:

*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

root@moon_gen_2:~# emerge -DaNuv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

dev-scheme/guile:12

  ('ebuild', '/', 'dev-scheme/guile-1.6.8', 'merge') pulled in by
    ('ebuild', '/', 'sci-electronics/gwave-20060606', 'merge')

  ('installed', '/', 'dev-scheme/guile-1.8.3-r1', 'nomerge') pulled in by
    ('ebuild', '/', 'x11-libs/guile-gtk-1.2.0.60', 'merge')
    ('installed', '/', 'sci-electronics/geda-20070526', 'nomerge')
    ('installed', '/', 'sci-libs/libgeda-20070526', 'nomerge')
    (and 1 more)

*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** 

Would require to also mask nay other recent things, and I would fall back in old compile bug of many of them (I remember building GEDA-2006 was hell).

Going back to guile 1.6 is really difficult for me.
Comment 10 Robert Bradbury 2007-12-27 05:16:52 UTC
I can confirm that I get this exact same build error on a pentium 4 (Prescott).
Comment 11 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-01-07 20:37:52 UTC
Created attachment 140407 [details]
a part of my overlay, tar -xvf somewhere like /usr/local/overlays/<something> for testing

Hello, 

First of all there is a new version of guile-gnome-platform upstream, 2.15.96:), and as the guys there say, there will be a 2.16.0 pretty soon. I made some work on fixing gwave, for the new version 2.15.96, and my patched gwave does not segfault, and starts(at least in x86,where I tested), but still seems to be unstable. Gwave's developer says:

15 -------------
 16 tested configurations:
 17 
 18 Fedora core 6
 19         guile-1.8.0-8.20060831cvs       (Standard with FC6+updates)
 20         gtk2-2.10.8-3.fc6               (Standard with FC6+updates)
 21         g-wrap-1.9.7-1sgt                (my own rpm)
 22         guile-gnome-platform-2.15.90-2sgt  (my own rpm)
 23 
 24 
 25 -------------
 26 
 27 CAUTION: Use only the version of guile-gnome-platform and g-wrap known
 28 to work with whatever version of guile you have. Mixing incompatibile
 29 versions of guile-gnome-platorm, g-wrap, and guile definitely fails.
 30 
 31 
 32 I recommend verifying that guile, gtk+-2.0, and guile-gnome-platofrm
 33 all work individualy before trying to build gwave using them.  Gtk
 34 and guile-gtk both come with "test-gtk" programs in their respective
 35 examples directories which are ideal for this purpose.  ** Please try
 36 this before reporting guile-gtk related problems with gwave. **
 37 
 38 *** I strongly recommend installing Guile and Guile-gtk the same way
 39 *** with the same prefix: either build both from source, installing
 40 *** both into /usr/local, or install both using your favorite packging
 41 *** system (RPM, DEB, or other).  Mixing packages and local-installs
 42 *** can be made to work, but often requires a lot of additional
 43 *** fiddling.
 44 
 45

so as Calchan said on #gento-bugs, the situation is really a mess.

I think we should wait for a new shiny version of gwave(if there will be any), or tell me to spent sometime to try to fix the 2.15.92 issue, which may be a nice solution for the time being. Someone can try my patched gwave, but if Marijn(hkBst) don't say his "ok", after seeing my work, i think it will be a bad idea to take my patches to the main tree.Calchan and drac, I'm sorry for not providing patches for guile-gnome-platform's and gwave's ebuilds, and I uploaded a whole part of my overlay.

Panagiotis(pchrist)
Comment 12 Erik Benada 2008-03-15 02:54:07 UTC
Using guile-1.8.3-r2 and g-wrap-1.9.10 (not in Portage yet) allows to compile guile-gnome-platform-2.15.95 successfully.

guile-gnome-platform-2.15.92 fails to compile with the following error:

guile  -c \
          "(debug-set! stack 400000) \
           (use-modules (gnome-0)) \
           (use-modules (g-wrap)) \
           (use-modules (gnome gw gobject-spec)) \
           (generate-wrapset 'guile 'gnome-gobject \"guile-gnome-gw-gobject\")"
guile  -c \
          "(debug-set! stack 400000) \
           (use-modules (gnome-0)) \
           (use-modules (g-wrap)) \
           (use-modules (gnome gw glib-spec)) \
           (generate-wrapset 'guile 'gnome-glib \"guile-gnome-gw-glib\")"
WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap util): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap rti): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap rti): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap c-types): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (g-wrap c-types): imported module (srfi srfi-34) overrides core binding `raise'
WARNING: (gnome gw support g-wrap): `declarations-cg' imported from both (g-wrap c-codegen) and (g-wrap scm-codegen)
WARNING: (gnome gw support g-wrap): `declarations-cg' imported from both (g-wrap c-codegen) and (g-wrap scm-codegen)
ERROR: No class slot with name `allowed-options' in class #<<gw-type-class> <gobject-object-type> 40321ae0>
make[4]: *** [guile-gnome-gw-gobject.c] Error 1

(seems to be fixed with patch (although patch is against 2.15.93) attached here:

http://permalink.gmane.org/gmane.lisp.guile.gtk/710

Comment 13 Dmitry Dzhus 2008-07-31 07:10:12 UTC
guile-gnome-platform-2.16.1 builds fine (unmasked libffi-3.0.5, gcc built without libffi)
Comment 14 Marijn Schouten (RETIRED) gentoo-dev 2009-07-19 11:52:26 UTC
Hi, I would like to know if any problems still remain with guile-gnome-platform-2.16.1.
Comment 15 DEMAINE Benoît-Pierre, aka DoubleHP 2009-07-19 16:02:34 UTC
I have no clue; I managed to not need it any more.

after unmasking (I am using stable) :

moon-gen-3 ~ # emerge -va dev-scheme/guile-gnome-platform
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild  N    ] dev-libs/g-wrap-1.9.11-r1  0 kB
[ebuild  N    ] dev-scheme/guile-gnome-platform-2.16.1  3,413 kB

Total: 2 packages (2 new), Size of downloads: 3,413 kB
Would you like to merge these packages? [Yes/No]
...
>>> Installing (1 of 2) dev-libs/g-wrap-1.9.11-r1
 * checking 56 files for package collisions
[...]
 * Detected file collision(s):
 *
 *      /usr/share/guile/site/srfi/srfi-35.scm
 *      /usr/share/guile/site/srfi/srfi-34.scm
 *
 * Searching all installed packages for file collisions...
 *
 * Press Ctrl-C to Stop
 *
 * dev-scheme/guile-lib-0.1.3
 *      /usr/share/guile/site/srfi/srfi-34.scm
 *      /usr/share/guile/site/srfi/srfi-35.scm
 *
 * Package 'dev-libs/g-wrap-1.9.11-r1' NOT merged due to file collisions.
 * If necessary, refer to your elog messages for the whole content of the
 * above message.

You may disagree, but *I* consider this answers your question: guile-plateform depends on something that does not compile fine: broken dep.

   * dev-scheme/guile-lib-0.1.3
   Install date: Sun Jul 19 14:24:02 2009
   USE=""
   CFLAGS="-O2 -march=athlon-mp -pipe"

... i'll remerge it without the protect feature.
Comment 16 DEMAINE Benoît-Pierre, aka DoubleHP 2009-07-19 16:03:57 UTC
ah no, i can't; collision-protect is already off on my system. I don't know what to do now.
Comment 17 Marijn Schouten (RETIRED) gentoo-dev 2009-07-20 10:29:37 UTC
This problem was already fixed. You still need to stay away from g-wrap-1.9.12 though (bug 278328).
Comment 18 DEMAINE Benoît-Pierre, aka DoubleHP 2009-07-20 13:17:32 UTC
(In reply to comment #17)
> This problem was already fixed. You still need to stay away from g-wrap-1.9.12
> though (bug 278328).
> 

fixed when ? i synched 2 days ago; 1.9.11-r1  bugs, and you tell me to stay away from 1.9.12; what should I do ? use an older one ?
Comment 19 Marijn Schouten (RETIRED) gentoo-dev 2009-07-20 14:56:50 UTC
Yes, use 1.9.11. I removed 1.9.11-r1. If you would just sync you would see this for yourself.
Comment 20 DEMAINE Benoît-Pierre, aka DoubleHP 2009-07-20 16:04:55 UTC
Yes =dev-libs/g-wrap-1.9.11 compiled fine. Your messages about the exact version to use were ambiguous.

dev-scheme/guile-gnome-platform-2.16.1 emerged fine.