Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200598 - emerge media-sound/mpc-9999 bugs due to interactive requirements
Summary: emerge media-sound/mpc-9999 bugs due to interactive requirements
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-11-28 06:52 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2007-11-28 16:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-28 06:52:16 UTC
I launched this; a few hours later, I came back, and saw that emerge hanged, and did not compleet his work. I still dislike interactive emerges (we have deal many bugs about it).

>>> Emerging (6 of 12) media-sound/mpc-9999 to /
 * checking ebuild checksums ;-) ...                                                                                          [ ok ]
 * checking auxfile checksums ;-) ...                                                                                         [ ok ]
 * checking miscfile checksums ;-) ...                                                                                        [ ok ]
>>> Unpacking source...
 * subversion check out start -->
 *      repository:
Error validating server certificate for '':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
Certificate information:
 - Hostname:
 - Valid: from Tue, 07 Dec 2004 04:23:14 GMT until Fri, 05 Dec 2014 04:23:14 GMT
 - Issuer:,, Pittsburgh, Pennsylvania, US
 - Fingerprint: 21:c3:93:35:09:e1:76:73:43:58:52:6d:de:06:60:9c:fc:96:81:35
(R)eject, accept (t)emporarily or accept (p)ermanently? p
svn: PROPFIND request failed on '/mpc/trunk'
svn: PROPFIND of '/mpc/trunk': Could not read status line: connection was closed by server. (
 * ERROR: media-sound/mpc-9999 failed.
 * Call stack:
 *     , line 1762:  Called dyn_unpack
 *     , line  669:  Called qa_call 'src_unpack'
 *     , line   35:  Called src_unpack
 *             environment, line 2608:  Called subversion_src_unpack
 *             environment, line 2817:  Called subversion_fetch
 *             environment, line 2794:  Called die
 * The specific snippet of code:
 *           ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || diefunc "$FUNCNAME" "$LINENO" "$?" "${ESVN}: can't fetch from ${repo_uri}.";
 *  The die message:
 *   subversion.eclass: can't fetch from
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/media-sound:mpc-9999:20071128-062955.log'.
 * Regenerating GNU info directory index...
 * Processed 271 info files.

Ok it worked the second time; but it should have worked on the first one. Maybe this bug should be considered as subversion issue ? a bit like the bug when wget was in trouble with ca-certificates ...
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-11-28 07:28:53 UTC
We really can't fix certificates that don't validate, nor will make assumption on behalf of users.
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2007-11-28 16:44:09 UTC
Anyway, this ebuilds was coming from some layman; thus, this bug does not have place in this BTS. But, I saw this only 2h after I open the bug, and forget to come and close it.