Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200130 - gnome-extra/gnome-system-monitor-2.20.1 crashes in add_disk()
Summary: gnome-extra/gnome-system-monitor-2.20.1 crashes in add_disk()
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-23 23:08 UTC by Andreas Dehmel
Modified: 2010-09-22 11:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Stack backtrace for the crash (bt-gnome-system-manager.txt,2.11 KB, text/plain)
2007-11-23 23:09 UTC, Andreas Dehmel
Details
Output of emerge --info on my system (my-emerge-info.txt,5.78 KB, text/plain)
2007-11-23 23:10 UTC, Andreas Dehmel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Dehmel 2007-11-23 23:08:57 UTC
gnome-system-monitor-2.20.1 crashes as soon as I click on the "disks" tab, or
if I mount/unmount any partitions. I built the package with debug info and got
a stack backtrace which I'll attach. Note I only built GSM with debug info,
but I think this should suffice as it looks suspiciously like a NULL pointer
access
Also note: I'm running the program in a regular window manager, not the Gnome
desktop, in case that has anything to do with it.This is also the reason why
I filed the bug under "Applications" rather than "GNOME".


Reproducible: Always

Steps to Reproduce:
1.Click on "disks" tab
2.Mount/unmount partitions
Comment 1 Andreas Dehmel 2007-11-23 23:09:39 UTC
Created attachment 136813 [details]
Stack backtrace for the crash
Comment 2 Andreas Dehmel 2007-11-23 23:10:16 UTC
Created attachment 136814 [details]
Output of emerge --info on my system
Comment 3 Andreas Dehmel 2007-11-23 23:14:52 UTC
I meant the "File systems" tab rather than "Disks". Sorry, I misremembered the name.
Comment 4 Gilles Dartiguelongue gentoo-dev 2007-11-24 12:49:41 UTC
which version of gtmm do you have ?
Comment 5 Andreas Dehmel 2007-11-24 15:52:09 UTC
I assume you mean gtKmm. I have version 2.12.1 installed, which is also the latest version in my portage-tree. The library was last built on Nov 14 on my system. The system should be up-to-date, I ran "emerge --update --deep world" yesterday. and I didn't get anything out of revdep-rebuild.
I just had a look which other packages depend on gtkmm and Inkscape crashes right on startup. Interesting warnings on startup in this case:

inkscape: Symbol `_ZTIN3Gtk6WidgetE' has different size in shared object, consider re-linking

(inkscape:9628): glibmm-CRITICAL **: Glib::Interface::Interface(const Glib::Interface_Class&): assertion `gobject_ != 0' failed
*** glibc detected *** inkscape: malloc(): memory corruption: 0x0000000000d896b0 ***
======= Backtrace: =========
...


Now rebuilding gtkmm and glibmm (2.14.2) ...
OK, recompiling boths libs _and_ Inkscape makes this programs works again. Not gnome-system-monitor, however. I'll try rebuilding the remaining *mm-libs on my system for now...
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-01-11 23:51:00 UTC
I wonder why this message pops up:

"inkscape: Symbol `_ZTIN3Gtk6WidgetE' has different size in shared object,
consider re-linking"

@herd, any idea of what could have happened ?
Comment 7 Gilles Dartiguelongue gentoo-dev 2008-04-14 14:50:01 UTC
hum forgot to post follow up. I was told this is due to c++ lib being recompiled and symbols changing a bit which makes apps start to stop working (aha). Only workaround is to reemerge faulty apps or libs and it'll work again. Nothing we (as gnome herd) can do here besides eventually putting annoying elog messages.

At best this should probably be a revdep-rebuild enhancement request...
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2010-09-22 11:13:08 UTC
The error <<has different size in shared object, consider re-linking>> can be fixed by remergint the package owning the file. See bug 338347 . The issue is not in the app, but in portage 2.2, or in revdep-rebuild.