Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 19910 - app-office/moneydance - easy to use personal finance software that is loaded with all the features you need: online banking and bill payment, account management, budgeting and investment tracking
Summary: app-office/moneydance - easy to use personal finance software that is loaded ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://infinitekind.com/moneydance
Whiteboard:
Keywords: PullRequest
: 523966 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-04-25 00:16 UTC by Robert Cole
Modified: 2018-11-16 23:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Reilly Technologies License (/usr/portage/licenses/reilly) (reilly,12.93 KB, text/plain)
2003-05-08 09:35 UTC, Ben Rogers
Details
Moneydance 2003, build 301 ebuild (moneydance-2003.301.ebuild,1.51 KB, text/plain)
2003-05-08 09:37 UTC, Ben Rogers
Details
Australian Business Access license (/usr/portage/licenses/ABA) (ABA,4.84 KB, text/plain)
2003-05-08 09:49 UTC, Ben Rogers
Details
Moneydance 2003, build 301 ebuild (moneydance-2003.301.ebuild,1.53 KB, text/plain)
2003-05-08 09:51 UTC, Ben Rogers
Details
app-office/moneydance-2014 (moneydance-2014.ebuild,882 bytes, text/plain)
2014-09-29 06:18 UTC, juantxorena@gmail.com
Details
TIK license (TIK.txt,14.46 KB, text/plain)
2014-09-29 06:18 UTC, juantxorena@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cole 2003-04-25 00:16:41 UTC
Quote from the website:

"Moneydance 2003, the groundbreaking new financial tool is now available for all 
platforms. Moneydance can be trusted to keep all of your financial information 
safe, organized, and at your fingertips. After just a few minutes with 
Moneydance's simple interface and powerful features, you will wonder how you 
ever got along without it."

I've been watching this software for a while now. It finially qualifies as a 
decent addition to the source tree. :)
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-04-28 17:21:16 UTC
please privde an ebuild
Comment 2 Robert Cole 2003-04-28 18:40:36 UTC
This bug report is for getting an ebuild created. 
Comment 3 Ben Rogers 2003-05-08 09:35:41 UTC
Created attachment 11685 [details]
Reilly Technologies License (/usr/portage/licenses/reilly)
Comment 4 Ben Rogers 2003-05-08 09:37:14 UTC
Created attachment 11686 [details]
Moneydance 2003, build 301 ebuild
Comment 5 Ben Rogers 2003-05-08 09:40:18 UTC
This ebuild seems to work for me.  I've been using it sucessfully for several weeks and don't seem to have any issues remaining.  Tested only on x86 with Sun JDK 1.4.1.02-r1.

The application requires a click-through license, so I force the user to get the actual binary.

I suggest app-office/moneydance/moneydance-2003.301.ebuild
Comment 6 Ben Rogers 2003-05-08 09:49:45 UTC
Created attachment 11687 [details]
Australian Business Access license (/usr/portage/licenses/ABA)
Comment 7 Ben Rogers 2003-05-08 09:51:00 UTC
Created attachment 11688 [details]
Moneydance 2003, build 301 ebuild

Update commenting and license for ABA JCE.
Comment 8 Jeroen Roovers gentoo-dev 2014-09-29 00:55:15 UTC
*** Bug 523966 has been marked as a duplicate of this bug. ***
Comment 9 juantxorena@gmail.com 2014-09-29 06:18:15 UTC
Created attachment 385702 [details]
app-office/moneydance-2014

This is an ebuild I made for the newest version 2014. It works, but it has some problems:
- It shows some QA errors related to LDFLAGS, which I don't know how to fix.
- The software may have some updates, but the downloaded package is the same, they just silently update them. It's the same problem as googleearth. Again, I don't know how to fix it.
- It comes with a bunch of bundled java libs, even jre itself. Of course, it is recomended to run the software with the bundled version, but I don't know if it would be desireable to substitute these with the installed versions, or if it would be possible according to the licence.
- The desktop file for the app is ugly.
Comment 10 juantxorena@gmail.com 2014-09-29 06:18:53 UTC
Created attachment 385704 [details]
TIK license

This is the license file.
Comment 11 Larry the Git Cow gentoo-dev 2018-11-16 23:01:52 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e766b9a94f3719c9008b6ac82971a56ac55a8c45

commit e766b9a94f3719c9008b6ac82971a56ac55a8c45
Author:     Conrad Kostecki <conrad@kostecki.com>
AuthorDate: 2018-11-01 23:02:08 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2018-11-16 23:01:41 +0000

    app-office/moneydance: new package.
    
    Moneydance is an easy-to-use personal finance software that is loaded with all the
    features you need: online banking and bill payment, account management,
    budgeting and investment tracking.
    
    Closes: https://bugs.gentoo.org/19910
    Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 app-office/moneydance/Manifest                 |  2 +
 app-office/moneydance/metadata.xml             | 17 ++++++++
 app-office/moneydance/moneydance-2017.8.ebuild | 59 ++++++++++++++++++++++++++
 3 files changed, 78 insertions(+)

Additionally, it has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bfae0756d50861d9efe1661c678289f0f79ada85

commit bfae0756d50861d9efe1661c678289f0f79ada85
Author:     Conrad Kostecki <conrad@kostecki.com>
AuthorDate: 2018-11-01 22:52:46 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2018-11-16 23:01:40 +0000

    profiles/license_groups: added TIK license to EULA group.
    
    Bug: https://bugs.gentoo.org/19910
    Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 profiles/license_groups | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5ca75d8e513896bd7d98b6c96fe0fe18881a2ec5

commit 5ca75d8e513896bd7d98b6c96fe0fe18881a2ec5
Author:     Conrad Kostecki <conrad@kostecki.com>
AuthorDate: 2018-11-01 22:52:00 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2018-11-16 23:01:39 +0000

    licenses/CSL-2.0: added new license for app-office/moneydance.
    
    Bug: https://bugs.gentoo.org/19910
    Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 licenses/CSL-2.0 | 110 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 110 insertions(+)

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=86adc23c19cd7e910e0a8cdb41c878745e0ee17f

commit 86adc23c19cd7e910e0a8cdb41c878745e0ee17f
Author:     Conrad Kostecki <conrad@kostecki.com>
AuthorDate: 2018-11-01 22:51:30 +0000
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: 2018-11-16 23:01:38 +0000

    licenses/TIK: added new license for app-office/moneydance.
    
    Bug: https://bugs.gentoo.org/19910
    Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
    Closes: https://github.com/gentoo/gentoo/pull/10321
    Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

 licenses/TIK | 60 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)