Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198810 - linux boot hangs with intel Q35 chipset
Summary: linux boot hangs with intel Q35 chipset
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard: linux-2.6.24
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2007-11-11 14:31 UTC by AE
Modified: 2008-02-26 17:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Q35 boot fix patch (q35.pci.patch,1.32 KB, text/plain)
2007-11-11 20:02 UTC, AE
Details
new patch (pci-conf1.patch,6.85 KB, patch)
2008-02-12 16:53 UTC, Daniel Drake (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description AE 2007-11-11 14:31:54 UTC
The linux kernel boot will hang at ACPI initialisation unless acpi=off or pci=nommconf are used as boot parameters. The kernel devs are aware of the problem:
http://kerneltrap.org/mailarchive/linux-kernel/2007/8/26/164870
but as of linux-2.6.24_rc2, the patch from the discussion hasn't made it into mainline. There's talk about BIOS updates fixing the issue for G33 chipsets, but not so for Q35 (I'm using the latest BIOS for the intel DQ35JO board). I've tested the patch against vanilla-sources-2.6.24_rc2 and haven't noticed any negative effects so far.

Reproducible: Always
Comment 1 AE 2007-11-11 20:02:23 UTC
Created attachment 135761 [details]
Q35 boot fix patch
Comment 2 Mike Pagano gentoo-dev 2007-11-12 14:24:14 UTC
There seems to still be quite a bit of discussions concerning the validity of this patch. I think it might be worth it to keep an eye on the upstream thread until an accepted patch is proposed and committed.

Comment 3 Mike Pagano gentoo-dev 2007-11-23 18:23:41 UTC
Please reopen this bug if a patch that fixes this get accepted upstream. We will then attempt to backport the patch to older kernels that we still support at that time.

http://dev.gentoo.org/~dsd/genpatches/faq.htm
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2007-11-25 19:51:10 UTC
Mike: have you confirmed that upstream has everything under control and doesn't need our help? Unless upstream tell us to go away, we should pester them and offer resources -- namely Andreas who would hopefully test candidate patches should they appear. We shouldn't close this unless there is nothing we can do.
Comment 5 Mike Pagano gentoo-dev 2007-11-26 01:35:02 UTC
If you have the time, read the thread from the original description. The discussion seems to have lost some steam and stopped.

If you think after reading there is more that we can do, we can reopen this.
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2007-11-26 21:46:24 UTC
we can at least attempt to breathe some life back into the issue
Comment 7 AE 2007-12-16 00:58:40 UTC
The problem has been brought to the attention of the master himself, and with any look above patch will get included soon (preliminarily at least):

http://lkml.org/lkml/2007/12/6/368
Comment 8 AE 2007-12-16 00:59:16 UTC
Luck, not look, of course.
Comment 9 AE 2008-01-26 21:26:42 UTC
For the record: The fix is in mm-sources and might make it into 2.6.25:
http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.24-rc6/2.6.24-rc6-mm1/broken-out/pci-disable-decoding-during-sizing-of-bars.patch

The only thing that troubles me is that my name is on the top of the page (they took it from this bug), while the patch is by Matthew Wilcox...
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2008-01-26 22:04:46 UTC
thanks for the update and your efforts, I just sent an email asking Andrew to correct that.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2008-02-12 16:53:04 UTC
Created attachment 143323 [details, diff]
new patch

Rumour has it that this patch solves the issue, and it's already upstream. Please could you apply it (*instead* of any others) to 2.6.24 and let us know what happens?
Comment 12 AE 2008-02-16 21:29:08 UTC
Daniel, the patch works well here.
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2008-02-16 21:57:39 UTC
Great, thanks for testing. Queued this up for next 2.6.24 release.
Not going to backport to 2.6.23 because the code the patch touches on has changed too much.
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2008-02-26 17:10:46 UTC
Fixed in genpatches-2.6.24-4 (gentoo-sources-2.6.24-r3), thanks for testing