Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 198162 - www-client/opera-9.5* - plugin issues
Summary: www-client/opera-9.5* - plugin issues
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jeroen Roovers
URL: http://my.opera.com/desktopteam/blog/...
Whiteboard:
Keywords:
: 217794 221025 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-05 14:12 UTC by Francois Chenier
Modified: 2009-05-25 02:04 UTC (History)
17 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,2.80 KB, text/plain)
2007-11-05 14:13 UTC, Francois Chenier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francois Chenier 2007-11-05 14:12:18 UTC
The problem could be on either of both packages but net-www/netscape-flash-9.0.60 plug-in is not working at all in opera-9.50. Most of the time, the flash animation area appears blank.

Packages affected:

   net-www/netscape-flash-9.0.60.0_beta100107
   www-client/opera-9.50 (all versions)

Reproducible : Always (go to www.adobe.com for example)

Reverting back to netscape-flash-9.0.48.0-r1 fix the problem. May be revelant or not but I'm running KDE-3.5.8 (was also there with 3.5.7).
Comment 1 Francois Chenier 2007-11-05 14:13:58 UTC
Created attachment 135248 [details]
emerge --info
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-11-05 16:13:25 UTC

*** This bug has been marked as a duplicate of bug 127200 ***
Comment 3 Jeroen Roovers gentoo-dev 2007-11-05 16:32:02 UTC
It's not exactly the same bug. The net-www/netscape-flash-9.6* betas have far worse problems when used with the www-client/opera-9.50* betas than for instance Youtube videos not displaying - on one system it's impossible to play Flash games but Youtube works fine (even though it still crashes Opera after at most a few minutes).

Opera has promised to resolve these issues when 9.50 goes final and according to the URL, the problems have got worse going from beta1 to beta2.
Comment 4 Andreas Arens 2007-11-05 20:35:20 UTC
Please check for stale oss or libs. Removing those fixed the 9.0.60 flash problems for a friend of mine. He tested oss when it's source was released, and had the libs still lay around, but his later kernel only had alsa. opera did all wierd things, including crashes, when the flash plugin was loaded and tried to use those libs.
Comment 5 Jeroen Roovers gentoo-dev 2007-11-05 21:06:08 UTC
(In reply to comment #4)
> Please check for stale oss or libs.

That's entirely unrelated to this bug.
Comment 6 teidakankan 2007-11-06 04:41:23 UTC
Sorry I know we are talking about Opera here, but maybe there is just a general problem with this version of netscape-flash.  Wouldn't work for me with the latest version/release of Firefox and had to downgrade to net-www/netscape-flash-9.0.60.0_beta082207 to get it to work again.
Comment 7 Jeroen Roovers gentoo-dev 2007-11-06 05:03:04 UTC
(In reply to comment #6)
> Sorry I know we are talking about Opera here

Good. Go file another bug for Firefox then, please.
Comment 8 Jeroen Roovers gentoo-dev 2007-11-09 17:30:15 UTC
I added a warning to pkg_postinst() of all the opera-9.50_beta?.ebuilds referring to this bug. The "Known issues" section in the blog entry for build 1662 (called beta3 in the tree but still labeled as "9.50 Beta 2" in opera:about) says this:

   "Plugins on UNIX might be even more broken - big changes 
    coming up... (Do not bother filing plugin bugs on UNIX)"
Comment 9 Jeroen Roovers gentoo-dev 2008-04-15 16:51:34 UTC
*** Bug 217794 has been marked as a duplicate of this bug. ***
Comment 10 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-09 15:00:44 UTC
*** Bug 221025 has been marked as a duplicate of this bug. ***
Comment 11 Carsten Lohrke (RETIRED) gentoo-dev 2008-05-09 15:05:01 UTC
(In reply to comment #0)
> Reverting back to netscape-flash-9.0.48.0-r1 fix the problem.

As not mentioned here, I'd like to point out that this is _not_ a fix as you run a insecure system in this case. See also GLSA 200804-21.

One workaround is not to use Flash, the other is to use Firefox.
Comment 12 Johan 2008-05-11 20:46:25 UTC
i hope to resolved this problem and this plugin works on amd64 when the problem fix?
Comment 13 Tiago Marques 2008-05-13 16:04:32 UTC
well upgraded from beta1 to beta2 and flash stopped playing videos- with the 9.0.124 version.
Then I changed the plugin path, inserted /usr/lib/nsbrowser/plugins and removed /opt/netscape/plugins and all works fine now.
Strange cause with older versions of opera it was the opposite - using the path with the symlink would make videos not work.
Comment 14 Ilya Semenov 2008-06-10 07:48:01 UTC
The solution is actually very simple, you just go to Tools - Preferences - Advanced - Content - Plug-in Options - Change Path... - Disable /opt/netscape/plugins.

By default Opera searches both /opt/netscape/plugins AND /usr/lib/nsbrowser/plugins, which results in Netscape Flash plugin being included *twice*.

That fully fixed Flash on opera-9.50_beta2_p1997 and netscape-flash-9.0.115.0 (and 9.0.124, too).
Comment 15 Jeroen Roovers gentoo-dev 2008-06-10 09:48:35 UTC
(In reply to comment #14)
> The solution is actually very simple, you just go to Tools - Preferences -
> Advanced - Content - Plug-in Options - Change Path... - Disable
> /opt/netscape/plugins.

I tried to automate that (see below).

> By default Opera searches both /opt/netscape/plugins AND
> /usr/lib/nsbrowser/plugins, which results in Netscape Flash plugin being
> included *twice*.

But that's not the problem.

> That fully fixed Flash on opera-9.50_beta2_p1997 and netscape-flash-9.0.115.0
> (and 9.0.124, too).

In gentoo-x86/www-client/opera/files/opera-*pluginpath*.patch I tried to fix that, but it doesn't really work:

jeroen@epia ~ $ fgrep -a netscape/plugins $(qlist -eo opera) | strings
/opt/opera/lib/opera/9.50/opera:
12OpAutoVectorI20PluginCandidateEntryE
8OpVectorI20PluginCandidateEntryE
scanPaths
Misc
/opt/netscape/plugins
/usr/local/netscape/plugins
/usr/lib/netscape/plugins-libc6
8OpVectorI17PluginPathElementE
Opera Plugin Proxy: NP_Shutdown

In other words, even if we fix the file paths, the opera code still tries it.

Currently I can view Youtube videos fine without a need for extra workarounds like these. However, clicking on a "related" video inside a Flash frame doesn't work, so there's something wrong with Flash & Opera's JavaScript again. I've been seeing this since the 9.50_beta2_p2*'s I think.
Comment 16 Patrizio Bassi 2008-06-27 16:20:38 UTC
i still have problems with 7.50 release.
anyone could get flash working?

i just have big locking and timeouts
Comment 17 Christopher Head 2008-06-27 16:43:31 UTC
I second the above comment, for me it seems to work with the 9.50 release but often hangs for long periods of time.
Comment 18 Tiago Marques 2008-06-27 17:39:08 UTC
The hang thing is a flash problem. It started happening to me since I started using flash 9 versions. The flash 7 worked fine. 
Comment 19 Patrizio Bassi 2008-06-27 18:24:03 UTC
but konqueror and gecko based like firefox, seamonkey and epiphany work ok, so i think it's opera.

for me it started aftet 9.2x
Comment 20 7v5w7go9ub0o 2008-07-04 21:10:25 UTC
Success!  

Just upgraded Opera and flash and, typically, youtube didn't work; endless rotation of the "circle".

[ebuild   R   ] www-client/opera-9.51  USE="qt-static -gnome -ia32 -qt3-static -spell" LINGUAS="-be -bg -cs -da -de -el -en -en_GB -es_ES -es_LA -fi -fr -fr_CA -fy -hi -hr -hu -it -ja -ka -ko -lt -mk -nb -nl -nn -pl -pt -pt_BR -ru -sv -tr -zh_CN -zh_TW" 0 kB 
[ebuild   R   ] net-www/netscape-flash-10_beta20080702  0 kB

***Thanks to someone for noting this thread within the Opera Ebuild***!!

So out of desperation, I linked to this thread and applied Ilya Semenov's suggestion ( #14) - and now it works great!

Strongly suggest that Jeroen Roovers advise Opera of Ilya Semenov's (and my) experiences; Opera is going nuts trying to track this down!

Comment 21 Michael 2008-07-07 01:00:11 UTC
Add /usr/lib32/nsbrowser/plugins/ to my plugin paths (settings, advance, content, plugin settings) solved the problem for me with my amd_64 system, Opera 9.50 and 9.51
Comment 22 Jeroen Roovers gentoo-dev 2008-07-07 01:13:44 UTC
(In reply to comment #20)
> Strongly suggest that Jeroen Roovers advise Opera of Ilya Semenov's (and my)
> experiences; Opera is going nuts trying to track this down!

As explained already over and over, this isn't Gentoo's or Opera's problem, but Adobe's - libflashplayer.so doesn't like it when Opera uses a plugin in a path that contains "netscape":

ls -l /opt/netscape/plugins/libflashplayer.so /usr/lib/nsbrowser/plugins/libflashplayer.so
-rwxr-xr-x 1 root root 8115888 2008-04-27 20:35 /opt/netscape/plugins/libflashplayer.so
lrwxrwxrwx 1 root root      39 2008-04-27 20:36 /usr/lib/nsbrowser/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so

It's still quite plausible for Opera to be looking for plugins in /opt/netscape/plugins. If you want that particular issue to be fixed, talk to Adobe.
Comment 23 7v5w7go9ub0o 2008-07-07 02:07:46 UTC
"as explained already over and over, this isn't Gentoo's or Opera's problem, but
Adobe's - libflashplayer.so doesn't like it when Opera uses a plugin in a path
that contains "netscape":"


Yes...... I understand; you're talking about ascribing "fault".

I'm not talking about ascribing fault. In this case Gentoo users found some workarounds that got them going. I merely suggest that you contact Opera as a courtesy - not proclaiming a "fix", but simply a good will gesture from Gentoo that'll make life better for Opera and their frustrated users. 

Having you do it as a Gentoo Rep could have payback for Gentoo... Earning Gentoo good will, and perhaps some recognition and direct assistance from Opera in the future. 

If you do not want to do it on behalf of Gentoo, I'll be happy do it as an individual - by simply copying this dialogue (actually not the whole dialogue - simply the useful workarounds) and sending copies as FYIs to various Opera entities (e.g. user forums, helpdesk).  

Comment 24 Jeroen Roovers gentoo-dev 2008-07-07 02:24:55 UTC
No, it's not about blaming, it's about fixing the problem. Opera could work around it just like you can, but then Adobe would have even less incentive to fix what is essentially their problem.

Do go ahead and pressure Opera to pressure Adobe more - I certainly cannot do that.
Comment 25 Will B. 2008-07-11 02:52:52 UTC
Hi Jeroen, as a suggestion, if we can't get a workaround going with a Gentoo patch, can you at least add text to the ebuild output indicating this workaround?  Thanks.
Comment 26 Patrizio Bassi 2008-07-15 05:21:50 UTC
after remmoving the netscap path i could get a flash video loaded, but i could just hear the sound, the video windows was empty...

and this is quite clear...
(npviewer.bin:9960): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

but look much more an opera issue. because now that's not anymore the blocking delay of before and sounds works...

(npviewer.bin:9960): Gdk-WARNING **: GdkWindow 0x3e00003 unexpectedly destroyed
The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 20045 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


and more...

(npviewer.bin:13807): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(npviewer.bin:13807): Gdk-WARNING **: GdkWindow 0x3e00003 unexpectedly destroyed
The program 'npviewer.bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 713 error_code 3 request_code 18 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
*** NSPlugin Wrapper *** ERROR: NPP_New() invoke: Connection closed
Comment 27 Jeroen Roovers gentoo-dev 2008-07-15 05:30:27 UTC
(In reply to comment #26)
> and this is quite clear...
> (npviewer.bin:9960): Gdk-CRITICAL **: gdk_window_get_origin: assertion

Oh, so the problem lies with nspluginwrapper now? :)
Comment 28 Patrizio Bassi 2008-07-15 05:32:26 UTC
i don't think so....firefox and konqueror (gtk and qt app) load it perfectly.

and i can hear the music, so plugin is loaded and working..display is failing..
Comment 29 Pacho Ramos gentoo-dev 2008-07-15 16:04:19 UTC
I have set opera to only use plugins from /usr/lib32/nsbrowser/plugins letting their operapluginwrapper-ia32-linux make its work (even when sometimes it consumes too much CPU :-S) and flash works :-)
Comment 30 Patrizio Bassi 2008-07-15 17:02:19 UTC
you're right works for me too
Comment 31 Sinisa Denic 2008-08-15 17:59:39 UTC
(In reply to comment #30)
> you're right works for me too
> 
Hey guys I've got working Opera flashplayer I faund out that there is some issue when you add paths
I've included only two paths in plugin paths and I removed all others
It is working like charm.
I left /usr/lib32/nsbrowser/plugins and /usr/lib/mozilla/plugins and there is 9 plugins such real,win,flash, iTunes,divx.
I didn't play a lot and I suppose it's possible to add other plugins like quicktime.
Main thing ,I think, is that only one name of the same plugin may appear on the list.
Comment 32 Jeroen Roovers gentoo-dev 2008-09-06 15:20:50 UTC
http://my.opera.com/desktopteam/blog/2008/09/05/9-60-beta-1-rc says this:

  "UNIX: Additional fixes to flash plugin handling. Freezes when using flash
   should now be mostly gone."

about build 2415, which has landed in the Portage tree as www-client/opera-9.60_pre2415.
Comment 33 Patrizio Bassi 2008-09-10 16:07:38 UTC
fixed with 9.60 betas, you can close....
Comment 34 Jeroen Roovers gentoo-dev 2008-09-11 08:21:35 UTC
(In reply to comment #33)
> fixed with 9.60 betas, you can close....

Haha, sorry. No. I thought this bug would go away after a few versions too. :)
Comment 35 shade 2008-09-19 18:45:14 UTC
(In reply to comment #32)
> http://my.opera.com/desktopteam/blog/2008/09/05/9-60-beta-1-rc says this:
> 
>   "UNIX: Additional fixes to flash plugin handling. Freezes when using flash
>    should now be mostly gone."
> 
> about build 2415, which has landed in the Portage tree as
> www-client/opera-9.60_pre2415.
> 

isnt working, with 2430 tested with 10_rc20080915
Comment 36 Man Shankar 2008-10-05 15:46:56 UTC
(In reply to comment #34)
> (In reply to comment #33)
> > fixed with 9.60 betas, you can close....
> 
> Haha, sorry. No. I thought this bug would go away after a few versions too. :)
> 

Well seems to lockup with opera-9.60_pre2436 and a clean opera profile.
The version of flash is 9.0.124.0. I am on amd64 architecture.

As a workaround i symlinked all the plugins in one directory; deleted all lines in the ~/.opera/pluginpath.ini file and added the path to the directory i created.
The plugins i symlinked are :

gecko-mediaplayer-* -> /usr/lib64/nsbrowser/plugins/gecko-mediaplayer-*

libflashplayer.so -> /usr/lib32/nsbrowser/plugins/libflashplayer.so

nphelix.so -> /opt/RealPlayer/mozilla/nphelix.so
nphelix.xpt -> /opt/RealPlayer/mozilla/nphelix.xpt

nppdf.so -> /opt/Adobe/Reader8/Browser/intellinux/nppdf.so

nsdejavu.so -> /usr/lib64/nsbrowser/plugins/nsdejavu.so

After that opera seems to work like a charm.
Does this work for others ?
Comment 37 shade 2008-10-05 16:07:57 UTC
(In reply to comment #36)
> (In reply to comment #34)
> > (In reply to comment #33)
> > > fixed with 9.60 betas, you can close....
> > 
> > Haha, sorry. No. I thought this bug would go away after a few versions too. :)
> > 
> 
> Well seems to lockup with opera-9.60_pre2436 and a clean opera profile.
> The version of flash is 9.0.124.0. I am on amd64 architecture.
> 
> As a workaround i symlinked all the plugins in one directory; deleted all lines
> in the ~/.opera/pluginpath.ini file and added the path to the directory i
> created.
> The plugins i symlinked are :
> 
> gecko-mediaplayer-* -> /usr/lib64/nsbrowser/plugins/gecko-mediaplayer-*
> 
> libflashplayer.so -> /usr/lib32/nsbrowser/plugins/libflashplayer.so
> 
> nphelix.so -> /opt/RealPlayer/mozilla/nphelix.so
> nphelix.xpt -> /opt/RealPlayer/mozilla/nphelix.xpt
> 
> nppdf.so -> /opt/Adobe/Reader8/Browser/intellinux/nppdf.so
> 
> nsdejavu.so -> /usr/lib64/nsbrowser/plugins/nsdejavu.so
> 
> After that opera seems to work like a charm.
> Does this work for others ?
> 

Strange but i can confirm this workaround. But it need one thing more. Paths cant be removed from plugins.ini, they need to be set to =2 (disabled). Dunno whow but opera used somebackup conf or something and when i started it again it had old paths. So =2 will be better.
Comment 38 shade 2008-10-05 16:26:27 UTC
i tested it with flash 10_rc20080915 and  opera 9.60_pre2440.
Comment 39 Man Shankar 2008-10-05 16:32:29 UTC
(In reply to comment #37)

> Strange but i can confirm this workaround. But it need one thing more. Paths
> cant be removed from plugins.ini, they need to be set to =2 (disabled). Dunno
> whow but opera used somebackup conf or something and when i started it again it
> had old paths. So =2 will be better.
> 

sorry forgot to mention that, yes it is strange that the even after editing the file is not totally respected, i beleive the other lines are getting activated due to the different plugins that may be linking to the directories.

For me a value of =0 works fine and as does =2 but if it is not set manually then they are set to 1.
Comment 40 Sergey 'L29Ah' Alirzaev 2008-10-05 20:26:38 UTC
(In reply to comment #36)
> (In reply to comment #34)
> > (In reply to comment #33)
> > > fixed with 9.60 betas, you can close....
> > 
> > Haha, sorry. No. I thought this bug would go away after a few versions too. :)
> > 
> 
> Well seems to lockup with opera-9.60_pre2436 and a clean opera profile.
> The version of flash is 9.0.124.0. I am on amd64 architecture.
> 
> As a workaround i symlinked all the plugins in one directory; deleted all lines
> in the ~/.opera/pluginpath.ini file and added the path to the directory i
> created.
> The plugins i symlinked are :
> 
> gecko-mediaplayer-* -> /usr/lib64/nsbrowser/plugins/gecko-mediaplayer-*
> 
> libflashplayer.so -> /usr/lib32/nsbrowser/plugins/libflashplayer.so
> 
> nphelix.so -> /opt/RealPlayer/mozilla/nphelix.so
> nphelix.xpt -> /opt/RealPlayer/mozilla/nphelix.xpt
> 
> nppdf.so -> /opt/Adobe/Reader8/Browser/intellinux/nppdf.so
> 
> nsdejavu.so -> /usr/lib64/nsbrowser/plugins/nsdejavu.so
> 
> After that opera seems to work like a charm.
> Does this work for others ?
> 

Doesn't work. Opera screams 'WARNING: /usr/lib64/nsbrowser/plugins/libflashplayer.so: library type cannot be detected'.

file:
/usr/lib64/nsbrowser/plugins/libflashplayer.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

Opera 9.60_pre2440, flash 10_rc20080915
Comment 41 shade 2008-10-05 20:48:28 UTC
(In reply to comment #40)
> (In reply to comment #36)
> > (In reply to comment #34)
> > > (In reply to comment #33)
> > > > fixed with 9.60 betas, you can close....
> > > 
> > > Haha, sorry. No. I thought this bug would go away after a few versions too. :)
> > > 
> > 
> > Well seems to lockup with opera-9.60_pre2436 and a clean opera profile.
> > The version of flash is 9.0.124.0. I am on amd64 architecture.
> > 
> > As a workaround i symlinked all the plugins in one directory; deleted all lines
> > in the ~/.opera/pluginpath.ini file and added the path to the directory i
> > created.
> > The plugins i symlinked are :
> > 
> > gecko-mediaplayer-* -> /usr/lib64/nsbrowser/plugins/gecko-mediaplayer-*
> > 
> > libflashplayer.so -> /usr/lib32/nsbrowser/plugins/libflashplayer.so
> > 
> > nphelix.so -> /opt/RealPlayer/mozilla/nphelix.so
> > nphelix.xpt -> /opt/RealPlayer/mozilla/nphelix.xpt
> > 
> > nppdf.so -> /opt/Adobe/Reader8/Browser/intellinux/nppdf.so
> > 
> > nsdejavu.so -> /usr/lib64/nsbrowser/plugins/nsdejavu.so
> > 
> > After that opera seems to work like a charm.
> > Does this work for others ?
> > 
> 
> Doesn't work. Opera screams 'WARNING:
> /usr/lib64/nsbrowser/plugins/libflashplayer.so: library type cannot be
> detected'.
> 
> file:
> /usr/lib64/nsbrowser/plugins/libflashplayer.so: ELF 32-bit LSB shared object,
> Intel 80386, version 1 (SYSV), dynamically linked, stripped
> 
> Opera 9.60_pre2440, flash 10_rc20080915
> 

try looking for flash plugin in /usr/lib32/nsbrowser/plugins/libflashplayer.so not in lib64 directory. Duno how you did it but plugin is 32 bit and shout be linked to lib32 direcotry. Real place to look for plugin is /opt/netscape/plugins/libflashplayer.so
Comment 42 Sergey 'L29Ah' Alirzaev 2008-10-05 21:37:47 UTC
(In reply to comment #41)
> (In reply to comment #40)
> > (In reply to comment #36)
> > Doesn't work. Opera screams 'WARNING:
> > /usr/lib64/nsbrowser/plugins/libflashplayer.so: library type cannot be
> > detected'.
> > 
> > file:
> > /usr/lib64/nsbrowser/plugins/libflashplayer.so: ELF 32-bit LSB shared object,
> > Intel 80386, version 1 (SYSV), dynamically linked, stripped
> > 
> > Opera 9.60_pre2440, flash 10_rc20080915
> > 
> 
> try looking for flash plugin in /usr/lib32/nsbrowser/plugins/libflashplayer.so
> not in lib64 directory. Duno how you did it but plugin is 32 bit and shout be
> linked to lib32 direcotry. Real place to look for plugin is
> /opt/netscape/plugins/libflashplayer.so
> 

That's just a symlink to 32bit one, doesn't matter. Or does?
Comment 43 shade 2008-12-17 11:34:24 UTC
Since 64 bit flash is out problem with flashplugin goes away on amd64 and 64 bit java plugin should be in sun jre 1.6.0.12 as sun devs said in bug about 64 bit plugin. AMD64 users should drink a glass of wine in new year for that:)
Comment 44 Pacho Ramos gentoo-dev 2009-05-24 17:55:34 UTC
Are people still suffering this today with current stable? flashplayer seems to work ok for me now... 
Comment 45 Will B. 2009-05-25 00:37:32 UTC
Flash 10 has worked well for me for a while on amd64 with no multilib or 32bit.
Comment 46 Jeroen Roovers gentoo-dev 2009-05-25 02:04:19 UTC
/me pops the cork. :)