Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 19775 - avifile- fails with xfree4.3.0-r2 based libXft
Summary: avifile- fails with xfree4.3.0-r2 based libXft
Status: RESOLVED DUPLICATE of bug 1991
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
: 20120 (view as bug list)
Depends on:
Reported: 2003-04-22 10:15 UTC by Derk W te Bokkel
Modified: 2009-01-29 16:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Derk W te Bokkel 2003-04-22 10:15:56 UTC
trying to upgrade this file .. discoverd that it fails due to missing references in the library 
/usr/lib/libXft in the samples/misc section of the build. All the missing references are to Fc* 
based subroutines such as FcFontMatch, FcPatternPrint, etc. there are 38 of them. I suspect 
this is due to the change to the built in Xft library into Xfree4.3.0-r2 into which I had just 
Comment 1 Derk W te Bokkel 2003-04-22 11:10:24 UTC
adding the fix from: 
and changing it to : 
 online 140 change  
 emake || die  
 emake LDFLAGS=-lfontconfig || die  
works and it now compiles. 
this may not be an optimum fix but it does work ..  
is there then a problem with the fontconfig files in the source code refering to 
obsolete functions or is the libxft lib incomplete? 
Comment 2 Seth Chandler 2003-04-22 14:24:55 UTC
try rebuilding fontconfig...i.e. 
emerge fontconfig 
Comment 3 Derk W te Bokkel 2003-04-23 00:14:16 UTC
Nope still blows up at the same spot. 
still while in directory: ..../work/avifile0.7-0.7.34/samples/misc 
after 'mkdir .libs' 
there is one more g++ call for .libs/avibench benchmark.o (flags and cruft omitted) 
/usr/lib/ undefined reference to 'Fc..etc..etc.'  (38 lines here) 
ends with -- collect2: ld returned 1 exit status 
and make cleaning up as per normal error handling  
exit code is 2 ,line 140, src_compile  
Tried a .. 'source /etc/profile' 
that didn't help either .. I'll  try a few other things and report back later 
Comment 4 Derk W te Bokkel 2003-04-23 00:35:50 UTC
tried a full reboot .. just to make sure .. still no joy except with the work arround. 
Comment 5 Derk W te Bokkel 2003-04-23 20:52:04 UTC
okay here's the deal .. once I had the latest fontconfig -2.0 emerged I re-emerged xfree 
then avifile compiles properly .. so the order is important ..  
is there anyway portage can be used to force or suggest this kind of recompile ordering 
when it is needed? this type of problem must come-up more often .. there's got to be a 
way to fix or hint in the ebuilds that some things require recompiling before certain 
software will install correctly. 
Comment 6 Martin Holzer (RETIRED) gentoo-dev 2003-04-24 05:38:09 UTC

*** This bug has been marked as a duplicate of 1991 ***
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-04-28 14:39:46 UTC
*** Bug 20120 has been marked as a duplicate of this bug. ***