Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 197648 - x11-misc/googleearth - upstream screwed the digest once more
Summary: x11-misc/googleearth - upstream screwed the digest once more
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Stefan Schweizer (RETIRED)
Depends on:
Reported: 2007-10-31 15:42 UTC by Toby Murray
Modified: 2007-11-21 09:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Toby Murray 2007-10-31 15:42:06 UTC
When updating from googleearth 4 to wget "resumes" the download of GoogleEarthLinux.bin if you haven't deleted it from distfiles. Obviously this causes a checksum failure because it needs to re-download the whole file. The file name is the same so this is normal behavior for wget but portage needs to be smarter. Either delete GoogleEarthLinux.bin or rename it to include the version number.

Reproducible: Always

Steps to Reproduce:
1. Have an old version of googleearth installed
2. Attempt to update to the newest version
3. Watch the fireworks
Actual Results:  
wget attempts to resume the download of GoogleEarthLinux.bin which causes the file to become corrupted.

Expected Results:  
The file should be renamed or deleted so that wget gets the whole file from scratch.

System is amd64

Full emerge log:

$ sudo emerge -1 googleearth
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) x11-misc/googleearth- to /
>>> Resuming download...
>>> Downloading ''
           => `/usr/portage/distfiles/GoogleEarthLinux.bin'
Connecting to||:80... connected.
HTTP request sent, awaiting response... 206 Partial Content
Length: 23,042,785 (22M), 1,435,377 (1.4M) remaining [application/octet-stream]

100%[++++++++++++++++++++++++++++++++++++++++++++++++++++++++===>] 23,042,785     3.52M/s             

utime(/usr/portage/distfiles/GoogleEarthLinux.bin): Operation not permitted
10:28:00 (3.52 MB/s) - `/usr/portage/distfiles/GoogleEarthLinux.bin' saved [23042785/23042785]

 * checking ebuild checksums ;-) ...                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                           [ ok ]
 * checking GoogleEarthLinux.bin ;-) ...                                                         [ !! ]

!!! Digest verification failed:
!!! /usr/portage/distfiles/GoogleEarthLinux.bin
!!! Reason: Failed on RMD160 verification
!!! Got: e2c9a00f4c1400381a975743d006779455af04ad
!!! Expected: ddf1490dc5037de60a235263e3d9bfe17210c977
Comment 1 Toby Murray 2007-10-31 22:03:22 UTC
I don't think the summary change that just happened is accurate. I'm pretty sure this is a portage problem, not upstream. When I went back and re-ran the emerge command after I posted this bug, it apparently deleted the GoogleEarthLinux.bin file and downloaded a fresh copy from scratch. The problem is just that wget tried to append to the end of the existing file instead of downloading it from scratch. 

Note the +++++===> in the wget output.
THAT is the problem here.
Comment 2 Toby Murray 2007-10-31 22:10:38 UTC
To be clear, the existing GoogleEarthLinux.bin file was a complete download from the OLD version of google earth. So wget tried to append bytes from the NEW version onto the installer file from the OLD version.
Comment 3 Stefan Schweizer (RETIRED) gentoo-dev 2007-11-21 09:42:17 UTC
seems to be an old portage version problem.