Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 196926 - sys-libs/glibc-2.7 compile fails with gcc-4.2.2 for i486+ with USE=glibc-omitfp
Summary: sys-libs/glibc-2.7 compile fails with gcc-4.2.2 for i486+ with USE=glibc-omitfp
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL: http://sourceware.org/ml/libc-alpha/2...
Whiteboard:
Keywords:
: 198340 198638 198761 199182 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-10-24 13:49 UTC by Weedy
Modified: 2007-12-10 13:27 UTC (History)
35 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch file for the bug (memmove-macro-string.h.patch,652 bytes, patch)
2007-11-07 14:46 UTC, Nigel Elliott
Details | Diff
new ebuild with call to apply patch (glibc-2.7.ebuild,10.68 KB, text/plain)
2007-11-07 14:48 UTC, Nigel Elliott
Details
memmove-macro-string.h.patch as Weedy pasted in (memmove-macro-string.h.patch,582 bytes, patch)
2007-11-07 15:03 UTC, Claes Mogren
Details | Diff
build.log for glibc-2.7 (build.log.tar.bz2,85.69 KB, text/plain)
2007-11-11 10:20 UTC, Christian Burger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Weedy 2007-10-24 13:49:35 UTC
build dies with a binutils-2.18.50.0.2/glibc-2.6.1-r0/gcc-4.2.2 toolchain.

Reproducible: Always

Steps to Reproduce:
1. emerge -av sys-libs/glibc
2. grab some popcorn

Actual Results:  
i686-pc-linux-gnu-gcc ../sysdeps/i386/backtrace.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -march=pentium4 -pipe -Wstrict-prototypes -mpreferred-stack-boundary=2  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES -fno-omit-frame-pointer -fexceptions   -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DPIC -DSHARED      -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtrace.os -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtrace.os.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtrace.os
i686-pc-linux-gnu-gcc ../sysdeps/generic/elf/backtracesyms.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -march=pentium4 -pipe -Wstrict-prototypes -mpreferred-stack-boundary=2  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/i686-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DPIC -DSHARED      -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtracesyms.os -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtracesyms.os.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/backtracesyms.os
In file included from ../include/bits/string3.h:1,
                 from ../string/string.h:428,
                 from ../include/string.h:49,
                 from warning-nop.c:53:
../string/bits/string3.h:58: error: redefinition of ‘memmove’
../string/string.h:59: warning: ‘memset’ declared inline after being called
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.7/work/build-default-i686-pc-linux-gnu-nptl/debug/warning-nop.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.7/work/glibc-2.7/debug'
make[1]: *** [debug/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.7/work/glibc-2.7'
make: *** [all] Error 2
 *
 * ERROR: sys-libs/glibc-2.7 failed.
 * Call stack:
 *           ebuild.sh, line 1695:  Called dyn_compile
 *           ebuild.sh, line 1033:  Called qa_call 'src_compile'
 *           ebuild.sh, line   44:  Called src_compile
 *    glibc-2.7.ebuild, line  148:  Called eblit-run 'src_compile'
 *    glibc-2.7.ebuild, line  144:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  179:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  122:  Called die
 * The specific snippet of code:
 *              make PARALLELMFLAGS="${MAKEOPTS}" || die "make for ${ABI} failed"
 *  The die message:
 *   make for default failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.7/temp/build.log'.
 *



emerge --info
Portage 2.1.3.16 (default-linux/x86/2007.0, gcc-4.2.2, glibc-2.6.1-r0, 2.6.23-gentoo i686)
=================================================================
System uname: 2.6.23-gentoo i686 Intel(R) Pentium(R) 4 CPU 2.60GHz
Timestamp of tree: Unknown
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18.50.0.2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -Os -pipe -fweb -fforce-addr -fgcse-after-reload"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium4 -Os -pipe -fweb -fforce-addr -fgcse-after-reload"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gentoo http://gentoo.mirrors.tds.net/gentoo http://gentoo.seren.com/gentoo"
LANG="en_CA.utf8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--hash-style=gnu -Wl,--sort-common -s"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/berkano /usr/local/overlays/chewi-overlay /usr/local/overlays/java-overlay /usr/local/overlays/java-experimental /usr/local/overlays/enlightenment /usr/portage/local/layman/php-testing"
SYNC="rsync://gentoo.arcticnetwork.ca/gentoo-portage"
USE="X X509 aac acl acpi aiglx alsa aoss aotuv ass async audacious automount bash-completion berkdb bidi bitmap-fonts bzip2 cairo ccache cdparanoia cdr cjk cli color-console compress cpio cracklib crypt curl dbus dga dri dts dv dvd dvdnav dvdr dvdread edb enca encode flac fortran gdbm ghcbootstrap gif glibc-omitfp glitz gpm gtk gtk2 hal hddtemp iconv imlib ipv6 isdnlog jpeg jpeg2k lame libwww lm_sensors logrotate logwatch lzo mad midi mmx modplug motif mp3 mp4 mpeg mplayer msn mudflap multislot multiuser musepack ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pam_chroot pam_console pam_timestamp pcre pdf perl pmu png pppd python rar readline reflection rtc sasl session spell spl sse sse2 ssl startup-notification svg sysfs syslog tcpd threads tiff truetype truetype-fonts type1-fonts unicode utempter uuencode vim vim-syntax vorbis win32codecs wma x264 x86 xgetdefault xml xorg xpm xscreensaver xv xvid zip zlib" ALSA_CARDS="ice1724" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vesa radeon mga"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2007-10-25 01:37:51 UTC
http://permalink.gmane.org/gmane.comp.lib.glibc.alpha/12878
Comment 2 Weedy 2007-10-28 19:01:22 UTC
works for me.

diff -urN /usr/portage/sys-libs/glibc/files/memmove-macro-string.h.patch /usr/local/portage/sys-libs/glibc/files/memmove-macro-string.h.patch
--- /usr/portage/sys-libs/glibc/files/memmove-macro-string.h.patch      1969-12-31 19:00:00.000000000 -0500
+++ /usr/local/portage/sys-libs/glibc/files/memmove-macro-string.h.patch        2007-10-25 01:12:07.000000000 -0400
@@ -0,0 +1,17 @@
+--- glibc-2.7/sysdeps/i386/i486/bits/string.h.orig     2007-10-25 00:50:29.000000000 -0400
++++ glibc-2.7/sysdeps/i386/i486/bits/string.h  2007-10-25 00:51:49.000000000 -0400
+@@ -143,10 +143,13 @@
+
+ #define _HAVE_STRING_ARCH_memmove 1
+ #ifndef _FORCE_INLINES
++#define memmove(dest, src, n) \
++  __memmove_g ((dest), (src), (n))
++
+ /* Copy N bytes of SRC to DEST, guaranteeing
+    correct behavior for overlapping strings.  */
+ __STRING_INLINE void *
+-memmove (void *__dest, __const void *__src, size_t __n)
++__memmove_g (void *__dest, __const void *__src, size_t __n)
+ {
+   register unsigned long int __d0, __d1, __d2;
+   register void *__tmp = __dest;
diff -urN /usr/portage/sys-libs/glibc/glibc-2.7.ebuild /usr/local/portage/sys-libs/glibc/glibc-2.7.ebuild
--- /usr/portage/sys-libs/glibc/glibc-2.7.ebuild        2007-10-24 02:36:53.000000000 -0400
+++ /usr/local/portage/sys-libs/glibc/glibc-2.7.ebuild  2007-10-25 01:10:21.000000000 -0400
@@ -144,7 +144,8 @@
        eblit-${PN}-$1 || die
 }

-src_unpack()  { eblit-run src_unpack  ; }
+src_unpack()  { eblit-run src_unpack  ;
+epatch ${FILESDIR}/memmove-macro-string.h.patch ; }
 src_compile() { eblit-run src_compile ; }
 src_test()    { eblit-run src_test    ; }
 src_install() { eblit-run src_install ; }
Comment 3 Hanno Boeck gentoo-dev 2007-11-07 14:40:57 UTC
*** Bug 198340 has been marked as a duplicate of this bug. ***
Comment 4 Nigel Elliott 2007-11-07 14:46:01 UTC
Created attachment 135425 [details, diff]
Patch file for the bug
Comment 5 Nigel Elliott 2007-11-07 14:48:57 UTC
Created attachment 135427 [details]
new ebuild with call to apply patch

Potentially this patch would be applied the same way as all the other patches. This method is applying the patch outside of the normal mechanism.
Comment 6 Claes Mogren 2007-11-07 15:03:13 UTC
Created attachment 135428 [details, diff]
memmove-macro-string.h.patch as Weedy pasted in

Put it directly in the glibc/files/ folder
Comment 7 Claes Mogren 2007-11-07 15:04:54 UTC
Oups, sorry everyone. Waited for the build to complete and didn't refresh the page. 

(In reply to comment #6)
> Created an attachment (id=135428) [edit]
> memmove-macro-string.h.patch as Weedy pasted in
> 
> Put it directly in the glibc/files/ folder
> 

Comment 8 Alexey Shvetsov gentoo-dev 2007-11-07 15:20:32 UTC
I have the same problem on x86 and x86_64 systems
Comment 9 Pierrot Rey 2007-11-08 03:51:07 UTC
(In reply to comment #8)
> I have the same problem on x86 and x86_64 systems
> 

My too, but with the patch it's good, thanks.
Comment 10 Vladimir Kirillov 2007-11-08 14:03:34 UTC
> (In reply to comment #8)
> > I have the same problem on x86 and x86_64 systems


same for me
Comment 11 Patrizio Bassi 2007-11-08 18:27:14 UTC
i think it's useless i say same for me on amd64 :)
Comment 12 Matt 2007-11-09 10:44:03 UTC
if it works - could you guys please push this into the portage-tree ?

many thanks in advance
Comment 13 Sandro Bonazzola 2007-11-09 19:49:21 UTC
Is there any particular reason for not masking glibc-2.7 until it compile or the patch proves to work fine?
Fails also for me on ~amd64.
Comment 14 SpanKY gentoo-dev 2007-11-09 20:01:24 UTC
people who have USE=glibc-omitfp are not considered a priority by any means

masking glibc-2.7 for ricers is not an option
Comment 15 Mart Raudsepp gentoo-dev 2007-11-09 23:12:50 UTC
Nothing with glibc-omitfp suggests that it is for ricers. Could you please come up with a valid reason, such as the patch that is already provided is not correct, so that it can be looked at?
Comment 16 Ryan Hill (RETIRED) gentoo-dev 2007-11-10 01:28:39 UTC
what happened to "if it's in ./configure, then it's valid and should be fixed or punted completely".  could you drop the USE flag until someone upstream can be bothered to get off their asses and look at it?

and c'mon.  could you give just a moment of consideration before you drop known-broken shit on people?  i know you're beyond caring but some of us have to answer for it.
Comment 17 SpanKY gentoo-dev 2007-11-10 04:08:00 UTC
i didnt say it wasnt supported, i said it isnt a priority ... see the difference ?
Comment 18 Patrizio Bassi 2007-11-10 08:48:31 UTC
this makes no sense.
if an USE flag is there it should work.
it makes no sense to say it's a risky flag. if it's risky why it's in the ebuild? deactivate it or force it disabled.
Comment 19 Jakub Moc (RETIRED) gentoo-dev 2007-11-10 10:38:53 UTC
*** Bug 198638 has been marked as a duplicate of this bug. ***
Comment 20 adriancz 2007-11-10 12:11:55 UTC
(In reply to comment #18)
> this makes no sense.
> if an USE flag is there it should work.
> it makes no sense to say it's a risky flag. if it's risky why it's in the
> ebuild? deactivate it or force it disabled.
> 

Or apply proper patch.

Comment 21 Jakub Moc (RETIRED) gentoo-dev 2007-11-11 08:29:52 UTC
*** Bug 198761 has been marked as a duplicate of this bug. ***
Comment 22 Christian Burger 2007-11-11 10:20:01 UTC
Created attachment 135721 [details]
build.log for glibc-2.7

Not fixed yet, please see below results after running:

emerge linux-headers glibc binutils-config binutils gcc-config gcc && emerge glibc binutils gcc && emerge system -e && emerge world -e  

x86_64-pc-linux-gnu-gcc stack_chk_fail.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h        -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail.o -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail.o.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail.o
x86_64-pc-linux-gnu-gcc fortify_fail.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h        -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/fortify_fail.o -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/fortify_fail.o.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/fortify_fail.o
x86_64-pc-linux-gnu-gcc warning-nop.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h        -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/warning-nop.o -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/warning-nop.o.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/warning-nop.o
x86_64-pc-linux-gnu-gcc stack_chk_fail_local.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h        -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail_local.o -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail_local.o.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/stack_chk_fail_local.o
x86_64-pc-linux-gnu-gcc ../sysdeps/i386/backtrace.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES -fno-omit-frame-pointer -fexceptions   -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DPIC -DSHARED      -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtrace.os -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtrace.os.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtrace.os
x86_64-pc-linux-gnu-gcc ../sysdeps/generic/elf/backtracesyms.c -c -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -fno-strict-aliasing -Wstrict-prototypes -mpreferred-stack-boundary=2  -fPIC -g0 -O99 -fomit-frame-pointer -D__USE_STRING_INLINES    -I../include -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug -I/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl -I../sysdeps/i386/elf -I../nptl/sysdeps/unix/sysv/linux/i386/i686 -I../nptl/sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux/i386 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../ports/sysdeps/unix/sysv/linux -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../ports/sysdeps/unix/sysv/i386 -I../sysdeps/unix/sysv/i386 -I../nptl/sysdeps/unix/sysv -I../ports/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../nptl/sysdeps/unix -I../ports/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../nptl/sysdeps/i386/i686 -I../sysdeps/i386/i686 -I../sysdeps/i386/i486 -I../nptl/sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../nptl/sysdeps/i386 -I../sysdeps/i386 -I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl -I../ports  -I.. -I../libio -I. -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/4.2.2/include-fixed -isystem /usr/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h  -DPIC -DSHARED      -o /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtracesyms.os -MD -MP -MF /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtracesyms.os.dt -MT /var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/backtracesyms.os
In file included from ../include/bits/string3.h:1,
                 from ../string/string.h:428,
                 from ../include/string.h:49,
                 from warning-nop.c:53:
../string/bits/string3.h:58: error: redefinition of 'memmove'
../string/string.h:59: warning: 'memset' declared inline after being called
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.7/work/build-x86-x86_64-pc-linux-gnu-nptl/debug/warning-nop.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.7/work/glibc-2.7/debug'
make[1]: *** [debug/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.7/work/glibc-2.7'
make: *** [all] Error 2
 *
 * ERROR: sys-libs/glibc-2.7 failed.
 * Call stack:
 *           ebuild.sh, line 1701:  Called dyn_compile
 *           ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *           ebuild.sh, line   44:  Called src_compile
 *    glibc-2.7.ebuild, line  148:  Called eblit-run 'src_compile'
 *    glibc-2.7.ebuild, line  144:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  168:  Called src_compile
 *    glibc-2.7.ebuild, line  148:  Called eblit-run 'src_compile'
 *    glibc-2.7.ebuild, line  144:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  179:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  122:  Called die
 * The specific snippet of code:
 *              make PARALLELMFLAGS="${MAKEOPTS}" || die "make for ${ABI} failed"
 *  The die message:
 *   make for x86 failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.7/temp/build.log'.
 *

 * Messages for package sys-devel/gcc-4.2.2:

 * If you have issues with packages unable to locate libstdc++.la,
 * then try running 'fix_libtool_files.sh' on the old gcc versions.

 * Messages for package sys-libs/glibc-2.7:

 *
 * ERROR: sys-libs/glibc-2.7 failed.
 * Call stack:
 *           ebuild.sh, line 1701:  Called dyn_compile
 *           ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *           ebuild.sh, line   44:  Called src_compile
 *    glibc-2.7.ebuild, line  148:  Called eblit-run 'src_compile'
 *    glibc-2.7.ebuild, line  144:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  168:  Called src_compile
 *    glibc-2.7.ebuild, line  148:  Called eblit-run 'src_compile'
 *    glibc-2.7.ebuild, line  144:  Called eblit-glibc-src_compile
 *   src_compile.eblit, line  179:  Called toolchain-glibc_src_compile
 *   src_compile.eblit, line  122:  Called die
 * The specific snippet of code:
 *              make PARALLELMFLAGS="${MAKEOPTS}" || die "make for ${ABI} failed"
 *  The die message:
 *   make for x86 failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.7/temp/build.log'.
 *
 * Regenerating GNU info directory index...
 * Processed 12 info files.
Comment 23 Jakub Moc (RETIRED) gentoo-dev 2007-11-11 10:21:41 UTC
(In reply to comment #22)
> Not fixed yet, please see below results after running:

We know that it's not fixed, that's why this bug is still open. No need to post more logs here either.
Comment 24 neomagus00 2007-11-12 16:17:21 UTC
Same error, patch works for me on amd64.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2007-11-14 21:42:42 UTC
*** Bug 199182 has been marked as a duplicate of this bug. ***
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2007-11-14 21:44:25 UTC
Is it so damn hard to remove the flag while it's broken, or why exactly do we need to be flooded by these pointless bugs?!
Comment 27 SpanKY gentoo-dev 2007-11-14 22:25:34 UTC
go away
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2007-11-14 22:28:29 UTC
Very helpful... you love to waste other people's time, don't you?
Comment 29 Patrizio Bassi 2007-11-15 09:19:53 UTC
come on, we don't want flames, just fix issues.
Comment 30 Jesco Freund 2007-11-15 17:48:11 UTC
(In reply to comment #26)
> Is it so damn hard to remove the flag while it's broken, or why exactly do we
> need to be flooded by these pointless bugs?!
> 

Jakub, if this is really your attitude, then I'm sorry but I will stop installing ebuilds from testing and reporting bugs to help stabilizing them. And btw., the error messages/logs in this case did not point towards some stupid compiler flag; so I missed this bug here (btw. I have neither gcc-4.2.2 nor a 486 *narf*).
Comment 31 Jakub Moc (RETIRED) gentoo-dev 2007-11-15 17:52:44 UTC
(In reply to comment #30)
You apparently missed the context and point of Comment #26... 

Back to the issue here, the use flag is masked now.
Comment 32 Chris Gianelloni (RETIRED) gentoo-dev 2007-11-16 00:37:43 UTC
(In reply to comment #30)
> (In reply to comment #26)
> > Is it so damn hard to remove the flag while it's broken, or why exactly do we
> > need to be flooded by these pointless bugs?!
> > 
> 
> Jakub, if this is really your attitude, then I'm sorry but I will stop
> installing ebuilds from testing and reporting bugs to help stabilizing them.

Please, please don't let Jakub run you off!  We need people like you who are helping improve the quality of Gentoo.  Your contributions are very important to us.  Thank you for your work.
Comment 33 Ryan Hill (RETIRED) gentoo-dev 2007-11-16 03:51:11 UTC
um, he's not CC'd.  in any case please keep the chatter relevant to the bug.  i've already mailed him privately.  thanks.
Comment 34 David Parrott 2007-11-16 19:30:26 UTC
why would we mask a (non-default and package-specific) use flag when the problem is solved w/ a patch that was already posted w/ working ebuild 2 weeks ago?

Why wasn't the patch used instead of masking?
Comment 35 André Terpstra 2007-11-16 20:21:44 UTC
(In reply to comment #34)
> why would we mask a (non-default and package-specific) use flag when the
> problem is solved w/ a patch that was already posted w/ working ebuild 2 weeks
> ago?
> Why wasn't the patch used instead of masking?

Exactly the same question puzzles me...
Comment 36 Ryan Hill (RETIRED) gentoo-dev 2007-11-17 00:11:02 UTC
It's not certain the patch is the correct fix, and applying incorrect fixes to something such as glibc can be a bad thing.
Comment 37 Andrzej Zaborowski 2007-11-17 00:17:19 UTC
(In reply to comment #36)

Which part of it looks uncertain?  Basically if you're saying a patch is wrong, propose a better one or a hint as to what should be corrected in it.
Comment 38 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-11-17 01:00:19 UTC
If you *really* want to know why I decided to go with a mask of the useflag rather than leaving it as it was or applying the patch, you might want to look at my post on http://farragut.flameeyes.is-a-geek.org/articles/2007/11/17/users-are-just-never-happy .

Be warned: if you complained here for the masking, I have no good words for you, so don't take it on me if you find I did bash you on the post. For a cryptic summary I can tell you that the world is not 1 bit depth.
Comment 39 André Terpstra 2007-11-17 07:55:04 UTC
(In reply to comment #38)
> If you *really* want to know why I decided to go with a mask of the useflag
> rather than leaving it as it was or applying the patch, you might want to look
> at my post on
> http://farragut.flameeyes.is-a-geek.org/articles/2007/11/17/users-are-just-never-happy
> .
> Be warned: if you complained here for the masking, I have no good words for
> you, so don't take it on me if you find I did bash you on the post. For a
> cryptic summary I can tell you that the world is not 1 bit depth.

OK I'm fully OK with this. The reasoning behind this move just wasn't clear from the bug report. Next time I personally would prefer a little more explanation (instead of internal Gentoo discussions). Keep up the good work!
Comment 40 Kliakhandler Kosta 2007-11-17 11:23:24 UTC
I'd like to note that I'm also affected by this bug but do not use the mentioned USE flag.
Comment 41 Alois Hammer 2007-11-21 01:35:25 UTC
The above ebuild and patch work for me.

I'd just like to add one thing: according to http://gentoo-wiki.com/Safe_Cflags#Pentium_III, -fomit-frame-pointer is a "safe" optimization.  If it's not, the wiki really ought to be updated.  (My present CFLAGS are set to precisely the recommendations on the wiki.)
Comment 42 Mat Ferry 2007-12-01 22:39:14 UTC
The patch is not working for me on my i586-pc-linux-gnu-4.2.2
The error is the same as before
Please find my build.log.gz at

http://rafb.net/p/ZvxuXG59.html
Comment 43 SpanKY gentoo-dev 2007-12-02 05:33:02 UTC
never ever post a link to rafb.net or a similar paste site into the Gentoo bugzilla ... it will simply expire and be a useless/dead link
Comment 44 SpanKY gentoo-dev 2007-12-10 01:13:36 UTC
fixed in glibc-2.7-r1
Comment 46 Weedy 2007-12-10 03:20:43 UTC
unblacklist the useflag please
Comment 47 Csaba Tóth 2007-12-10 03:59:06 UTC
u can uncomment it here: nano /usr/portage/profiles/default-linux/amd64/package.use.mask
Comment 48 Leonid Podolny 2007-12-10 12:47:59 UTC
(In reply to comment #44)
> fixed in glibc-2.7-r1
> 

So, what about a flag? It's still masked.
Comment 49 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-10 13:27:58 UTC
No it's not. Please check before complaining next time.