Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 195455 - dev-perl/gtk2-perl-1.145 fails compiling
Summary: dev-perl/gtk2-perl-1.145 fails compiling
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2007-10-11 04:19 UTC by Rumen Yotov
Modified: 2007-10-11 10:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rumen Yotov 2007-10-11 04:19:22 UTC

dev-perl/gtk2-perl-1.145 fails for me.
error log:
 * Using ExtUtils::MakeMaker
Can't locate in @INC (@INC contains: /etc/perl /usr/lib/perl5/vendor_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/local/lib/site_perl .) at (eval 12) line 1.
BEGIN failed--compilation aborted at (eval 12) line 1.

Checking if your kit is complete...
Looks good
MakeMaker FATAL: prerequisites not found (Glib not installed)

               Please install these modules first and rerun 'perl Makefile.PL'.
Tried at least twice.
Will try recompiling glib ...
Thanks. Rumen

Reproducible: Always
Comment 1 Rumen Yotov 2007-10-11 04:26:05 UTC

Just saw that the config looks in:/usr/local/lib/site_perl which don't exists.
All packages are installed by portage, no custom paths.
Will recompile 'perl' too.
perl-5.8.8-r2 USE=berkdb -build -debug -doc gdbm ithreads -perlsuid
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-10-11 07:48:03 UTC
recompile dev-perl/glib-perl and try again. Also, emerge --info please.
Comment 3 Rumen Yotov 2007-10-11 10:01:51 UTC

Rebuild glib-perl-1.144, then received the same error about (gtk2-perl).
Rebuild dev-perl/Cairo-1.04.1 too.
gtk2-perl compiles OK now.
As i'm using paludis, could i use it's configuration ?
Closing the Bug.
Thanks. Rumen
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-10-11 10:05:23 UTC
Well, my guess is that you either didn't run perl-cleaner after upgrading perl, or perl-cleaner doesn't work w/ paludis.
Comment 5 Rumen Yotov 2007-10-11 10:13:40 UTC

Surely run perl-cleaner with perl-5.8.8-*, as i had some issues (w/ perl) not long ago.
It certainly has problems with paludis, as it invokes emerge to do it's job, after identifying the needed packages.
Thanks again. Rumen