Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 194137 - new ebuild: media-gfx/gimp-lqr-plugin (content-aware aka liquid resizing)
Summary: new ebuild: media-gfx/gimp-lqr-plugin (content-aware aka liquid resizing)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL: http://liquidrescale.wikidot.com/
Whiteboard: sunrise-overlay
Keywords: EBUILD, InOverlay
: 194458 (view as bug list)
Depends on: 203143
Blocks:
  Show dependency tree
 
Reported: 2007-09-28 20:12 UTC by Paweł Hajdan, Jr. (RETIRED)
Modified: 2010-11-10 21:07 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gimp-lqr-plugin-0.2.1.ebuild (gimp-lqr-plugin-0.2.1.ebuild,584 bytes, text/plain)
2007-09-28 20:13 UTC, Paweł Hajdan, Jr. (RETIRED)
Details
media-gfx/gimp-lqr-plugin-0.3.0-r5.ebuild (gimp-lqr-plugin-0.3.0-r5.ebuild,524 bytes, text/plain)
2007-12-23 14:09 UTC, Piotr Szymaniak
Details
gimp-lqr-plugin-0.4.0_p4.ebuild (gimp-lqr-plugin-0.4.0_p4.ebuild,829 bytes, text/plain)
2008-02-10 04:38 UTC, David Leverton
Details
liblqr-0.1.0_p1.ebuild (liblqr-0.1.0_p1.ebuild,790 bytes, text/plain)
2008-02-10 04:40 UTC, David Leverton
Details
gimp-lqr-plugin-0.5.0.ebuild (gimp-lqr-plugin-0.5.0.ebuild,565 bytes, text/plain)
2008-10-21 08:18 UTC, Piotr Szymaniak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2007-09-28 20:12:30 UTC
This might be an interesting plugin for gimp to have, and contnt-aware resizing is definitely attractive thing, especially it's quite new and hyped.
Comment 1 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2007-09-28 20:13:18 UTC
Created attachment 132124 [details]
gimp-lqr-plugin-0.2.1.ebuild
Comment 2 Shaun Cloherty 2007-09-29 06:09:48 UTC
The attached ebuild worked well for me on x86. After adding the ~x86 keyword of course...
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-10-02 06:45:09 UTC
*** Bug 194458 has been marked as a duplicate of this bug. ***
Comment 4 Ian 2007-10-02 12:12:13 UTC
can someone update the summary of this bug?  the title of the project page (at http://liquidrescale.wikidot.com/ is "Liquid Rescale GIMP plugin" but searching for that on bugzilla doesn't find this bug.  

to prevent further duplicates, i would change the summary to: 

new ebuild: media-gfx/gimp-lqr-plugin (content-aware aka liquid resizing aka liquid rescale) GIMP plugin
Comment 5 Piotr Szymaniak 2007-12-23 14:09:20 UTC
Created attachment 139179 [details]
media-gfx/gimp-lqr-plugin-0.3.0-r5.ebuild

Version bump.
Comment 6 David Leverton 2008-02-10 04:38:27 UTC
Created attachment 143082 [details]
gimp-lqr-plugin-0.4.0_p4.ebuild

Version bump (BTW, I think media-plugins is a more appropriate category than media-gfx).
Comment 7 David Leverton 2008-02-10 04:40:02 UTC
Created attachment 143083 [details]
liblqr-0.1.0_p1.ebuild

The library that the new version depends on, I suggest media-libs.  This ebuild doesn't currently install the documentation or examples, it wasn't quite obvious how to handle those.
Comment 8 Piotr Szymaniak 2008-10-21 08:18:43 UTC
Created attachment 169260 [details]
gimp-lqr-plugin-0.5.0.ebuild

Version bump, included (as always) in roslin uberlay. (;

Also, this bug should depend on bug #203143.
Comment 9 Piotr Szymaniak 2009-04-09 20:08:43 UTC
This is now in the sunrise overlay. You can find it at:
http://overlays.gentoo.org/svn/proj/sunrise/reviewed/media-gfx/gimp-lqr-plugin/
Comment 10 niogic 2010-10-27 16:04:51 UTC
Still not mature enough for main tree?
Comment 11 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2010-11-10 21:07:14 UTC
(In reply to comment #10)
> Still not mature enough for main tree?

I finally added it. :)